3 Replies Latest reply: Aug 20, 2013 4:04 PM by dg3274
GeorgeD16 Level 1 (0 points)

Is there a message size limitation on the built-in mail app?

We are unable to fwd emails with attachments larger than about 7MB. We recently upgraded our devices to IOS6.

Our exchange server is setup to allow 40MB attachments.

A third party activesync/mail app is able to fwd the email message without issue from the same device.

iPhone 4S, iOS 6
  • vmanning Level 1 (0 points)

    Having similar issues here. Nothing larger than a 7.7 MB email went through when using ActiveSync or MDM, tried on both WiFi and 4G.


    Success: Created a 9.9 MB msg and sent from my Gmail account

    Fail:        Forwarding that msg with MDM account

    Success: Forwarding that msg with Gmail account

  • charon79m Level 1 (0 points)

    I have discovered the same thing.


    I've tested this on 4 different iOS devices on iOS version 6.0.1 and 6.1.2.  I've connected to three different Exchange servers (two 2010 and one 2007) all with message send limits set to 10MB or greater. 


    When sending from iOS the messages fail to send.


    When we connect from any other mobile platform, they send without issue.


    I would very much like to know if anyone else is experiencing this issue.  I've submitted a bug report to Apple.

  • dg3274 Level 1 (0 points)

    There is one more "limit" setting in Exchange that you might want to check:



    And incase that link ever goes down, here is what it says:


    You may see the following error for an Activesync device.  In this case it was an iPhone:

    An exception occurred and was handled by Exchange ActiveSync. This may have been caused by an outdated or corrupted Exchange ActiveSync device partnership.
    Exception message: Maximum request length exceeded.

    This will repeat over and over again as the iphone syncs.  Ask the user to check the outbox of the phone for a stuck message which possibly has an attachment.  You will find that any messages larger than 10MB by default are rejected by activesync but the iPhone will continue to try and send it until the message is manually removed from the outbox of the phone.

    If you need to increase the max message size (not attachment size in this case as it is the message as a whole which is being rejected) perform the following:

    1. On the CAS server under the install directory go to ClientAccess\Sync folder
    2. Open the web.config file
    3. Find the <httpRuntime maxRequestLength=”10240″/> entry
    4. Up the value to the KB value you want (bear in mind phone data costs!)
    5. Save the file
    6. Restart IIS