Previous 1 2 3 4 Next 51 Replies Latest reply: Sep 18, 2015 12:18 PM by andhavarapufromsunnyvale Go to original post
  • NatanTeam Level 1 (0 points)

    Last days I finally realized that the wi-fi always reconnects and is ready to use after unlock the device. The cases when it was disconnected was when I had walked out of the wireless coverage, and when I got back, the iphone5 just took a while (like 10-20 sec) to reconnect again. That was only it! So, I indeed discovered that when I stay under wi-fi coverage, iphone5 always is readily connected after unlock the screen. I've tested/checked it many times ever since ; )

  • Micheal001 Level 1 (0 points)

    and when you lock the screen wifi lost , this is not a perment solution .

  • geomac91 Level 1 (0 points)

    this helped me:

     

    http://helpios7.com/fix-wifi-connection-issue-ios-7/

     

     

    I have Iphone5 & ios7

  • geomac91 Level 1 (0 points)

    Sorry , in a previous post I put a solution that finally did not worked.

     

    But now I think I found the solution, as you'll seee below.

    At work, my phone (iphone5 with ios7) was keeping wifi on when lock screen. At home the opposite. So the conclusion was, logically, that I had a problem with my router (Dlink 605L). After 2 days of googling, I fonud this post:

     

    http://support.apple.com/kb/HT4199

     

    So I changed my router's name from "dlink" to other name (no matter which kynd of name) and the problem is solved now!!

  • salhussin Level 1 (0 points)

    Hello there.. i had the same problem and i thought my iphone was broken. once i googled, i found out that many iphone users are facing the same prob. i tried everything posted here but none of them worked. However, I found a way.. and it worked on my iphone 5. maybe you could try this.

     

    Go to setting --> Wi-Fi --> Choose your network

     

    once u r connected to your selected wifi network, there will be an symbol next to it.. click on that symbol. under HTTP proxy, click Auto.

     

    hope this helps.

  • chaseinger Level 1 (0 points)

    thank you salhussin, your solution worked for me. got quite annoying on an old phone to wait for it to connect to 3G, then back to WiFi all the while being rather unresponsive. all good now.

  • andhavarapufromsunnyvale Level 1 (0 points)

    It seems following worked for me.

     

    Go to setting --> Wi-Fi --> Choose your network

     

    once u r connected to your selected wifi network, there will be an symbol next to it.. click on that symbol. under HTTP proxy, click Auto.

Previous 1 2 3 4 Next