Previous 1 2 Next 21 Replies Latest reply: Nov 5, 2015 11:16 AM by Philly_Phan
philmarriott Level 1 (0 points)

I received my iPhone 5 yesterday, a black 64 GB. I have WiFi problems with it.

It connects fine to the WiFi and everything works, but only for a while. At any given moment it just loses the internet connection while still connected to the WiFi.

Turning on and off the WiFi brings internet back temporarily but it can lose the connection again shortly afterwards.

I have tried the phone on 3 WiFi networks.

-D-Link router at work. Same problem.

-TimeCapsule 3rd generation at work. Same problem.

-TimeCapsule 4th generation at home. Same problem.


What I've tried so far is:


-Set the TimeCapsule WiFi at home to channel 11 for 2,4 GHz and 48 for 5 GHz rather than automatic.

-Gave the 5 GHz WiFi its own name, and tried using only 2,4 GHz and 5 GHz respectively.

-Did a full reset of the phone without restoring from backup.


No problems at all with internet over cellular.


So far unsuccessful. What to do? Wait for iOS 6.0.1?

  • matrixxzero Level 1 (130 points)

    Yes. It appears so or goto Apple for an exchange. There are a lot of us in the same boat with temporary fixes that don't last.


    Good luck!

  • philmarriott Level 1 (0 points)

    I'm in Sweden, bought it from Apple UK. I won't be going to UK for an exchange. They're not even out in Sweden yet.

  • philmarriott Level 1 (0 points)

    I read something about the problem being related to "certain wireless settings" but the article did not elaborate. I also read something about changing the router's wireless security settings. The article suggested WPA2 Personal. My TimeCapsule at work offers:


    WPA/WPA2 Personal (current setting)

    WPA2 Personal

    WPA/WPA2 Enterprise

    WPA2 Enterprise



    Does anyone know if any of these settings would be better or worse?

  • matrixxzero Level 1 (130 points)

    Some have had success changing the channel to the highest number such as 11. Some have had success changing to just WPA2. Others had success just going to Settings > Wifi > Name > scroll to bottom and "Renew Lease".


    These are the suggestions I have seen posted in the hundreds of pages. Most are temporary at best. Some strike a lucky chord of success.


    I hope this helps. If not, I hope someone more knowledgeable can help you! Sweden .. I would love to go there!

  • alexvort Level 1 (0 points)

    Same problem on 4S after upgrade till IOS 6

  • philmarriott Level 1 (0 points)

    I did call Apple about this and they were willing to replace my phone, but I'd have to send my phone to their office in Ireland and they would after receiving my phone send a replacement phone to my Borderlinx address in the UK. This would cost me about 80 € in total.

    After some research I have decided that this is a software problem and not a hardware problem.

    I did make another restore on my phone, this time via iTunes, which means it completely reinstalls the system, rather than just wipes it as when you do a restore via the phone. Still not working properly.

    So, I guess we're all anxiously waiting for 6.0.1 then.

  • philmarriott Level 1 (0 points)

    I have found a working solution, but involves lowering the security. At work I set the router to WEP and after that I had no problems with the WiFi on my phone at all. At home I use only a TimeCapsule and they don't support WEP, so I simply switched off the security and made the network hidden. So far no problems.

  • mitchiemitch Level 1 (0 points)

    This fix to the wifi glitch worked for me: How to fix the Wi-Fi glitch in iOS 6 for Apple devices


    There are some pretty straight forward changes in settings you have to make (includes screenshots to walk you through).


    I hope this works for you - gl

  • philmarriott Level 1 (0 points)

    I tried this at first but it did not work for me. First I just reset network settings but then I also made a complete restore and that did not help.

  • mobg888 Level 1 (0 points)

    I googled for half a day for the solution.


    i've tried switching off LTE, rebooting network, hard reset, restore, using DNS,, switching off iCloud, switching off cellular, changing proxy to Auto, etc etc etc but nothing worked.


    but i just saw this fix :


    and tried it. Worked perfectly.


    my wifi has been so far stable for the past 1 hour and everything is blazingly fast.



    to summarise:

    #1:  Click “Settings” on the home page of your iPhone or iPad

    #2:  Scroll down and tap on “Safari”

    #3:  You’ll now be looking at the settings of your Safari browser > go down to the “Clear History” and “Clear Cookies and Data” section and tap on both of those settings to clear everything out (one at a time please!).

    Now turn your iPhone or iPad off completely to reboot


    (credit tabletcrunch)


    Hope this works for you too.

  • alexvort Level 1 (0 points)

    reseting network settings solveed the problem...

  • philmarriott Level 1 (0 points)

    @alexvort - that did not work for me.


    An update: WEP did not work any more this morning. When I entered the office the phone hooked up with the WiFi but I had no Internet. So I removed the security from my TimeCapsule in the office and made the network hidden. Now it's been running smoothly for 2 hours.

    It seems to me that iOS 6 has trouble handling encryption on the WiFi.

  • JJ_Rapidz Level 1 (5 points)

    I also have this problem (iPhone 4s) I rung up apple and was told it was a hardware error and they be happy to replace the headset, all I have to do is send my phone off and I'd receive a new one within 10 days off sending mine off, all this is free of charge apple send you a free post recorded delivery bag and box to send your phone off. However there is a choice of a courier exchange so you not left without a phone but apple charges for a courier service.

    My advise if apple are willing to replace the phone, take the offer

  • BigMcGuire Level 1 (0 points)

    Yep, I was having problems with my new iPhone 5 at work with our Netgear router. At home with my N600 Netgear I had 0 problems (or with my parent's D-Link at their house). But at work, I'd connect but I'd have no internet. Clearing Safari history/cache did nothing. Setting DNS and forgetting network did nothing.


    What fixed it? Resetting network settings. Seriously. I hit that, restarted. BAM I'm blazing on WiFi right now without a problem.


    But like most people, I discounted it even before trying it but I kept this tab up and after spending 10 mins trying other things, finally decided to give the reset network settings a try.

Previous 1 2 Next