Previous 1 3 4 5 6 7 Next 91 Replies Latest reply: May 23, 2014 6:42 AM by donnie51 Go to original post
  • mrg2507 Level 1 Level 1

    Apple have shown how short sighted they are......   when you cannot even delete a number without it being kept in the memory......  hopeless. In this day and age we shouldn't have to do factory resets, or add fake names...  this should be a simple software update, so come on Apple - pull your fingers out.

  • Ricarduccio Level 1 Level 1

    I hear you all !

    I have been trying to see how i can deel

    With this issue/bug but no good solutions.

    Restoring should not and is not the solution.

    I have reported this issue to apple and let us

    Hope they listen to us.

    Let see if they get a fix before next X-mas ! Lol

    So apple team, get to work on this ASAP !


  • Huldra_2 Level 1 Level 1

    Can someone please make a "delete-my-ex" app to fix this? It's really hopeless...

  • Vinnie667 Level 1 Level 1

    Yes I agree, the amount of times I've text my ex because I had the number still even though I deleted it.

  • Madenengland Level 1 Level 1

    Hi I have a sort of fix:

    I'm going to use the letter J as that's the name/letter I'm having the problem with for my example.

    Put the number back in your contacts using a symbol like !!!!! As the name.

    Now send a text saying test from !!!!!/old number (If its an Ex send. Code 1394: Your Number Has Now Been Blocked From The Following Recipient)

    Now go back into contacts and delete the number you want rid of i.e. !!!!!

    Hey presto number is sort of vanished, it's just not in the same list of contact suggestions

    Its now under !!!!! Which shouldn't pop up when you type J for example to send a message.

    Hope this helps!

  • Ricarduccio Level 1 Level 1

    thnks for the sort of fix !!

    but it is too much extra

    work! it should be just

    a much easier fix -

  • Huldra_2 Level 1 Level 1

    Thank you for the sort of fix :-)

    But I already did it the "hard way", which wasn't really that hard at all. I restored my phone as a new device. Then I synced it with iTunes. Had to do this a couple of times, because I discovered as I was going along that I could sync back everything the way it was, even photos (had to go into my photo library to find them, but they were all there, from the last time I competely synced my phone). I got all my apps back, just had to set them up again. It is a little bit of work, but when you know how to do it it's not hard and totally worth it, for someone like me who has an issue with contacting ex'es when I'm drunk ;-)

    Still, Apple could fix this easily by putting in an option when you delete a contact, like "Are you sure you want to delete this contact permanently?". I wish they do, because I know a lot of people like to get rid of the numbers of people they don't want or don't need to contact anymore, and it is annoying that they pop up even if it isn't an ex.

    At least I learned how to use this forum and how to get full use of iTunes sync :-)

  • karenfromid Level 1 Level 1

    I just purchased an iPhone 5 and I have an "other number" showing up when I try to send a new message to my husband.  It was his old iPhone work number.  He retired a year ago and that number has been reassigned to a 10 year old girl.  I have deleted my husband's contact and created a new one.  It still shows up.  I can not find a way to get rid of the old "other" number.  I have accidentally sent messages to the 10 year old because of this.  Please, Apple, find a solution to get rid of the attachment of these removed numbers from our contacts that keep showing up no matter what we do.  I have spent many hours trying to solve this issue.


    The best temporary fix I have found is to create a new contact with the name "Do Not Call" and assign the "other" number to that.  When I enter my husband's name, the number still comes up but it helps me to recognize that it is the wrong number.

  • cheonweb Level 4 Level 4

    If you send a one last message to that 10 yo girl using the "Do not call" contact (or better change the name to something like $%#@) then the old number will be assigned with the "$%#@" name and will not appears when you type your husband name.

  • karenfromid Level 1 Level 1

    Yes. This worked. Thanks for the help.

  • cheonweb Level 4 Level 4

    You're welcome.

  • robertuk Level 1 Level 1

    I am also having the same problem. Why have APPLE not picked this up yet and fixed it. This is now Obviously a common problem.      

  • KhoiDekDoi Level 1 Level 1

    I try this advise, it's work for me!

  • dadmaj Level 1 Level 1

    It doesn't work. They still show up. They show up if you have texted them at least once. If you type in the message area, they show up.

  • cheonweb Level 4 Level 4

    It doesn't work because the problem has nothing to do with Address book. It's the Message App cache memory. Assign the old number with a fake contact named something like "$£%" and send a message to this number. Then delete the fake contact.

    Or restore your iPhone as new (not from backup).

Previous 1 3 4 5 6 7 Next