8 Replies Latest reply: Nov 4, 2012 12:12 PM by r.fletcher
Ronin81 Level 1 Level 1 (0 points)

I have an iPhone 4S.  When I updated to iOS 6 itunes music stopped work (I used iTunes match).  Either the iCloud icon appeared or music showed up without being playable and showing the song length as 0.  After trying a bunch of stuff, I tried to do an erase and restore from iCloud.  When I did this, the restore hung on the iOS load screen (black screen with silver/white apple with a white status bar).  The status bar would go to about half way and then hang.  The first time, I left it like that for 16 hours.  Still didn't work.  I've tried several different things--putting it in recovery mode, DFU mode, and all in all, restored it 10 times.  I spoke to Applecare 3 times, went in to an Apple store for 3 hours, where they gave me a new iPhone to try with and it still didn't work. 

 

I thought I had done a manual backup, but must have pulled the plug before it finished.  This was my screwup.  Then again, iCloud is supposed to "just work."  What's the point of cloud backup if you have to backup for that? 

 

Anyone encountered this problem and know a fix?  The data is up there in iCloud for the apps, but I just can't access it. 


iPhone 4S, iOS 6
  • ejw94118 Level 1 Level 1 (0 points)

    For what it's worth, I have exactly the same problem. It is extremely frustrating.

  • mgarrigan Level 1 Level 1 (0 points)

    I have exactly the same problem, did you find a workaround? So much for the tag line "It just works"

  • r.fletcher Level 1 Level 1 (0 points)

    Same problem. I had a 4S with iOS 6. It backed up a number of times. I dropped the thing and broke the screen, got a repalcement at the Apple Store yesterday, and now I can't restore the new one from the iCloud backup. I've tried a couple different backups and it's always the same: First there's a screen w/ a blue progress bar that completes, then the black screen w/ Apple logo and silver progress bar. The first time the progress bar goes all the way up (takes a little while and hangs at 50% before finishing), then the same screen shows up again and the progress bar only gets to 5-10%. If I just let it sit it resets once in a while -- maybe once an hour -- (black spinner screen) but goes right back to the progress bar screen and gets stuck at the same place every time.

     

    I'm not giving up on this thing. I'm going to call support first and take it back to the Apple store if they can't help.

  • ejw94118 Level 1 Level 1 (0 points)

    I was able to restore my phone. I am not confident it actually will work again for me or others, but here is what I did. It is certainly worth a try. With the phone stalled on the apple screen, I plugged it into my computer hit "restore". The computer asked me if i wanted to back up my phone before restoring and I said YES. It then went and restored as before. This time, instead of restoring from iCloud, I told it to restore from the local backup I had just made on the stalled phone. Call it magic (I am still wondering), the phone reinstalled and everything was there. I did have to re-input all my passwords, but for the most part, the phone acted just as it had before. I have no idea why this happened and if anyone from Apple can offer some advice as to how to avoid this in the future, that would be most appreciated.

  • james_277 Level 1 Level 1 (0 points)

    I am sure my restore is now corrupt?

    Has been on status bar for 8 hours and has not moved.

    I have tried a manual reset to start the process all over again but it keeps going back to the status bar.

    Not sure what else I can do

  • james_277 Level 1 Level 1 (0 points)

    I'm getting the same. Did you resolve the issue?

  • Nick Field Level 1 Level 1 (0 points)

    Based of what EJW said I was able to repair.

     

    1. Attempt to restore off Icloud

    2. wait for it to sit there

    3. plug in and open itunes

    4. Restore

    5. BACKUP before restore

    6. Restore from copy on itunes (not icloud).

     

    Worked like a charm.

     

    Thanks

  • r.fletcher Level 1 Level 1 (0 points)

    I hadn't follwed up here because I hadn't found a solution, but good news: iOS 6.0.1 is out and I think they fixed this bug. All I know is that I had made absolutly zero progress on this. I tried the procedure above, restored multiple times, called AppleCare, visited multiple Apple stores. Nothing got me any closer. But after updating to iOS 6.0.1, restoring from the very same iCloud back up worked the first time.

     

    Still, I'm done using iCloud backup. If it fails your hands are completely tied, and Apple's first lines of support are absolutely no help. Back to iTunes backups for me!