2 Replies Latest reply: Sep 27, 2012 2:58 PM by b noir
jennylynn_ Level 1 Level 1 (0 points)

Help needed!

 

I've got an imac that is a coupled of years old and its currently running on OSX 10.5.8 after it just being updated. After updating it I tried to download the new itunes version 10.7 as ive just upgraded my iphone 4s to ios6. However when i go to install itunes it comes up with the message:

'This software requires Mac OSX version 10.6.8 or later'

 

Tried to update my imac again but its saying theres no available updates.

 

Anyone know how to sort this out so I can download the new itunes and I can sync my iphone?

 

 

Thanks


iMac, Mac OS X (10.5.8)