3 Replies Latest reply: Oct 2, 2012 1:49 PM by lllaass
waggiefromlosangeles Level 1 Level 1 (0 points)

I have a second generation ipod touch, still running the 2.21 version, when I connect it to itunes, it told me there is a newer version 4.2, but when I tried to update it, it keep telling me some unknow error accurred (-1), and won't let me update it, but won't tell me how to fix the problem...can anyone help?


iPod touch, Windows 7