4 Replies Latest reply: Nov 14, 2012 4:46 AM by Nukular
bradschhk Level 1 (0 points)

Just started out with OS X Server and I had a working Profile Manager albeit very fresh installation before the 10.8.2 and 2.1.1 update.


After the update, I get an "A Server Error has Occurred" message on logging into Profile Manager and I would have been redirected to




The log for profilemanager has the following entry:


Sep 28 10:35:32 bradosfs1.bradbury.lan ProfileManager[17783] <Info>: @@@ process_in_transaction: PGError: ERROR:  could not serialize access due to concurrent update

        : UPDATE "settings" SET "last_modified_guid" = NULL, "knob_sets_enabled" = '--- {}


        ', "updated_at" = '2012-09-28 02:35:31.974173' WHERE "id" = 1 @@@

Sep 28 10:35:32 bradosfs1.bradbury.lan ProfileManager[17783] <Info>: @@@ Retry #1 of 'verify_auth_token' due to database transaction failure.... @@@

Sep 28 10:35:32 bradosfs1.bradbury.lan ProfileManager[17790] <Alert>: NoMethodError (undefined method `user_result' for OpenDirectory):

          /System/Library/Frameworks/RubyCocoa.framework/Resources/ruby/osx/objc/oc_impor t.rb:789:in `method_missing'

          lib/open_directory.rb:380:in `collect_user_group_records'

          /System/Library/Frameworks/RubyCocoa.framework/Resources/ruby/osx/objc/oc_attac hments.rb:1151:in `each'

          lib/open_directory.rb:365:in `collect_user_group_records'

          lib/open_directory.rb:403:in `get_directory_user_groups'

          app/helpers/user_group_helper.rb:67:in `find_all'

          app/controllers/magic_controller.rb:208:in `send'

          app/controllers/magic_controller.rb:208:in `do_magic'

          app/controllers/magic_controller.rb:208:in `do_magic'

          app/controllers/magic_controller.rb:181:in `each'

          app/controllers/magic_controller.rb:181:in `do_magic'

          app/controllers/magic_controller.rb:180:in `each'

          app/controllers/magic_controller.rb:180:in `do_magic'

          app/controllers/magic_controller.rb:173:in `each'

          app/controllers/magic_controller.rb:173:in `do_magic'

          /config/environment.rb:130:in `transaction'

          lib/mdm_utilities.rb:161:in `process_in_transaction'

          app/controllers/application_controller.rb:127:in `give_session_to_models'

          thin (1.2.7) lib/thin/connection.rb:76:in `pre_process'

          thin (1.2.7) lib/thin/connection.rb:74:in `catch'

          thin (1.2.7) lib/thin/connection.rb:74:in `pre_process'

          thin (1.2.7) lib/thin/connection.rb:57:in `process'

          thin (1.2.7) lib/thin/connection.rb:42:in `receive_data'

          eventmachine (0.12.10) lib/eventmachine.rb:256:in `run_machine'

          eventmachine (0.12.10) lib/eventmachine.rb:256:in `run'

          thin (1.2.7) lib/thin/backends/base.rb:57:in `start'

          thin (1.2.7) lib/thin/server.rb:156:in `start'

          thin (1.2.7) lib/thin/controllers/controller.rb:80:in `start'

          thin (1.2.7) lib/thin/runner.rb:177:in `send'

          thin (1.2.7) lib/thin/runner.rb:177:in `run_command'

          thin (1.2.7) lib/thin/runner.rb:143:in `run!'

          /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/webserver/thin :8

Sep 28 10:35:32 bradosfs1.bradbury.lan ProfileManager[17790] <Info>: Rendering /Applications/Server.app/Contents/ServerRoot/usr/share/devicemgr/backend/public /500.html (500 Internal Server Error)

Sep 28 10:35:32 bradosfs1.bradbury.lan ProfileManager[17789] <Info>: Completed in 600ms (View: 0, DB: 429) | 200 OK [http://bradosfs1.bradbury.lan/magic/do_magic]


I cannot tell if this is a problem with the ruby code as the log implies about user_result method being missing or whether it was caused by the postgresql update query failure.

Server 2.1.1, OS X Mountain Lion (10.8.2)
  • bradschhk Level 1 (0 points)

    Solved. Line 380 in lib/open_directory.rb had the wrong method in the parameters.


    It should be group_result instead of user_result


    If you have this problem (as shown in the logs above)

    Change line 380 from

    Rails.logger.error("collect_user_group_records: ignoring invalid OD record #{user_result} (#{e.message})")


    Rails.logger.error("collect_user_group_records: ignoring invalid OD record #{group_result} (#{e.message})")


    You should now be able to access profile manager.

  • ShireOfHarvey Level 1 (0 points)

    Thanks for that I'm having the exact same problem.


    What is the full path of lib/open_directory.rb?


    Thanks again

  • ShireOfHarvey Level 1 (0 points)

    found it! and making the changes worked for me, thanks once again


    is in:


  • Nukular Level 1 (0 points)



    I am having the same problem like u both.


    But for me there is another problem first ... how do i edit and safe the open_directory.rb?