7 Replies Latest reply: Jan 14, 2013 4:42 PM by Islander4703
Oliver Saunders Level 1 Level 1

Not sure if there are any bods out there that use 10.6.8 server for AirPrint but if you do - you will have noticed that iOS6 doesn't see shared printers where as iOS5 does. Below is the fix. You need to be reasonably proficient with Terminal but otherwise - straightforward. Hope this helps.....

(Obviously you can stop the service and use Netputing's AiorPrint Activator but for a server based managed queueing system, this just allows it to works as it did before.)

 

10.6.8v1.1 Server and iOS6 AirPrint not working… Fix below…

 

 

Stop Print Services and as root from terminal using vi or equiv add the following:

(you will need to chmod 744 to edit then 444 the mime file after. 'touch' the files when your done)

It may work being left rwx but I don't know - I have just put the files back to their original state.

Restart print services after and you are all good.

 

 

usr/share/cups/mime/

 

File: apple.types

Add the following line in bold (I have shown a few lines either side so you know where to put them):

 

 

image/pict                              pict pic PICT string(522, <001102FF0C00>)

image/urf                               urf (0,UNIRAST)

 

# Image formats supported by CGImageIO.

image/imageio                   crw cr2 nef bay raw dcr dng orf srf fax

 

 

 

File: mime.convs

Add the following line in bold:

 

text/css                              application/postscript                    33          texttops

text/html                              application/postscript                    33          texttops

image/urf                               application/vnd.cups-postscript 66           pdftops

image/gif                              application/vnd.cups-postscript          66          imagetops

image/png                              application/vnd.cups-postscript          66          imagetops

image/jpeg                              application/vnd.cups-postscript          66          imagetops


Xserve, OS X Server, Core Server - 10.6.8v1.1
  • Appsurfer Level 1 Level 1

    Even easier solution - just switch the router on and off.....DOH

  • Oliver Saunders Level 1 Level 1

    Appsurfer

     

    I fail to see what this has to do with a router. I had the problem at home and at 2 clients. Rebooting the router at home - one of the many things I tried before sussing the issue made no difference what so ever.

    Please enlighten if you have a more technical answer to the problem of how rebooting a router fixes this.

     

    FYI - I have passed this to a few other people and it has solved there issue.

  • Appsurfer Level 1 Level 1

    I don't understand why, I have a netgear 4 port router with wireless -N and a HP 400 printer connected by Ethernet to one of the ports. The printer also has wireless capability. tried rebooting Pc and printer to no avail but later rebooted router -bingo

  • Oliver Saunders Level 1 Level 1

    Arrr - your Printer is AirPrint capable. You are printing direct from an iOS device to the printer. Some printers need a firmware update - others will work with iOS 6 straight away.

     

    The issue above relates to Mac OS X Server 10.6.8 (not client) and in relation to Print Services. You can use 10.6 Server and AirPrint to Any printer you like - not just an AirPrint ones. This is what AirPrint Activator does for client -  the above fix mends for Server.

     

    Glad you got you problem solved anyway.

     

    Oli

  • CanArmyGuy Level 1 Level 1

    Worked like a charm! Thanks!

  • kramere_wrk Level 1 Level 1

    This same fix applies to 10.7 server.

  • Islander4703 Level 1 Level 1

    I uploaded the latest handy print v4 on my Mac book pro and it fixed the problem. My new iPad will now AirPrint . Good luck