Previous 1 2 Next 22 Replies Latest reply: Mar 9, 2015 3:30 PM by FlemicalReaction
josearaujo Level 1 Level 1

Hi, I am using snow leopard and this message has appeared since the last day "your mac OS X startup disk has no more space available for application memory". Could it be something related to the mail problems people have been talking about on mountain lion ( ) ? The thing is that I can run the solution for mountain lion as the mail folder is not inside Library and I cant seem to find it.... any other ideas? I also saw the thread where people suggest to remove any HP printer related things, but that didnt work for me. Thanks!

  • josearaujo Level 1 Level 1

    Oh, and I only have 1Gb of RAM. (30 Gb of disk space available also)

  • ds store Level 7 Level 7

    Your boot drive is likely nearly full.


    Use Activity Monitor > Drive Usage to see the pie chart.


    Reduce user files using a external storage drive (not TimeMachine!)


    See this


    Most commonly used backup methods



    Also your RAM is rather low, use the free MacTracker to find your rmachine and it's RAM capacity (may be more than Apple says) and visit for their checker to get the right specs/order


    install videos and tools  here


  • josearaujo Level 1 Level 1

    Hi! Thanks for your answer, but I am not sure you have understood the problem correctly. Actually I made a typo and I have 2Gb of RAM.

    I have 80 Gb free in my hard drive, so it cannot be related to the hard drive. Also, note that the error message is about memory to run applications, so it cannot be disk space but is RAM related right?


    I installed the mactracker but its not really clear what should be done with it... it doesnt even discover automatically which version my macbook is :S why is it useful?

  • josearaujo Level 1 Level 1



    I found out that chrome was taking 110% of my memory when the mac was getting slower, until chrome was paused and the same warning appeared. Tried with Safari, same thing happened. Tried with firefox, same thing happened :S This is all happening when I am browsing. Does somebody has any tip on how to solve this issue? This has NEVER happened before some days ago, and now it is happening several times a day!

  • Oliver Jobson Level 1 Level 1

    I had the exact same issue this morning - it's nothing to do with running out of space on your hard disk - it's to do with virtual memory.


    I have 16gb of memory, with about 13gb free this morning (after resolving the issue) and a 1TB hard drive, of which I have about half free.


    For some reason OS X had decided to increase the swap file (virtual memory allocation) to 56GB - I think this might be the maximum that OS X can use - hence it was asking me to close some applications to make some room.


    Closing chrome and firefox (which were reported by finder to be 'unresponsive') seems to have fixed the issue - so this is consistent with your experience, as well as that of others I have come across (who reported they were only running safari and finder).


    I can only think it was a memory leak caused by a bad browser plugin - I had left open the redbull stratos youtube page in both chrome and firefox (couldn't get it to load yesterday!) so perhaps the stream data had leaked in to memory overnight (totaly guessing here).

  • gjlj Level 1 Level 1

    I'm having the same problem on my macbook running Snow Leopard, and have been since almost exactly the same time.  Leaving browsers open on the computer for any period of time causes progressive slowing of the computer then I get the error message and have to force quit the applications.  I've had the problem especially with chrome and firefox, especially when browsing pages that refresh regularly such as facebook or Youtube.  I have over 70GB of my hard drive free and I've checked that my RAM is seated correctly.  I've also cleaned out my deleted items and downloads files without any resolution.  I've checked my log files and the folder is only 400KB in size, so I don't seem to have any runaway log files.


    This is driving me completely crazy so any help would be greatly appreciated.

  • josearaujo Level 1 Level 1

    Haha yeah, we really have EXACTLY the same problem. I am not sure if anyone has actually a solution for it. I got so mad about this that what I did was to format my hard drive and instal snow leopard from the cd, and then install mountain lion which i downloaded from the app store. First i tried to install mountain lion before formatting but it said that my disk was broken when i ran the disk utility (not sure that was the problem though, as all was fine before...)


    Now all works fine and i hope it doesnt happen with mountain lion. If u can pay for the update i would go

    For this solution as it takes the headache away...

  • MASK47 Level 1 Level 1

    I had this same problem, took the Mac to my local Apple shop (a registered Apple agent) and within 30 seconds he had it working again. He reset the "P Ram" by powering off then pressing what looked like 5 fingers on the keyboard, then powered up and voila all a goer.


    Hope this helps.

  • gjlj Level 1 Level 1

    Well that sounds like a solution of some sort, but I upgraded to Snow Leopard from download, so I don't have the disk, the options for upgrading to mountain lion isn't really an option as there's something so broke that the disk utility can't even repair the disk without the disk for snow leopard that came with the computer (uh oh, didn't come with snow leopard).  So it sounds like I would have a similar problem to you for upgrading.


    The options here are getting pretty thin on the ground, I think I'm going to end up taking a 4 year old computer to an apple store and paying through the nose to get a software glitch fixed .


    Deep joy, this whole thing is messed up, I can't wait to find out what is really causing the problem.

  • k6rtm Level 1 Level 1

    I've just seen this on my 4gb Mac Mini -- running snow leopard server.  No web browser activity on this machine; it's a server sitting in a closet, running Snow Leopard Server, and a Python monitoring hack.  No changes to this system other than software updates -- and the Python hack has been running unchanged for many months.


    Plenty of space available on the boot volume, 64gb on an 80gb volume.


    Reboot and all seems well; but for how long? This is a weird one!

  • gjlj Level 1 Level 1

    Well, this led to a new problem today, my poor macbook took over 30 minutes to start up this morning and when it did it refused to open any programs, I'm starting to think that this problem may be associated with a more progressive problem on the mac in the hardware.


    Oh well, gebius bar, here I come.

  • Reegor Level 1 Level 1

    I am having this problem today, first time ever. I am running Mountain Lion 10.8.2, so the OS is apparently not the issue.


    Hardware: 8 GB of RAM, which was half full.

    512GB of SSD, which had 200 GB free.


    I was running:


    Microsoft Word

    some esoteric programs



    I had to restart from a frozen machine. When I restarted, same thing just happened again. This time, all I had open was Word. (I have since opened Safari).


    Comment: could this have something to do with a tiny MS Word upgrade I just received? I got it AFTER the problem started, but the timing is strange.

  • jcssj Level 1 Level 1

    I am having exactly the same problem with mountain lion.  I go to use it and wake it up and get the message your osx startup disk has no more available space.  It has started with my ssd and mountain lion.  No trouble before the ssd.  I have 79 gb of space now, 38 the first time it happened.  My guess is a bug in osx.  Less likely possubility of ssd reporting full.  The only solution I have found is hard reset.  After reboot all the programs open and finder shows the correct free space.  I have tried shutting down programs or moving data to a usb, but osx is locked up when this error occurs. 

  • Alec V. Level 1 Level 1

    I am also having the exact same problem on my iMac (2.7 Ghz Intel Core i5) with the latest version of Mountain Lion. I restarted the machine once and everything seemed to be fine, but when I came back today the machine took 10 minutes to accept my password and another 10 to restore my user login session, and I saw the alert you got. My machine continued to be slow even after I quit all apps. I have 479 GB free on my internal hard drive and 12GB of RAM.


    Having reset the PRAM as one user recommended, and logging back in, I am waiting to see if the problem returns. In the meantime I noticed that Virtual Memory (VM size) in Activity Monitor is over 300GB (yes GB!).... maybe something is amiss there.... my largest app in the list is using 3.69GB VM and 3.11GB real memory.

Previous 1 2 Next