Previous 1 2 3 4 5 Next 67 Replies Latest reply: Apr 29, 2013 10:10 AM by Brendan SF Go to original post
  • bluerayprime Level 1 Level 1 (0 points)

    Hi, today I just came accross a possible root of the problem. On my machine runing 10.8.2 (Installer App purchased from App Store) I experience the same problem with pixelated icons in low resolution: folder icons, icons in the launch pad etc. I also started these processes with ONYX an so on like described in former comments. That did not fix the problem. SystemUIServer errors I found, but they were old ones and not from now. So killing this service aso did not help.

    On a different partition there is a preview developer version of 10.8.0 installed - fresh and clean. And just to cross check I started this and the icons looked ok. Just to try I run an update of iTunes to 10.7. (IOS 6 support) and 2 other Apps. I made this through the App Store. While loading I kept the launch pad open. Afte the succesfull update the former highres icons changed to lowres - and this happend to all 3 freshly updated programs.

     

    So my idea now is, that a current update process over the App Store causes the icon resolution problem. Maybe it came across since the launch of IOS 6 in october with the new features - especially retina support. On the test partition I installed xcode for developers over the App Store in september. And that time it worked ok. The update process caused the problem now and at the moment I have no idea how to fix it.

    I hope this information helps someone out to find a solution.

  • David Losada Level 1 Level 1 (10 points)

    All i can say is that it's not something user related. I've installed Mountain Lion three times in a different internal disk in my MacPro, and each time I've had the pixelated icons.

  • Notary Sojak Level 1 Level 1 (135 points)

    Tidbit of info: According to a reply I got to my bug report, Apple is persuing this issue in ML - I was asked to see if it still happend in the latest GM of 10.8.2. They are not going to fix it in earlier sysems like SL.

    Since I don't have ML on any of our Macs yet, I really can't test the GM, but if you file a bug report on this issue at bugreport.apple.com it will probably help. You'll need to sign in with your Apple ID.

  • David Losada Level 1 Level 1 (10 points)

    It still happens in 10.8.2 supplemental update 1. Even in installations from scratch. Yesterday I wasted the whole day formatting and reinstalling, and today I'm cloning back the precious installation since I got the pixelated icons right after the restart.

  • bluerayprime Level 1 Level 1 (0 points)

    I can confirm this message. 10.8.2 supplemental update does not fix the icon problem in ML.

  • donazipe Level 1 Level 1 (30 points)

    Well, it is good that at least someone at apple is finally looking into this issue...

    I have 10.8.2, and the bug is there. As written in this and other thread, it might be linked to a but related to systemUIserver (the process that has to do with the menubar icons...). Killing and restarting this systemUIserver temporarely (few minutes) fixes the problem...

    Looking forwared for an official fix!

    PS: I filed a bug report few weeks ago, I only received a message telling that this is a duplicate... I guess the same happened to others... But no contacts from apple!

  • ianthekirkland Level 1 Level 1 (0 points)

    I've had this problem ever since Snow Leopard. Here's the scoop:

     

    • It's not Lion-related or Mountain Lion-related

    • It's not third-party software-related

    • Deleting your .DS_Store files won't fix the root cause of the problem

    • Restarting wont' fix the root cause of the problem

    • No one at Apple (that's accessible to speak with (to my knowledge)) knows how to fix this issue

     

    ---------------------------------------------------------------------

     

    What I do know, is that I am the type who likes to "push my system" more than the average user (i.e. customized RAM, lots of command line tweaks, etc.)  I'm also an icon junkie. I like to customize / create my icons (though I've dramatically cut-back on this...especially since recent OS's have made it tougher and tougher to customize the UI. I keep a folder – with roughly 20 subfolders of several hundred icons each. As another post pointed out, I have to believe this takes some sort of toll on some hidden cache buried somewhere deep in the system. I've pretty much given up on the issue...and have become so acclimated to blurry icons that I almost fail to even notice it...

     

    I still want this annoyance to go away. If anyone has found anything on this, please let me – and everyone else – know!

  • Tracy Valleau Level 1 Level 1 (35 points)

    I'm delighted that you can be so definitive. I've personally only been programming Apple products for 32+ years, and I can't be that definitive. I assume you've seen the 26-page thread that goes back three years on the forum, here:

     

    https://discussions.apple.com/thread/2132399?start=0&tstart=0

     

    What the issue is with these forum messages is that everyone's post is anecdotal. That is, it's only their own experience. I've posted my share of "eureka" moments, only to have to retract them, so I'm hardly without fault.

     

    I've spent 50-60 hours trying to track this down... and I know how to debug software. I'd guess that it's one of those "if that, and then later this, couple with one of these, then sometimes..." which is why it's so difficult to resolve. In my own case (and apparently others) it seems to be related to, or triggered by, the finder's use of UIServer in conjunction with .DMG files. That, in turn may corrupt something else.

     

    But you can be sure of one thing: when/if it's resolved, it will be all over these forums!

     

    Good luck (...to everyone!)

  • tasslehawf Level 1 Level 1 (0 points)

    Since I had noticed this issue first when I downloaded Tweetbot for Mac, I looked at the icon file inside the bundle and noticed that there are now a set of icons for Retina displays. if I attempt to copy either the highest resolution retina or non-retina icon and past them as the icon (in get info) it will allow me to have a slightly higher resolution but not as high as the ones is it still displaying correctly. My two threories (before I saw that this was an issue also on SL) was 1) It's a bug with the was the system supports Retina or 2) Developers aren't yet on top of including the correct icons in the apps for retina (and that was somehow breaking the icons displaying correctly).

     

    The Mac application Wedge (client for App.net) icon displayed incorrectly when I first downloaded it, but was fixed in a subsequent update which is what fed my second theory.

  • sgginc Level 3 Level 3 (665 points)

    Just downloaded Wedge and its pixelated.

    10.8.2

     

     

    Ken

  • tasslehawf Level 1 Level 1 (0 points)

    I updated Safari yesterday and it's icon is now pixelated. I'm guessing all of my icons will be progressively reduced to low rez each time an application is updated.

  • supportneeder Level 1 Level 1 (0 points)

    I can also confirm that this is related to App Store updates/downloads. I just ran the latest App store update which updated Safari and Xcode and now those are both pixelated. Originally when I bought/downloaded tweetbot in the app store it was pixelated.

  • tasslehawf Level 1 Level 1 (0 points)

    supportneeder wrote:

     

    I can also confirm that this is related to App Store updates/downloads. I just ran the latest App store update which updated Safari and Xcode and now those are both pixelated. Originally when I bought/downloaded tweetbot in the app store it was pixelated.

     

    I downloaded Xcode 4.5.2 the other day and it's icon was OK, but the simulator icon is really low resolution.

  • David Losada Level 1 Level 1 (10 points)

    Ok. After asking me for more info about this bug, and after providing them with lots of screenshots and webarchives of several places where people discuss this bug, Apple just responnded this:

     

    Hello David,


    This is a follow up to Bug ID# 12536646. This bug has been closed as a Duplicate. The issue is being tracked under the original Bug ID# 10400585 which is also listed in the Related Problem section of your bug report. To check the status of the original bug report, please visit the Related Problem section of the Problem Detail view of your closed duplicate bug.

     

    For the first time since System 6.0.4, I spend more time troubleshoting the Mac than troubleshoting the PC.

  • supportneeder Level 1 Level 1 (0 points)

    Is there a link to Bug ID #10400585 that they're referencing? When I search on that I just get this thread.