Previous 1 2 3 4 5 Next 67 Replies Latest reply: Apr 29, 2013 10:10 AM by Brendan SF Go to original post
  • bluerayprime Level 1 Level 1 (0 points)

    Hi! After some days checking logs, tracking errors an testing I found finally a hint to a solution that works for me - but i'm still observing if this will solve this problem for all time. As stated in former comments, updating software (system or apps) over the app store causes problems. Icons get blured if they were not before, an when they are ok by chance after a restart, others get blured which were ok before.

    I have screenshots of the launch pad etc., but people have seen this almost enough times by themselves, haven't they? Blured icons in the launch pad originate from the finder folder "Applications". All icons, which are pixelated in this folder, get pixelated in the launch pad also. Restarting the Dock and deleting the .db-file before does not help. I also could not find any other user/software-specific solution until now.

    The only thing that solves the problem on my machine is: changing the hardware - that means the grafic card! After changing to the config. to: Mac Pro + HD 5770 everything works ok after new system setup to current sys. ver. 10.8.2 + suppl. update. I tested: update over app store, checked finder icons, logs. Everything works as expected.

    More or less I was inspired to change the hw by checking the posted specs of new mac pro: I read in some blog, that pixelated icons are not reported on the "newer" machines. This might stand for the idea to upgrade hardware when upgrading the sys - if possible of course.

    I closed this issue for me with that solution and view it as a hardware/software-bug in correlation.

    Good luck for all of you.

  • tasslehawf Level 1 Level 1 (0 points)

    Too bad mine is a Macbook Pro, like most apple hardware, hardware configurations can't be changed.


    The bug has to be in the way that the application or the finder is selecting which icon to display since the correct icons are there in the .icns file.

  • bluerayprime Level 1 Level 1 (0 points)

    Well, I dont' want to discourage any user with MacBooks or iMacs. That doesn't mean changing the hardware is "the only" solution. But it seams to be the fact, that hw matters.


    For me it's just a practical solution: who has the time to play detective on bugs of new software all day long? But I like things working smootly and perfect, so that's why I changed the config.


    Just want to help an give a hint ...

  • Tracy Valleau Level 1 Level 1 (35 points)

    BlueRayPrime's hint that changing the graphics card had an effect harkens back to what I suspected all along (and noted previously) - it's something looking at the wrong screen resolution. Either it's not finding the resolution it expects; (ie 0x0) or it's looking in some place that has become corrupted. It seems to happen when software is first added; in my own case, specifically when an icon on a .dmg file is viewed.


    If it were that simple however, there would be no exceptions, but about 2%-5% of the time, I see a "clean" icon. Unfortunately that means that over 95% of the time, the problem remains.


    Either way, I rather strongly suspect that it's something that the finder is looking up in order to "properly" render the icon.

  • Tracy Valleau Level 1 Level 1 (35 points)

    And here's soemthing new on my system. Today I checked for Adobe updates, and it turned out I needed three, including Application manager and ACR 7.2. I told it to go ahead and update, and they all failed. I won't go into the round and round here, but the error was Error Code: U44M1I210 which you can Google if you like. You'll find I'm not alone with that error, but I'll cut to the chase here.


    I did some log research, and concluded that it was a problem mounting disk images... the same thing I suspected in the icon resolution issue. (I was also frequently seeing "the following disk images couldn't be opened. (name) Reason: no mountable file systems .")


    So: I created a new user and tried again. Not only did I (as before) get back to clean icons, but this time all the Adobe software updated without any trouble at all.


    My point is this: two more things to look for, and hopefully report here if you see them:

    1) can't successfully update some Adobe software (you can download .dmg updater from them if you're really curious) and

    2) "no mountable file systems" happening a lot. (The solution to that, for me at least, is simply to move the .dmg file to a different drive.)


    As usual, FWIW.

  • tasslehawf Level 1 Level 1 (0 points)

    I was fiddling with the icon size in the Applications folder, but then I restarted it - and that fixed it - for now. I honestly don't reboot that often anymore so it hadn't crossed my mind.

  • David Losada Level 1 Level 1 (10 points)

    Bluerayprime, I have a MacPro mid 2010 with an ATI Radeon 5770. And I have the pixelated icons all around. Even after an OS install from scratch. Not only a new user but a complete system installation.


    It only happens in Mountain Lion. I have a second internal disk with 10.6.8 and it works perfect. Unfortunately, I can't say the same of Mountain Lion.

  • Lanny Level 5 Level 5 (6,200 points)

    I have previously experienced this issue after updating SL to ML. I was never able to fix the issue.


    However, for me, it only came about when doing upgrades to existing SL partitions.


    Doing a clean install followed by a setup assistant migration resolves the issues.

  • Tracy Valleau Level 1 Level 1 (35 points)'s something else to try:

    relaunch system daemons

    kill spotlight


    This is really easy to do if you have Mountain Lion Cache Cleaner: just visit the system menu and you'll see both items.


    Not sure if I had to do both, but that seemed to have (temporarily, OF COURSE) cured the things I was seeing.


    (I decided to try this because I went into the teriminal and used the opensnoop command to watch what was happening when I opened some .dmg files. I noticed a huge number of mdworker calls and cache openings so I figured, what the heck...)


    Next tests will be thru reboot, and see if I can cure it again using the same technique.


    Something like system daemons and/or mdworker would certainly explain the difficulty at finding a solution...


    Anyway: if you happen to have MLCC, give it a go, and let's see what you get.

  • Tracy Valleau Level 1 Level 1 (35 points)

    OK... couple of hours of testing later: MLCC (Mountain Lion Cache Cleaner) - the relaunch System Daemons is the one that does the trick on my system. Not too surprising since I discovered the UIServer thing a while back. I've written the author to see exactly what it is he's killing and relaunching, but no reply yet.


    If this is it, then it would mean that something (or several things) are interferring with one or more daemons during the boot process, and leaving them corrupted. A relaunch obviously would fix that.


    So, programmatically, that does not necessarily mean there's a single culprit. For example, suppose that (say) three different authors are using old/outdated techniques during their startup process... or making the same faulty assumptions about how things work. The muck things up and then don't clean up properly.


    That would nicely explain why no one can find a single something to remove and cure the issue... and so on.


    So, again, if you have MLCC (or perhaps SLCC, depending on your system) try the relaunch System Daemons tool, and see if you, like me, find the issue resolved.


    That would be great to know. And if/when the author lets me know what he's actually doing with that command, I'll see if that info provides any further insight.


    Here's the URL to MLCC:


    Fingers crossed!

  • donazipe Level 1 Level 1 (30 points)

    mmm... maybe I am missing something, but it does not work in my system.

    Let's check what I did:

    Opened MLCC, menu "System", issued the command "Restart System Daemons..."

    the Authenticate panel shows up, asking for password.

    By the way, Tracy, if you click the "Details" arrow, you will see the command:

    "/usr/bin/sudo /bin/lill -HUP"

    so I guess that is the command the menu is executing, maybe no need for author's answer...

    A progress bar appears, "Restarting system daemons...", lasting few seconds.

    Anyway, after that, mounting any problematic .dmg image or unzipping a compressed archive, the blurry icons are there.

    The only solution is to run the kill SystemUIServer script...

    Unfortunately, only a temporary solution. The next dmg mounted has the blurry icons back.

    I also tried a 2 shot: first MLCC, immediately after SystemUIServer... but same result. Only a temporary fix.

    So, I am back to my original finding reported few weeks ago: relaunching SystemUIServer temporarely fixes the issue, but the kill command needs to be reissued every time to mount images with clear icons...

    MLCC is not making any difference on my system... or maybe am I doing something wrong?

  • David Losada Level 1 Level 1 (10 points)

    Restarting system daemons has no effect for me either. killing SystemUIServer es more effective, but temporary.


    And I doubt that a third party piece of software is involved here: I have the blurry icons right after installing Mountain lion in a blank disk.


    In a MacPro mid 2010 with the stock ATI Radeon 5770.

  • Tracy Valleau Level 1 Level 1 (35 points)

    Awww... bummer. I did hope I'd stumbled on something that would help everyone, and not just me.


    Back to the drawing board.

  • donazipe Level 1 Level 1 (30 points)

    One additional maybe overlooked observation...


    mount dmg/unzip file => blurry icons

    kill systemUIserver => icons OK

    copy files from mounted dmg to the desired location on the drive

    => sometimes icons are OK, sometimes are blurried, even if copied from a mounted dmg on  which icons look fine after restarting systemUIserver...


    In this case, by leaving the dmg image mounted and force quitting finder, and then copying again the problematic app from the dmg to the HD, icons are ok.


    So, this appears to support the hypothesis of some kind of corruption between dmg/unzipped archives, systemUIserver and the way the finder displays icons...

    Sometimes killing systemUIserver might no be enough... force quit finder may help.

  • bluerayprime Level 1 Level 1 (0 points)

    Back again on this subject ... I was quite puzzled to read this response, that changing graphics card hardware does not work in all cases. Testing again in response to David Losada on Mac Pro (2008) with 10.8.2 + HD 5770 I found out the following:


    On a small notebook disk -> fresh install of 10.8.2 (purchased as App in AppStore)

    Unplugged all other disks before!

    Tested the system: finder, updates -> works ok, no pixelated icons to report

    Forgot to test dmg-files -> plugged in the former disk with data

    Guess what: had pixelated icons after restart?!?

    Unplugged this disk again -> restart -> icons ok


    New session:

    Moved data to other disk (former Lion 10.7, working ok)

    Killed this "corrupted" disk partitions (2 on 1,5 TB disk with system and data partition)

    (former sys config. was on that disk which was not working concerning that icons issue)

    Restart with notebook disk (clean install)

    Made 2 new partitions as before (sys, data)

    Unlugged notebook disk

    Fresh installation of 10.8.2 on the new created sys part.

    Testing: icons ok, update ok, finder ok, dmg mounting ok

    Installed software -> updates -> moved some data back -> all working ok, no pixelated icons

    Restarting, moving data back etc. - > all working



    I have a freshly installed system with all former installed progs and files, can do updates and handle with data and progs as expected. All icons are ok until now - what wasn't the fact before - at least after update through AppStore icons were blured. That has dissapeared!


    Why doing all this works? Have no really concrete answer yet. Changing hw might help. A fresh install might help. Restarting SysServices help temporarily. But as comments show: that doesn't allways resolve the issue.


    My idea now is (have to compare logfiles someday), that the filesystem might also have an effect. This might concern installations like updates from 10.6.8 or 10.7.x to 10.8.x or eaven fresh installations on existing partitioned disks?!?

    I part. sys disk over 10.8.2. Strange is: my "data" partition looks empty in the finder when i start with Lion sys. part. But I moved files there ... ?!?

    My question: Does ML have a particularly different filesystem? Or is this question nonsens?

    But how shall I explain why my system is now working properly ... Any ideas?