Previous 1 2 3 4 5 Next 67 Replies Latest reply: Apr 29, 2013 10:10 AM by Brendan SF Go to original post
  • David Losada Level 1 Level 1
    Mac OS X

    I removed all the disks from the MacPro but one and began to install. The blurry icons appeared almost instantly. And they got worse.


    I think that it has something to see with spotlight and the number of files in the Mac.


    By the way: look at this report from MacFixit. Even the people at CNET is affected by this bug. Can you see the pixelation in the dashboard and iPhoto icons in this launchpad screenshot?


    Apple gearing up for major adjustments to the Mac | MacFixIt - CNET Reviews

  • chepitox Level 1 Level 1

    I had and still have the issue happening. The only way I get it solved is by restarting the Mac and zapping the PRAM (restart and hold cmd+option+P+R).


    But then it comes back after a while where then almost all the new apps that I download get those pixelated icons. And then I'm good for a PRAM zap.


    Surely something goes wrong at some point of time, but do not have a better solution yet.

  • Tracy Valleau Level 1 Level 1

    I'm going to have to back out of this, after this post, since too much of my life has been wasted trying to find the problem.


    What follows WILL NOT resolve issues of fuzzy icons ALREADY ON your hard drive.  For me, however, this worked:


    1) disable spotlight (using Mountain Lion Cache Cleaner, or whatever you like.)

    2) restart;

    3) after desktop comes up, again using MLCC, choose system/restart system daemons...


    This works for me. Today I decided to set Spotlight to running again, and instantly the dmg's I mounted showed up as fuzzy. I did the 3 steps above, and my problems went away.


    Yes, that means that Spotlight isn't running, and that, in turn creates other issues... so it's a fail/fail situation. Choose the devil you want to dance with.


    Good bye all, good luck.

  • David Losada Level 1 Level 1
    Mac OS X

    I'm sure it has something to see with Spotlight. But i'm also tired of fighting against Mountain Lion. Apple OS has definitively gone down the hill.

  • Djim's Level 1 Level 1

    Same Tracy's experience, same results.


    Where are OS X developpers ?


    This problem, very annoying and undeserving the supposed graphic quality

    of a mac interface, runs from Lion for me, and it will probably be in the next version 10.9 ...

  • grdh20 Level 1 Level 1

    Had this happen on 10.8.2 on a new 2012 imac. Followed some of the suggestions here and somehow it returned tio normal icons.  I think this may be in relation to an overflowing  icon cache but it really isn't clear what's going on.  Apple should look into this, but if it isn't happening to you right then, I'm not sure hopw they would troubleshoot it.

  • brentg33 Level 1 Level 1

    So i have a 2011 27" imac running 10.8.2.... never had this problem until a few days ago, i updated Oynx and Tweetbot via the MAS.  Now those two icons are pixelated in Launchpad.  i have tried a few fixes, reset PRAM, ran basic stuff in Cocktail/Onyx. Killed the systemUIserver via terminal.  reset the dock, tried reszing icons in the finder window....cleaned out a ton of caches via cocktail...etc...nothing has seemed to work..  Is there anyone who has found a better solution? or are we hoping 10.8.3 fixes it?



  • chino Level 1 Level 1

    I found this thread obviously because I was having this issue, too.


    my solution: command-i on affected app, change perms on admin or whatever to 'read & write.' then the app just needs to be touched, give it a label color then remove if desired. problem solved.

  • Loren Ryter Level 2 Level 2

    For what it's worth, I am having this problem on a more or less fresh install of Mountain Lion (10.8, then upgraded to 10.8.2 with the same problem). 


    After a fresh install of 10.8 on a new volume, before using it, I moved over certain files from a previous 10.7.5 volume.  Specifically, documents and a number of files from the ~/Library folder, inlcuding preferences and application support folders and some other things.  But the only things modified, in other words, were contained in the user domain.  I did not copy over anything in ~/Caches/


    I deleted and zapped the PRAM but the problem came back with a new package install (I believe of MS Office 2011).


    Seeing the length of this thread I would love to see a solution, but not holding my breath.

  • ant1matter Level 1 Level 1

    Don't know if this helps at all, but I noticed when I looked into the .icns file for the apps where the icon was pixilated, it was using #3 instead of #1. So I tried going to System Preferences => Displays and changed the resolution down from 1440x900 to 1280x800. I noticed that although the screen was now blurrier, the icons looked respectively clearer. I then changed the resolution back and the icons are fine. I'll have to see if this stays the same after restarting.


    BTW I'm using an Early 2008 (Pre-Unibody) 15" MBP 2.4GHz with 6GB of RAM (officially only supports 4GB) and NVIDIA GeForce 8600M GT with 256MB VRAM.


    Edit: After restart, icons are still normal.

  • Loren Ryter Level 2 Level 2

    Still normal?  Even after using a package installer?  Or does it recurr in that case?

  • WJLGREEN Level 1 Level 1

    I have been having this problem for last week or so with Chrome. I have trawled many forums. OnyX didn't work - it had the same issue with its icon incidently. Nothing else has either. But I have found a fix via a chromium discussion thread.


    Run the following command in the terminal and then re-boot and everything should go back to normal!


    /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.fram ework/Support/lsregister -kill


    This is an Apple problem though and they need to fix this in the next system update.

  • Chris Byrd Level 1 Level 1

    So I did the following 3 things to resolve this problem.  For how long it will stay resolved, I can't say at this point. 


    1. Removed everything from the ~/Library/Caches folder and rebooted (didn't visibly change anything immediately)
    2. Ran '/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.fram ework/Support/lsregister -kill' process noted above (this seemed to fix icons in the finder, but did nothing for launchpad)
    3. Ran 'rm ~/Library/Application\ Support/Dock/*.db; killall Dock' (this cleared up the bad icons in launchpad and the Dock)


    Maybe someone can take this and refine it a little further, but at least this got me back to seeing proper icons.

  • ApMaX Level 1 Level 1
    Mac OS X

    Same problem here with Mac (October 2012) with OS X 10.8.3. The above workarounds do not fix it.

  • Jason Hanks Level 1 Level 1

    I don't know if this is the same issue, I don't have an issue with dmg icons or anything in the dock. The issue that brought me here was pixelated icons of jpegs in the finder. I recently purchased a macbook pro retina and moved a huge image library (10+ gigs of mainly jpegs - I'm a tattoo artist by trade) onto my hard drive. I was pleased to be able to browse my portfolio and image library on the beautiful display by looking at the icons in finder/pathfinder instead of having to open bridge or make albums in iphoto (just moved to mac from 15 years of PC use, been a windows XP holdout but don't like the direction msoft is going at all). Ran into my first "problem" last night:


    Saved some images after doing some editing and the icons generated were pixelated....***? Being that I'm just getting reaquainted with the OS after 15 years, I don't know about flushing caches and the other suggestions here but I did right click-get info/command-i the file/icon and unchecked the "use custom icon" and wa-lah! Problem solved. On a side note, the icons at the top of this typing window are fuzzy/pixelated but I think it's something I'll have to get used to having this retina display, some sites (even the cover page at oddly enough) don't display labels and text properly.