Previous 1 2 3 Next 67 Replies Latest reply: Apr 29, 2013 10:10 AM by Brendan SF
David Losada Level 1 Level 1
Mac OS X

The problem discussed here


is affecting Mountain Lion 10.8.1 and 10.8.2.


This is a dmg screenshot taken just after an installion from scratch. Plain vanilla Mountain Lion 10.8.2. No add-ons installed. And some icons appear pixelated or blurry.


Captura de pantalla 2012-09-28 a la(s) 10.56.29.png



This bug is prevalent in files located in dmg files, but also affects Finder views (this one is from my main disk):


Captura de pantalla 2012-09-28 a la(s) 12.02.18.jpg


Captura de pantalla 2012-09-28 a la(s) 12.04.21.jpg




Captura de pantalla 2012-09-28 a la(s) 12.06.34.jpg


And even applications that make use of standard system icons. This is from Toast 11. See the CD:


Captura de pantalla 2012-09-28 a la(s) 12.08.00.jpg


The pixelated icons also appear in the application switcher (I can't take an screenshot of the application switcher).


This never happened to me in any system prior to Mountain Lion. It happens in any user account. It happens even right after an installation from zero on a secondary disk. Reinstalling ths OS, deleting caches and repairing permissions have no effect.


The icons only show well logging as root. So it seems that Apple has messed something regarding icons and access privileges. Something that cannot be solved with a permissions repair.


Apple, fix Mountain Lion. This is awful.

Mac Pro, OS X Mountain Lion (10.8.2), Macpro mid 2010
  • donazipe Level 1 Level 1

    This post comes from the snow leopard discussion on this same issue...

    Since the bug has been exacerbated on ML, it could be worth to continue the discussion over there too...


    First, thanks to Tracy and David for trying killing systemUIserver...

    Here there's another "me  too". I prepared the script... mount image (ie, googlechrome.dmg), pixelated icon. Run the script. Mount again the image: icon is fine, full resolution. I eject the mounted disk, when I retry, pixelated icon is back... sometimes this happens on the second try, sometimes it is ok, but then it become pixelated after some time...

    I come back with my previous hypothesis: there is something in the menubar, linked to systemUIserver, that is causing this problem?

    Let's try to draw a picture. I have an iMac mid 2011, and a MacBookPro i5. On Both 10.8.2. The blurry icon bug on both.

    I have those menu applications on both macs:





    growl 2

    desktop utility




    hardware growler






    and, of course, some apple menu:

    keychain, airport, sound, timemachine, bluetooth, spotlight, notification center

    I don't think these have something to do, since they are not affected by killing systemUIserver.

    Similarly, I would tend to exlude dropbox and littlesnitch, since they are installed on my girlfriend mac, and she has never seen this bug.


    I have some other menus either on the iMac or the MBPro (not both);









    I would kindly ask you if you have any of these (in particular, apps I have on both macs) running on your mac... Hoping we could track down the culprit(s)...


    For Tracy: the intuition about the old routine (menucracker) was pretty good... too bad it didn't solve the problem :-(

    I will try to check console to see if something else comes out... But at the same time, I think it could be worth to dig down extra menus...


    Thanks for all your efforts!

  • donazipe Level 1 Level 1

    Checked console for systemUIserver errors/messages...


    In my case, iStatMenu is loading MenuCracker...


    Anyway, I noted some strange messages:


    SystemUIserver:ISGetIconFamilyFromStorage: seed mismatch for 2e170b00, actual is 29a583ff

    (this is repeated 7-8 times, the two numbers/codes ad the end change)


    and then another error:

    SystemUIserver:Could not load menu extra NSbundle </Library/Application Support/iStat local/extras/> (loaded) for Class (null)


    I don't know what all this mean... but that seed mismatch for ISGetIconFamilyFromStorage may be something to look at...

    (sorry, I am a biologist, I have no idea about programming, errors and stuff like that...)

  • donazipe Level 1 Level 1

    Some more followup:

    uninstalled iStatMenu. Removed every file (prefs, deamon, etc.) belonging to iStatMenu.


    Mounted problematic dmg file => blurry icon

    run kill SystemUIServer => icon is ok

    wait for a while => mount dmg => blurry icon


    I have the impression that MenuCracker has nothing to do with this issue. This also confirms what Tracy reported about MenuCracker...


    Thus, it might be worth looking at that ISGetIconFamilyFromStorage error message... Does anyboty find it in console? What does it mean? From this point on, there isn't much I can do... I don't even know what that is!

  • David Losada Level 1 Level 1
    Mac OS X

    I have the ISGetIconFamilyFromStorage, but I don't know exactly what does it mean. In any case, I'm sure that it's something wrong in the systrem itself that maybe is exacerbated by an external factor. But i have the low res icons even in a new Mountain Lion install.

  • Tracy Valleau Level 1 Level 1

    I didn't abandon everyone, but there's little more I can do except test other suggestions.  If someone from Apple manages to read the bit about the SystemUIServer technique, that -should- be enough to point them at the problem. It is 100% repeatable for me (and apprently others):


    kill SystemUIServer

    mount = good icon


    mount = bad icon


    Don't know what more mere mortals can provide by way of debugging help.




    PS. I have tried -everything- posted on the other list. I"m close to convinced that most of the problem originate with the bad dmg mount; get written to disk, and then continue to effect icons elsewhere. The obvious fact is that the corruption has to have started _somewhere_. The reason some people can resize their monitors; dump caches; delete pref files (et al & ad infinitum) is that they are "curing" the symptoms, not the cause, and it seems to (therefore) alway come back.


    At least that's my current hypothesis, and I'm sticking to it...


    ... er...


    .... until something changes again, of course!   :-)



  • Tracy Valleau Level 1 Level 1

    FWIW, I made life _slightly_ more convenient:


    Took the kill_systemUIServer Applescript; (do shell script "killall SystemUIServer")

    saved it as an application;

    created an Automator service that

    1) runs that kill-script;

    2) pauses for 0.75 seconds

    3) opens the dmg file


    saved the service under the name "ow myMount"  (ow == "open with" just for my convenience)


    Now, while I still have to train myself not to double click on the .dmg file, at least I can control-click on the dmg, and choose my ow myMount service.



  • David Losada Level 1 Level 1
    Mac OS X

    The new 10.8.2 supplemental update doesn't fix the bug.

  • Tracy Valleau Level 1 Level 1

    Well, I woke up bound and determined to find it... and nearly trashed my hard drive in the process. I ended up cloning it back from a backup, but I spent another 9 hours on it today.


    Nothing to report, except now I believe the issue to be corruption in the hidden user files for each "numbered" user (501; 502; etc.)


    I'm a bit surprised at how difficult it is to simply purge those things, but I did do this:

    a safe boot (which cleans out a lot of stuff) followed by a bunch of low-level cache cleaning using Mountain Lion Cache Cleaner and TinkerTool.


    (None of that caused my problems, which were due to my "experimenting".)


    But it wouldn't hurt to try the safe boot process, just in case it might cure someone's problem here....


    Apple's instructions for safeboot:


    1. Be sure your Mac is shut down.
    2. Press the power button.
    3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).


  • chas0001 Level 1 Level 1

    I have been having the pixelated icon problem since installing 10.8.2.     I seached the Console for SystemUIServer and found out that errors were being reported by


    PocketCloudserver (Wyse)   - cannot remember installing this!

    /library/Quickview/Suspicious Package.qlgenerator


    I unstalled PocketCLoudserver using its own uninstaller and deleted the Suspicious Package.qlgenerator file.    I then rebooted into Safe Mode and rebooted again normally.


    Since doing this the pixelated icon problem has totally gone.    Not sure how long it will last though!


    FYI: I am still using iStatMenus.

  • donazipe Level 1 Level 1

    Dear chas0001,

    as soon as I read your message, I went to check my system.

    I checked /Library/Quicklook for the suspicious package.qlgenerator (ps: quicklook, not quickview on my mac): it was present on my macbook pro, but not on my iMac. (Both macs have the pixelated icon bug). Deleted it.


    I also checked for pocketcloud... I had it on both. So I deleted it using the provided uninstaller script (although it was not running), I did a manual check using iFileX to be sure there were no leftovers...

    Cleaned all caches (ML cache cleaner, deep cache cleaning), restarted in safe boot mode, then back in normal mode...


    Results? Unfortunately no difference...Blurry/fuzzy/pixelated icons on main drive, on mounted dmg...

    and also in unzipped archives (usually, app without icon after the archive is unzipped).

    The only thing that seem to work (just for few seconds...) is to kill systemUIserver, and mount/unzip files right away. Icon looks fine, but just for a short time. On next dmg/unzip, blurry icons are back...


    Concerning iStat menu, I deleted it on my macbookpro but kept it on my iMac. No difference, both show the blurry bug...


    But let's not despair. I start to think this has something to do with the systemUIserver error shown in console.

    You had errors with pocket cloud, removed it and (hopefully) you fixed it...

    I have a different error:

    On the iMac:

    SystemUIServer: ISGetIconFamilyFromStorage: seed mismatch for ......., actual seed is .....

    On MacBookPro:

    SystemUIServer. *** WARNING: - [NSImage compositeToPoint: fromRect:operation:fraction:] is depcreated in MaOSX 10.8 and later. Please use _[NSImage drawAtPoint:fromRect:operation:fraction:] instead.


    I don't have any idea about what they are, what they do, how to fix them.


    I am posting the whole error log in console, just in case someone at apple silently follows this discussion and finds this info useful to help fix the problem:



    06/10/2012 22:36:07.893 SystemUIServer[820]: ISGetIconFamilyFromStorage: seed mismatch for 272408b0, actual seed is ff500542
        1   OSServices                          0x00007fff8984c950 _ZL26ISGetIconFamilyFromStoragejPP17CIconStorageArrayPj + 140
        2   OSServices                          0x00007fff8984c8aa _ISAcquireStorageRefInternal + 19
        3   OSServices                          0x00007fff8984dfa4 _ISRetainStorage + 31
        4   HIServices                          0x00007fff8ee96dc0 CreateCGImageRefFromBitmapInfo + 162
        5   HIServices                          0x00007fff8ee98477 _ZL30ISImageRefCGCacheAddImageEntryPvS_sPK8RGBColorjP18_ISBitmapImageInfo + 241
        6   HIServices                          0x00007fff8ee96285 _ISGetCGImageRefForISImageRef + 2756
        7   HIServices                          0x00007fff8ee9574d _ISCreateCGImageForTypeAtScale + 857
        8   AppKit                              0x00007fff8dde23d4 -[NSIconRefImageRep CGImageForProposedRect:context:hints:] + 17
        9   AppKit                              0x00007fff8dd5de1d -[NSImageRep CGImageForProposedRect:context:hints:flipped:] + 62
        10  AppKit                              0x00007fff8dde2346 -[NSImage _newSnapshotRepForRep:rect:context:processedHints:] + 162
        11  AppKit                              0x00007fff8dd843c8 -[NSImage _snapshotRepForRep:rect:context:processedHints:] + 195
        12  AppKit                              0x00007fff8dd5dd77 __48-[NSImage CGImageForProposedRect:context:hints:]_block_invoke_0 + 305
        13  AppKit                              0x00007fff8dcc34d6 -[NSImage _usingBestRepresentationForRect:context:hints:body:] + 170
        14  AppKit                              0x00007fff8dd5d9e5 -[NSImage CGImageForProposedRect:context:hints:] + 938
        15  Search                              0x00000001065c82a8 MDActivateFinder + 6694
        16  Search                              0x00000001065b214f __MDNodeGetterCopyFunctionNoFetchNoExtension + 24906
        17  Search                              0x00000001065b2944 __MDNodeGetterCopyFunctionNoFetchNoExtension + 26943
        18  Search                              0x00000001065b66a6 MDApplicationsToOpenWithNodes + 4511
        19  Foundation                          0x00007fff8d5dd986 -[__NSOperationInternal start] + 684
        20  Foundation                          0x00007fff8d5e51a1 __block_global_6 + 129
        21  libdispatch.dylib                   0x00007fff8ee79f01 _dispatch_call_block_and_release + 15
        22  libdispatch.dylib                   0x00007fff8ee760b6 _dispatch_client_callout + 8
        23  libdispatch.dylib                   0x00007fff8ee771fa _dispatch_worker_thread2 + 304
        24  libsystem_c.dylib                   0x00007fff94a46cab _pthread_wqthread + 404
        25  libsystem_c.dylib                   0x00007fff94a31171 start_wqthread + 13



    Error on MacBookPro:

    07/10/2012 12:32:40.125 SystemUIServer[8124]: *** WARNING: -[NSImage compositeToPoint:fromRect:operation:fraction:] is deprecated in MacOSX 10.8 and later. Please use -[NSImage drawAtPoint:fromRect:operation:fraction:] instead.

  • chas0001 Level 1 Level 1

    Sorry that it did not work for you.    I have not had a reocurrance of the pixelating since. 


    Have you tried to also run ONYX  I would give it a go.   


    I ran it and made it


    delete all .DS_Files (Maintenance > Rebuild)

    Rebuild Display of Folders content and rebuild dyld's shared cache (Automation)


    Also look at deleting the ~/library/preferences/ then restarting finder.


    You never know!


    Good Luck.

  • David Losada Level 1 Level 1
    Mac OS X

    This is a message from Parallels. Look at the alert sign:

    Captura de pantalla 2012-10-08 a la(s) 13.31.58.jpeg

    What's the relation between this sign and a file icon?


    And look at this:


    a) Icon preview:

    Captura de pantalla 2012-10-08 a la(s) 12.48.26.jpg


    b) Navigating into the package and getting info on the .icns resource the icon looks well.

    Captura de pantalla 2012-10-08 a la(s) 12.48.50.jpg



  • donazipe Level 1 Level 1


    Tried the Onyx suggestions.

    First manteinance>rebuild, then automation>rebuild displays and rebuild dyld cache


    The procedure "cleaned" some icons that were blurry, but did not solve the problem.

    Some dmg, and some zipped archive, mount/expand with blurried icons. Copying to the main drive,  icons remain blurried.


    Only solution... the same, kill SystemUIServer and copy the files right away.


    Anyway, your finding is VERY INTERSTING.

    If you don't see the bug anymore, that means you have found the app/software that was causing the SystemUIServer error in console... Removing the problematic software, you don't see blurried icons anymore.

    Could you check your console and see if that systemUIserver error is gone?


    I wish I were able to identify the source of the problem on both my macs...

    But the more I think about it, the more I see that the problem is in that console error.


    PS: of course I also tried Tracy's suggestion on safe boot. No difference... Any of these procedures appear to cure the symptoms, not the cause. Sooner or later, the blurry icons are back.

  • chas0001 Level 1 Level 1

    This is my console log for SystemUIServer.    I had updated to the latest version of iStat Menus 3.25.


    Hope it helps.


    09/10/2012 00:01:25.324 SystemUIServer[245]:MenuCracker 2.2 (/Library/Application Support/iStat local/extras/


    MenuCracker is now loaded. Ready to accept new menu extras.

    09/10/2012 00:01:25.325 SystemUIServer[245]: failed to instantiate and get the principal class of bundle: NSBundle </Library/Application Support/iStat local/extras/> (loaded)

    09/10/2012 00:01:25.342 SystemUIServer[245]: MenuCracker: Allowing "iStatMenusNetwork".

    09/10/2012 00:01:25.345 SystemUIServer[245]: MenuCracker: Allowing "iStatMenusTemps".

    09/10/2012 00:01:25.349 SystemUIServer[245]: Could not load menu extra NSBundle </Library/Application Support/iStat local/extras/> (loaded) for Class (null)

    09/10/2012 00:01:25.445 SystemUIServer[245]: iStat Menus loading extra - network

    09/10/2012 00:01:25.500 SystemUIServer[245]: -[TCMNATPMPPortMapper refreshExternalIPInThread] NAT-PMP: IP refresh did fail: -7

    09/10/2012 00:01:25.606 SystemUIServer[245]: iStat Menus loading extra - sensors

    09/10/2012 00:01:25.727 SystemUIServer[245]: iStatMenus Daemon version 3.25 (101)

    09/10/2012 00:01:37.534[224]: ([245]) Job appears to have crashed: Segmentation fault: 11

    09/10/2012 00:01:37.688 ReportCrash[349]: Saved crash report for SystemUIServer[245] version 1.7 (369.2) to /Volumes/Macintosh Data HD/Users/*****/Library/Logs/DiagnosticReports/SystemUIServer_2012-10-09-000137_ Macintosh-i7.crash

    09/10/2012 00:01:48.766 SystemUIServer[380]:MenuCracker 2.2 (/Library/Application Support/iStat local/extras/


    MenuCracker is now loaded. Ready to accept new menu extras.

    09/10/2012 00:01:48.766 SystemUIServer[380]: failed to instantiate and get the principal class of bundle: NSBundle </Library/Application Support/iStat local/extras/> (loaded)

    09/10/2012 00:01:48.771 SystemUIServer[380]: MenuCracker: Allowing "iStatMenusNetwork".

    09/10/2012 00:01:48.772 SystemUIServer[380]: MenuCracker: Allowing "iStatMenusTemps".

    09/10/2012 00:01:48.773 SystemUIServer[380]: Could not load menu extra NSBundle </Library/Application Support/iStat local/extras/> (loaded) for Class (null)

    09/10/2012 00:01:48.863 SystemUIServer[380]: iStat Menus loading extra - network

    09/10/2012 00:01:48.884 SystemUIServer[380]: -[TCMNATPMPPortMapper refreshExternalIPInThread] NAT-PMP: IP refresh did fail: -7

    09/10/2012 00:01:48.964 SystemUIServer[380]: iStat Menus loading extra - sensors

    09/10/2012 00:01:49.128 SystemUIServer[380]: iStatMenus Daemon version 3.25 (101)

Previous 1 2 3 Next