Previous 1 2 Next 27 Replies Latest reply: Aug 12, 2013 11:11 PM by gumsie
bill501 Level 1 (10 points)

I cannot play DVDs on a MBPro running 10.8.2 with DVD Player. It will open only if a DVD is not in the drive. I can play the same DVDs with VLC, so it's not the drive. I tried deleting the dvdplayer plists from the user library without avail.


Does anyone have other suggestions





MacBook Pro, OS X Mountain Lion (10.8.2), MBPs x 3 iPad iPhones Mini, G5 MPro
  • gumsie Level 4 (2,155 points)

    I'm not celebrating the prescence of your post here, but at last!! Someone with a similar problem to me?


    Right, can you check the following for me........


    Navigate thus pls;

    DVD Player, (then right click and choose Show Package Contents)> Contents> MacOS and double click the file you see within, (called DVD Player). It should open with a terminal window, then insert a disc, what message do you get in the window?

  • errol5291 Level 1 (0 points)

    I have the same problem. After I follow the steps above I get:


    Bus error: 10



    [Process Completed]

  • gumsie Level 4 (2,155 points)

    The same error as me or the OP?

  • errol5291 Level 1 (0 points)

    Brand new MBP that I picked up last night. When a DVD is inserted and player comes up it unexpectedly quits.

  • gumsie Level 4 (2,155 points)

    If it were me I'd, (assuming the store was close enough), go and have a moan. Or I'd try a Safe Boot, followed by an immediate reboot and if that doesn't work then a Reset NVRAM.

  • errol5291 Level 1 (0 points)

    Those things did not work. I called Apple and walked through a couple of things without success. The person helping me did acknowledge that they are seeing the problem when I told her about it being on the forum. Right now I am reinstalling OSX as per her recommendation.


    I don't have much choice at this point. I need to bring it to my daughter at college tomorrow - 5 hours away.


    I will post the results of the reinstall.

  • gumsie Level 4 (2,155 points)

    Thanks, be interested to find out the solution.

  • errol5291 Level 1 (0 points)

    Well. It fixed the problem with the DVD player and I haven't found anything else so far that does not work. However, it is on 10.8 and I am afraid to upgrade it. So I don't know if it would break again if i went back up to 10.8.2. If I were not pressed for time, I would give it a shot.

  • gumsie Level 4 (2,155 points)

    Cool, I'd not be too afraid of upgrading. If time is an issue though then yes leave it for later. (Make a bootable clone beforehand though).

  • bill501 Level 1 (10 points)

    errol5291 wrote:


    Well. It fixed the problem with the DVD player and I haven't found anything else so far that does not work. However, it is on 10.8 and I am afraid to upgrade it. So I don't know if it would break again if i went back up to 10.8.2. If I were not pressed for time, I would give it a shot.


    What fixed the problem with DVD Player Errrol?


    FWIW when I opened the exec file in the Terminal I got this error:


    err = f8000001 /Volumes/Haxdisk/Projects/DefaultFolderX/DFCarbonPatch/../../Libraries/mach_sta r-1.2-intel-0.3/mach_override/mach_override.c:253


    multiple times with the last 3 numbers different. I can't believe this app is carbonized as this suggests



  • errol5291 Level 1 (0 points)

    Reinstalling OSX back to 10.8 fixed the DVD player issue. From this I would conclude that it is the version of OSX. But, since I did not update it again to 10.8.2 I cannot say for sure.

  • TheWrinklie Level 1 (0 points)

    For your info (and anyone else with this problem), I have a relatively new iMac - 1 month old - tried DVD player for the first time yesterday morning and it wouldn't work whenever there was a disc in the drive.  I phoned Apple UK support and after a few minor tweaks and reboots was taken through the steps to do a complete re-install of OS X Mountain Lion.  What the chap didn't tell me before I started was that Apple expect everyone to have super-fast broadband.  Well, here in rural Britain that's a (very) long shot!  I only get 1mb download speed on a very good day with the wind in the right direction.  My machine started downloading updates at 1000 yesterday and didn't finish until 2230 yesterday..... then I had to 'Check for updates...' which took another 3 hours!!!   Guess what.....?? DVD player still didn't work!


    Judging from the numerous posts here and on related links - this is a MAJOR DVD player bug.  I can't now book another call to Apple Support until this afternoon (but they are going hear what I have to say in their 'How did your support call go....?' e-mail!) so I've tried a fix from another postee which has certainly worked for me.  So if you have this problem, it may be worth a go:-


    1. Go to this link 5241-solved-valid-dvd-drive-could-not-found-70012-mountain-lion-dvdplayback.fra m and it will download the previous Framework version (5.5.0) of DVD Player (current Framework version is 5.6.1).


    2.  In Finder, open the following folders: Macintosh HD ---> System ---> Library ---> Frameworks.  Locate the folder 'DVDPlayback.framework' and rename it 'old DVDPlayback.framework' (just so you still have the original if you need it).  You will need the Administrator password for this operation.


    3.  Take the downloaded folder (which should also be called 'DVDPlayback.framework' and drop it in the 'Frameworks folder' alongside the original folder you have just renamed.


    4.  Now try running DVD Player again and it should work.  Once running, you should be able to go to 'About DVD Player...' on the File menu and it will show you the app version number (which shouldn't have changed) and the framework version number.


    My main gripe here is that Apple Support MUST know that the latest DVD Player has a problem under Mountain Lion but they're not admitting it.  So come on Apple - I expect this kind of deceit from Microsoft but I'm really disappointed that you're just as bad. This is why I've moved from PC to Mac.  If you have a bug, just tell people to bear with you while you fix it - don't send us all round the houses!


    Good Luck!

  • martinfromsouthampton Level 1 (0 points)

    Thank you so much TheWrinklie; it worked like a charm!

  • TheWrinklie Level 1 (0 points)

    Good - I'm so glad it worked for you also!!  Thanks for your feedback.  Just a shame that Apple Support aren't yet owning up to the problem, let's hope the next update for the OS X will rectify this.  

Previous 1 2 Next