13 Replies Latest reply: Feb 12, 2013 10:00 PM by JoshH-011
RCcpa Level 1 (0 points)

Upgraded my Iphone 4S to IOS 6 and my Klipsch headphone remot would not work.  Volume buttons worked, and the center button would start playing music, but it would not stop or pause the songs.  I tried my original Apple earbugs with the remote and did not have any problems.  The I used the Klipsch again, and now they work great.


Sounds strange, but that is what happened.

iPod touch, Windows XP Pro
  • ClausRittig Level 1 (0 points)

    If you find out more, please do tell!

    I'm having the same problem with my in-ear headphones (of all brands), and I can't make them work!

  • ClausRittig Level 1 (0 points)

    (I did try putting in my original iPhone buds, but they won't work either)

    Mine is an iPhone 4, not a 4s.

  • ClausRittig Level 1 (0 points)

    Problem solved.

    iPhone 4, worked fine until I upgraded to iOS6.

    Go to Settings -> Music -> Lydkontrol (sound control?) (Sorry, I'm danish.)

    After the upgrade, "Lydkontrol" (sound control?) was set to O. Set it to I. Still doesn't work. Reboot phone. NOW it works!

  • ranz.k Level 1 (0 points)

    hi Claus.

    I cannot find the Lyfkontrol or sound control as u mentioned above. Where is it?


  • sundirtwater Level 1 (0 points)

    I couldn't find any settings to change so I just rebooted my phone and now it's working again.  Not sure if it will last but it's working now!

  • franklinveaux Level 1 (0 points)

    On English iPads, it is in Settings -> Music -> Volume Limit.


    I was having this same problem; after updating to iOS 6, headphones would not work. I plugged in headphones, went to Settings, then to Music, touched Volume Limit, and set it halfway down. I then went back to Settings, Music, Volume Limit, and slid it all the way up...and my headphones magically started working again. Fr whatever reason, this seems to fix the "headphones don't work" bug.

  • NeoNedz Level 1 (0 points)

    I have tried above suggestions but my earphones remote/control still doesnot work, my phone is 4s any help?

  • M21Falcon Level 1 (0 points)

    NeoNedz - I tried franklinveaux's suggestion and it worked only after I rebooted.


    My issue was my 3rd party earbud remote would not pause, forward, reverse music.

    Volume control and play were the only features working.

  • NeoNedz Level 1 (0 points)

    Thanks MrFalcon,



       But i guess im out of luck, ive rebooted my unit 5x and follow the instruction above but still my headphone's control is not working, its annoying since i need to manually switch music everynow and then manually. I hope apple will do something about this.

  • WhyDidIUpdate Level 1 (0 points)

    I have an iPhone 4S running IOS 6.0.1. I bought the Klipsch S4i Rugged's from the Apple Store. The controls would not work, at all.  I tried them on a friend's iPhone 4S running IOS 6.0.0 and the controls worked fine. I traded the earphones for a different set, and had the same problem. They worked on an iPhone 4S running 6.0.0 but not 6.0.1. I tried all of the workarounds and fixes mentioned above, rebooting, moving the max volume up and down, etc., nothing works. I contacted apple care and the tech knew nothing about the problem but said he would put it in his notes. I also sent an email to Klipsch, explaining the problem. You would think the headphone manufacturers would be on Apple to fix this total mess caused with the advent of IOS 6, especially on headphones "designed" for Apple products. On a side note, it would be nice if Apple would fix iTunes Match as well. The functionality was destroyed with 6.0. 

  • aman09 Level 1 (0 points)

    I am also facing the same problem, recently upgraded to ios6.0.1. Left earpiece of my apple headphones is not working thereafter. Pls do the needful.

  • sonihemish Level 1 (0 points)

    Hi All,


    I was facing all sorts of issues with my earphone controls.


    This solved my problem.


    1. Double click home button. (press twice).This will show you all the apps that you have currently open.
    2. Long click on the 1st app in the list [about 3 seconds]. This will make the icons wiggle and show a red minus sign on the left hand top corner.
    3. Scroll [right] to see your music app (if you can't see it already).
    4. Press the red minus sign. This will completely close the music app.
    5. Restart your music app and things should be back to normal. [I also would close all other app in the same fashion, just in case, cause things like youtube apps use the controls on your earphones as well. ]


    In short: - kill, kill-em-all and restart your music app.

  • JoshH-011 Level 1 (0 points)

    This is the most similar problem that I'm having.  Super annoyed that when I upgraded from 5.0 (I know, old) to 6.1 on my ipod touch (4th gen), the earbud volume control (but not play/pause) stopped working.  tried the same fixes, nothing seems to work.  Annoying!