Previous 1 2 Next 15 Replies Latest reply: Sep 20, 2013 6:39 PM by alexjadams
Wandering Willy Level 1 (0 points)

I have just upgraded from an iPhone 3G to an iPhone 5.  Internet tethering (now called Personal Hotspot) to use up data credit on my phone account worked very well on my old phone.  However when I plug the iPhone 5 cable into my MacBook Pro it is simply not recognised in Network Preferences, as my old phone was.  With the 5 I can tether with either Bluetooth and Wi-Fi, but the response is dreadfully slow and subject to hanging.  I have spent hours on the phone with Telstra (Australia) and Apple with no success.  Has anyone else encountered this problem?  Can anyone help?

iPhone 5, iOS 6, MacBook Pro - MacOS 10.6.8 Snow Leo
  • ShadyMac Level 4 (1,250 points)

    No I have not had that problem...


    I tethered via USB with no issues...


    Toggled off my WIFI on both iPhone and MBP

    Plugged USB cable into MBP and iPhone 5

    Then toggled the hotspot on

    It poped up with a choice to turn WIFI back on or continue USB only

    I Chose USB only and it nearly immediately showed me having 1 connection and when I opened settings > Network on my MBP I showed connected to iPhone 5 with an IP...


    I tested and it worked fine...

  • Wandering Willy Level 1 (0 points)

    Thanks for the quick response, but no joy.  I just went through that very procedure for the umpteenth time, to be sure, and with a clean install of Snow Leopard I have on a USB stick for emergency purposes, to be sure.  The iPhone 3G is recognised right off, the iPhone 5 is not.

  • dchao99 Level 4 (2,055 points)

    A little bit late to your question:  But you need to check if the data plan for your iPhone 5 *does* support tethering.  Carriers all over the world are now realizing they can make money on the tethering plan (thanks to the success of iPhone),  Free tethering is in the past now.


    If the SIM in your iPhone 3G does supports tethering, then you can cut the it with a nano SIM cutter.  And put the 3G SIM into the new iP5.

  • Wandering Willy Level 1 (0 points)

    Tethering works!  If you read my original message, tethering works, just not very well and primarily not at all when connected to by USB cable.  In fact tethering has nothing to do with the USB problem because Snow Leopard Network Preferences does not recognise that the iPhone is plugged in.  Please note, all this (tethering with USB or Bluetooth) worked well with my old iPhone 3G on the same carrier account.


    No, your response was of no help whatsoever!

  • hutchris Level 1 (0 points)

    I'm having a similar problem. I have OS X 10.6.8 and iPhone 4s iOS 6.0. I can use the personal hotspot over wifi but it doesn't work over USB.


    I plug in my phone and nothing happens??

  • Wandering Willy Level 1 (0 points)

    They say misery loves company.   


    Several weeks ago I contacted Apple about the problem and they have finally responded.  I'll be finding out if they have come up with a solution on Monday (Australia time).  I'll pass on any goodies I get here.


    Cross your fingers and hope.

  • IsmaelPineda Level 1 (0 points)

    I do have the same problem, please let me know if apple could fixed it out and how they did. Fingers crossed...

  • Wandering Willy Level 1 (0 points)



    Unfortunately I suspect I have little joy for you.  In the first place I gave up on getting any help from Apple when my emails to the consultant I was dealing with, Drew, bounced.  Perhaps he was fired or quit.  I haven't heard from Apple since.  Then when I updated to iOS 6.0.1, suddenly USB tethering (Personal Hotspot) to my iPhone 5 started to work.  I don't have a clue why.  I now have USB connectivity to both my iPhone 5 and iPhone 3G (iOS 4.2.1).  However I'm now having trouble tethering on wifi with the iPhone 5.  Since I don't really need it and have been otherwise distracted, I've been ignoring the problem.

  • edamamebuffet Level 1 (0 points)

    Hi, I was looking at this thread while figuring out why my USB tethering was not working.


    I figured out the solution for my situation at least.


    System Preferences > Network


    Check to see if an "iPhone USB" item exists on the list on the left.


    If not, click the "+" icon below,

    Interface: iPhone USB

    Service name: iPhone USB

    Click "Create"


    Click "Apply"


    Now try turning Personal Hotspot on your iPhone off then back on.


    Hope that works for everyone.

  • Oghma Level 1 (0 points)


    I tried this (because I'm suddenly unable to connect to Personal Hotspot via USB), but when I click the "+" icon I don't see "iPhone USB" in the list of interfaces.


    The interfaces I see are:




    Bluetooth DUN




    6 to 4


    (Tethering via Bluetooth and Wifi is fine, BTW, and I can connect/sync my iPhone to iTunes via USB without problems)


    Any ideas how to get the iPhone to show in the list of interfaces?


    My MacBook is a 2008 model, running Lion (10.7.5), the iPhone is an Iphone 4 running iOS 6.1.3

    Note - it doesn't appear to be  problem with the iPhone, as the same problem occurs with a different iPhone with different version of iOS6 (older)




  • Alfista_SK Level 1 (0 points)

    I have the same problem with iPhone 5 6.1.4 and Lion 10.7.5.

  • lucastle Level 1 (5 points)

    Hi, I had this problem before, solved it.  Then it happened again and I couldn't find the place where I found the solution, but it was still in my download folder so I'd like to share it with you friends.  I uploaded the "kext utility" plus a functional KextUSBEthernet file.
    (this worked with leopard) iphone 4 and 5.
    I also found an updated version of the Kext Utility for more recent OSX


    hope that works for you.

  • lucastle Level 1 (5 points)

    BTW unzip the file, run the Kext Utility (put your password when requested) drag the functional Kext file (included) and well its that simple.. oh and restart your computer.

  • chad von nau Level 1 (10 points)

    I was able to fix this same issue by using the kext from the iTunes 10.6.3 installer. More detail about how to do this here.

Previous 1 2 Next