6 Replies Latest reply: Nov 4, 2012 3:39 PM by fmon
LA_Hockey_Dad Level 1 Level 1 (0 points)

Hi-

 

My Disk Utility application opens but hangs on the "Gathering Disk Information" screen and I get the spinning wheel of doom. I let it spin for minutes/hours and it doesn't seem to matter. I have to Force Quit to get out of it.

 

I searced for a preference file to try trashing it and creating a new one but no luck in my search by name.

 

Any help would be great. Thanks!


OS X Mountain Lion
  • 1. Re: Disk Utility: Application Fails To Open / Must Force Quit
    macjack Level 9 Level 9 (50,510 points)

    Go to your Finder "Go" menu hold the option key to choose "Library". Then go to Preferences/com.apple.DiskUtility.plist and delete it.

    Relaunch DU and test.

  • 2. Re: Disk Utility: Application Fails To Open / Must Force Quit
    LA_Hockey_Dad Level 1 Level 1 (0 points)

    macjack-

     

    Cool trick to get to the library faster. Love it. I'll add that to by bag of tricks.

     

    I deleted the .plist and a related lock file, emptied the trash and launched Disk Utility again. Unfortunately, the same result. Still hangs on the "Gathering Disk Information" step.

     

    Any other tips? Thanks!

  • 3. Re: Disk Utility: Application Fails To Open / Must Force Quit
    macjack Level 9 Level 9 (50,510 points)

    Have you tried starting in Safe Mode and see if the problem still occurs?

    Restart holding the "shift" key.

    (Expect it to take longer to start this way because it runs a directory check first.)

     

    If this works look in System Preferences > Users & Groups > Login items and disable any third party login items. Also look in /Library/Startup Items. Nothing is put in that folder by default, so anything in there is yours.

     

    btw - you can disregard lockfiles they are all 0k.

  • 4. Re: Disk Utility: Application Fails To Open / Must Force Quit
    LA_Hockey_Dad Level 1 Level 1 (0 points)

    macjack-

     

    Another good suggestion but the progress bar never gets past 1/3 of the way. I tried a second time and it stuck around the same place and after 45 mins or so I had to hold down the power button to restart and get back to work.

     

    How long should the Safe Mode start up take? I have a Mac Pro with 4 2TB drives and OS 10.8.2 and 8GB RAM.

     

    Thanks!

  • 5. Re: Disk Utility: Application Fails To Open / Must Force Quit
    macjack Level 9 Level 9 (50,510 points)

    It sounds like it's hanging on the disk check.

    Boot up holding command-r keys into your Recovery Volume.

    The screen should give you these choices...

     

    Restore from TM backup

    Reinstall Mac OS X

    Get help online

    Disk Utility

     

    Run Disk Utility > Repair Disk, if you get errors run until no errors reported or reports "the disk cannot be fixed".

  • 6. Re: Disk Utility: Application Fails To Open / Must Force Quit
    fmon Level 1 Level 1 (0 points)

    LA Hockey, I don't know if you ever worked this out, but I had exactly the same problem while trying to troubleshoot some issues with my Time Capsule backups. If I had the Time Capsule drive mounted when I started DU (which I had to do to make is visible so that I could verify the volume), DU hung as per your description, but if the TC wasn't mounted, DU started normally. Ultimately I realized that if I left it long enough, DU started, appropriately listing the Time Capsule volume. It seemed to take about 15 minutes for this process to complete. Maybe it has something to do with the large size of the sparebundle file, I don't know.

     

    So- if you're using Time Machine, try ejecting the backup disk before you start DU and see if that helps at all.