1 Reply Latest reply: Sep 28, 2012 6:22 PM by Niel
betweenrides Level 1 Level 1 (0 points)

I am being told I need 10.6.8 to install iTunes 10.7 so I can synch my new iPhone 5.


iMac, Mac OS X (10.5.8)