5 Replies Latest reply: Sep 29, 2012 8:51 AM by Cookiebher
Cookiebher Level 1 Level 1

I have the first generation of the ipod and I keep trying to install this app, but it just keeps showing this pop-up that says 'This app is incompatible with this ipod touch'

 

Please help


iPod touch
Solved by lllaass on Sep 29, 2012 8:48 AM Solved

Only by gettign new model iPod or other iOS device like iPhone or iPad.

Reply by Connie99 on Sep 29, 2012 8:41 AM Helpful

When Apple released iOS 6, they upgraded some apps as well. Many apps like Facebook for example, are not compatible with old versions of iTouch.

All replies