Previous 1 2 Next 24 Replies Latest reply: Mar 18, 2013 12:12 AM by chiefsub63
Byronski Level 1 Level 1 (0 points)

Since I have updated to Mountain Lion, my mail keeps disconnecting intermittently.  I have to quit Mail and re connect.  I have a hard wire LAN connection


iMac, OS X Mountain Lion (10.8.2)
  • LousyFool Level 4 Level 4 (2,640 points)

    Can you describe the symptoms of "disconnecting" in detail, please?

    IMAP, POP3, Exchange?

    In preferences, what interval for checking mails is set?

  • Byronski Level 1 Level 1 (0 points)

    Get a small icon on the left hand side (Mailbox list) showing disconnection symbol.  This happens on all my 3 account on Gmail, iCloud and Sky aheich are all iMap

    Mail is set for checking every 5 minutes

  • LousyFool Level 4 Level 4 (2,640 points)

    I only get this if a mail server is temporarily not available. Without any further action it goes away upon next successful connection with the server (in your case after 5 minutes).

     

    Leads me to suspecting that your Internet connection and/or network settings could be a bit "messy"?

  • Byronski Level 1 Level 1 (0 points)

    Could this be when the computer goes to 'sleep'.  Got it again after computer wen to 'sleep' overnight.  The icon is a small triangle with a ! inside.  Unable to force it by saying 'Mailbox', 'Take all accounts online'  Only solution is to Quit Mail and all the mails keep flooding in.

  • LousyFool Level 4 Level 4 (2,640 points)

    Questions:

    Could you click on one of the triangles and tell what the error message is?

    Would it be the same if you quit Mail before sending the Mac to sleep, then launched Mail after it woke up?

    Do these arrows pop up every 5 minutes again when Mail is checking for new messages again?

     

    I bet the answer to the last 2 questions is "no"...

     

    WiFi, or Ethernet wired? What's your router set up to? Does it time out connections or renew DHCP leases often? I suspect that, upon waking up with Mail active, Mail is the first to right away check for new mail, even before the communication in between Mac and router is established.

     

    P.S.: If still unclear after all of the above, next thing will be to check the log... it's all in there...

  • Byronski Level 1 Level 1 (0 points)

    Many thanks for taking an interest in my problem.

    When I click on triangle, get message - Unable to connect 3 accounts have connection failures.  When I click the indicator next to each account for details, I am offered to "Take All Account Online" but that doesn't work.  If I "Open Coonection Doctor" the SMTP account types connects but none of the iMAP accounts open, with the status Mail unable to opne any accounts.

     

    You are right in that the answer to your 2 questions is NO.  If I close Mail before it gors to sleep or if I close it and reopen, it all fires up properly and stays connected.  It looks like its the sleeping of the computer is doing it, but I didn't have this problem before I upgraded to Mountain Lion.

     

    My router is set up with a hard wired ethernet.  I don't understand your last 2 paragraphs.  Where do I check the log?  I wouldn't know where to setup anything on the router.  I have a LAN extender TP-Link where I connect my router to a TL-WPA281KIT and at the computer end, it connects to a TL-PA Mini Powerline Adapter

  • LousyFool Level 4 Level 4 (2,640 points)

    You are right in that the answer to your 2 questions is NO.  If I close Mail before it gors to sleep or if I close it and reopen, it all fires up properly and stays connected.  It looks like its the sleeping of the computer is doing it, but I didn't have this problem before I upgraded to Mountain Lion.

    I am convinced that in Mountain Lion, when it comes back out of sleep with Mail active, Mail is trying to go on-line before your network/Internet connection is established, leading to the first check going "wrong", and only from then on - 5 minutes later - things going normal and well.

    One way to maybe work around it is checking mail manually then, once only when the triangles are there, either by pressing Shift-Command-N, or by adding the "Get Mail" icon to the toolbar, if it's not there yet, for you click on it.

     

    Don't mess with the router if you're not familiar with it, I was just wondering if it could be set to respond faster after some inactivity, or whatever could cause it.

     

    The Mac's log would have been helpful if you had a general mail problem, but you don't, other than the periphery being "too slow for Mail". So, except for that all is good, and improving this could be a task for once you have a true network/router expert visiting...

  • Byronski Level 1 Level 1 (0 points)

    You may be right that this is a Mountain Lion issue.

     

    I have disconnected the hard wired ethernet LAN and went Wireless direct to my router, which I have been using for over a year.  And yes the problem is still there in that I get the same error message.

     

    Do you think it will work if I wait for 5 minutes after I have woken the computer, it would work.  Forcing it to go online doesn't work. Shift-Command-N does not work.

     

    Is this a general problem with Mountain Lion?

  • LousyFool Level 4 Level 4 (2,640 points)

    It is not an ML "issue" as in "problem". For example, I myself very much appreciate how fast my MBA wakes up and goes to work, e.g. checking emails. IOW, I don't experience that same error, and probably most people don't, otherwise we'd be flooded with "me too" posts.

     

    Some thing else is "asleep" in your network or Internet access. Again,

    improving this could be a task for once you have a true network/router expert visiting

     

    BTW, mind me asking, who is your ISP, where do you get your Internet from? Please don't tell me it's via satellite... that might explain it...

  • Byronski Level 1 Level 1 (0 points)

    Something as affected my network settings since ML has been downloaded. Will have to take my Mac in to the shop for a 'Genius' to look into it.

     

    Pardon my ignorance, but what does MBA (is it Mac Book Air), IOW BTW stand for?

     

    My ISP provider is Sky in the UK, which runs off the telephone line.  I know its a different OS, but my iPAd and iPhone do not have this problem.

  • LousyFool Level 4 Level 4 (2,640 points)

    Good luck then.

     

    MBA = MacBook Air

    IOW = in other words

    BTW = by the way

     

    LOL.

     

    OK?

  • gethinc Level 1 Level 1 (0 points)

    You are not the only one.  I had the same problem which has been driving me nuts for the last two days.  Then I found this solution to a different Mail problem posted by graphicsluc, and tried it, and it appears to work.  For now.

     

    shut down

     

    then turn on computer while holding command R

     

    when OS Utilities window comes up go to the top menu bar and click Utilities, then Terminal.

     

    type (all one word, lower case): resetpassword

     

    hit return

     

     

    go to the bottom of the reset password window that comes up,

     

    select the HD

     

    then click the Reset button at the bottom under "Reset Home Folder Permission and ACLs"

     

     

    then wait for it to finish (it takes a while)

     

    click the red button to close the finder.

     

    then go to Terminal at top,

     

    Quit Terminal.

     

    Then restart under the apple logo icon.

     

    As I say, it worked for me. 

     

    G

  • gethinc Level 1 Level 1 (0 points)

    Sigh.  Ignore that.  It worked once.  Then it broke again. could not connect to the google imap server and could not connect to the iCloud imap server, it says.  But it says mail is able to connect to the Internet.  Ad if i close mail and reopen it, it works again.  So, I'm still looking for a solution too, should anyone have any bright ideas that don't involve me having to give Apple Support the £35 they are demanding to offer me assistance with the software I just paid for. 

  • Byronski Level 1 Level 1 (0 points)

    Just seen a big thread on the discussion site.

     

    Mountain Lion disconnect from Ethernet in sleep mode

     

    I am not the only one.

     

    Will just have to wait until Apple get a fix for it.

Previous 1 2 Next