13 Replies Latest reply: Nov 30, 2012 2:25 PM by SB7523
SB7523 Level 1 (0 points)

I am at a loss - been unable to export any photos via the File>Export>Versions or Originals option in Aperture 3.4.


This seems to have happened after I upgraded to the most recent version of Aperture, but I'm not 100% sure this is the problem.  I have tried exporting a single photo and multiple photos.  Every time I get an error dialog box, Export Results, that states "Export Versions Complete with Errors".  I then states 0 of 1 file has been exported (the 1 changes based upon how many I've attempted to export).  Below that it states "The export operation failed to create a file for the version identified below".  It then lists the filename of the image I attempted to export.


I've tried removing, then reinstalling Aperture through the App Store - no luck.


On a side note, I used iPhoto to export the photos from my Aperture library, and it works fine. 


Thanks for any help on this!Error.jpg

MacBook Pro (Retina, Mid 2012), Mac OS X (10.7.5)
  • Frank Caggiano Level 7 (25,715 points)

    Have you tried exporting to different folders on your drive? Where are you exporitng to?

  • SB7523 Level 1 (0 points)

    I've tried exporting to different folders including my desktop.  I have also confirmed that over 100GB of free space exists on the drive.

  • Frank Caggiano Level 7 (25,715 points)

    Always the same message?


    You'll need to look in the Console logs to see if the system is reporting any errors when you try to export. The Console app is in the Utilities folder located in the system Applications folder.


    When you open it select the first entry in the System Log Queries column, 'All Messages' then select 'Clear Display' from the menu bar.


    Now try the export from Aperture and see if anything shows up. Report back.

  • SB7523 Level 1 (0 points)

    Thanks for the help...



  • Frank Caggiano Level 7 (25,715 points)

    Nothing in the logs looks like it applies here. What happens if you drag  an image out of Aperture and place it on your Desktop. This will only be exporting the preview but might supply some information concerning your problem.


    Also what preset are you using? Are you trying to export JPGs or TIFFs or ?? Have you tried different presets and file types?


    Finally where is the library and masters stored? Are the masters managed or referenced?

  • SB7523 Level 1 (0 points)

    Sorry about the delayed reply - been unplugged for the last week.


    I tried dragging and dropping an image from my Aperture browser to the Desktop and it copies a lower resolution version of the file (JPG format).  Looks like it may be copying the preview only?  I haven't done anything with my Aperture library location, so all of the master images are on the same drive as my library.  I checked the "Locate Reference Image" option just in case, but it says there are no referenced files...


    Only thing I could think of...is this new dual use of a library for Aperture and iPhoto possibly causing a problem?  I'm not 100% sure, but it seems that this error I'm getting is timed with when I upgraded to the newest version of Aperture.


    Answering the rest of your questions...doesn't matter the preset I try to use, I always get the same error message.  This even happens if I try to export the original RAW file. 


    My library is stored on my hard drive, and the masters are there as well. 



  • SB7523 Level 1 (0 points)

    Is there anyone else out there having this problem with the newest version of Aperture?  I am completely unable to export any files, just tried to export a video that was imported in my last batch...nothing.  Any work-arounds out there that someone can think of?  What recourse do I have getting some help with this from Apple?


    Is there an Apple Aperture tech support person in the house?

  • Frank Caggiano Level 7 (25,715 points)

    When you didn;t post back I assumed the problem resolved itself.


    You're next steps are to make a new empty library import a few images into it and try the export. If that still fails make a new user and again make a new empty library, import and then try the export.


    As to your question about any Apple techs here. No this is a user to user forum if you require help from Apple you'll need to contact Apple directly.



  • SB7523 Level 1 (0 points)

    Many thanks for your response...seems like I may be getting somewhere now.


    I tried your first suggestion, no dice.  The new library and import of images under my primary user account resulted in the same error message.   However, when I logged in under another user account on my computer, opened Aperture, created a new library and attempted an import, it all worked as it should.


    So, with my limited OS X experience, does this mean I have a corrupted user account?  I have done all my work under this account, so it seems that it would be a lot of work to do everything under another account.  Is there some way to start a clean slate under my current account with aperture?  As always, any help you can provide would be great!



  • léonie Level 10 (90,550 points)

    So, with my limited OS X experience, does this mean I have a corrupted user account?  I have done all my work under this account, so it seems that it would be a lot of work to do everything under another account.  Is there some way to start a clean slate under my current account with aperture?  As always, any help you can provide would be great!

    Just a short answer, till the sun rises in Florida and Frank can be back to this thread:

    It means, that one of the different settings between your user account and a new user account may be causing this. Possible reasons:

    • Permissions and ownership settings in your user account. If you do not own files in your user library or they have the wrong permissions, Aperture may be unable to access or modify the files.
    • Corrupted Preferences and preset files (export presets, raw decode presets, file naming presets) in your user library.
    • Corrupted caches
    • Non standard helper applications you are using (export plug-ins, haxies) or launching as start-up items.


    Things to try:


    Good Luck


  • Frank Caggiano Level 7 (25,715 points)

    Glad we made some progress. What this means is that something unique to your account is causing the problem. This usually comes down to a file or files in your ~/Library folder, hopefully it will be an Aperture related file as this will greatly simplify things.


    Léonie covered it pretty well, doing the steps with the Aperture preference files is a good place to start. As is the boot into single user mode.


    Just a few additional thoughts:


    Is your primary account an Admin account? If not was the test account made as an Admin account?


    I asked and you answered that you had tried exporting to different folders, are the folders you're trying to export to on the internal drive or on an external?


    When you exported using the test account you of course not   export to a folder in your original accounts user area. Was there a common folder that you did export to that worked with the test account but not with your user account?


    One other test  try to export from each account to /Users/Shared what happens.



  • SB7523 Level 1 (0 points)

    Thanks to you both for your time and help troubleshooting.  The problem is resolved - am now fully able to export photos and videos out of Aperture.  I'm not 100% sure which was the solution, either repairing permissions to the hard drive or deleting the user profile step described at the link provided (Aperture 3: Troubleshooting Basics). 


    Again, many thanks!

  • SB7523 Level 1 (0 points)

    I don't suppose you could try to assist me again.  This same thing has happened again. The fix was to delete the user profile.  I've gone back in and done that again, but a few days later, I'll be unable to export photos with the same error.  I've gotten around it by switching the library over to iPhoto, but it's kind of a pain.  Any ideas why my user profile would keep corrupting the program?