3 Replies Latest reply: Dec 30, 2012 8:22 AM by Klaus1
AlejandraCouret Level 1 Level 1 (0 points)

I have just bought an iphone5 and my itunes says i must download the latest version... 10.7

My computer doesn't let me download it saying i must have mac os x version 10.6.8 or later.

My computer is a mac os x version 10.5.8... does this mean i can not download this update? and that i will not be able to sync my new iphone??


Please help!

MacBook, Mac OS X (10.5.8), new iphone 5
  • Klaus1 Level 8 Level 8 (47,335 points)

    Yes, that is correct.


    First check to see if your Mac can run Snow Leopard:


    Requirements for OS X 10.6 'Snow Leopard'




    Whilst Apple have withdrawn Snow Leopard from download, you can still get it from Apple by calling 1-800-MY-APPLE (if you are in the USA) and they will supply the SL DVD for $30.  You can also purchase the code to use to download Lion from the same number.


    If you are outside the US call your national Apple Helpline:




    If you're in the UK, use this number: 0871 508 4400


    When you have installed it, run Software Update to download and install the latest updates for Snow Leopard.

  • kaspar2012 Level 1 Level 1 (0 points)

    i dont really understand what your saying. my mac wont allow me to download it aswell (i am trying to do it as an apple advisor said to do this as lots of my purchased songs didnt download). it is very frustrating because it downloads and then after half an hour and its done downloading it says "do you want to install itunes" then i click on that and it say "im sorry but itunes acnnot be installed on this computer". i alresdy have the old version of itunes.

  • Klaus1 Level 8 Level 8 (47,335 points)

    You need to be running Snow Leopard 10.6.8 in order to use iTunes 10.7. You are running leopard.


    Now follow the instructions in my post.