Previous 1 3 4 5 6 7 Next 121 Replies Latest reply: May 6, 2015 11:55 PM by RoDiBi Go to original post
  • smags01 Level 1 (0 points)

    same exact problem here.  I have comcast and the TG862G Arris router and iMessage photos will not send and photo stream also does not work (new pictures taken with my iphone just sit in the camera roll and never move over to My Photo Stream).  Definately something wrong with this router.

  • satyrsynth Level 1 (0 points)

    I was having a similar issue where my iphone 5 would not allow me to enlarge images sent via imessage. This problem started directly after setting up imessage for my new macbook air with mountain lion. Here is how I fixed it:


    1. Reset your network settings on your iphone. Settings > General > Reset > Reset Network Settings (this may be all that is necessary)


    2. Make sure your osx is updated to the newest version, I believe there is a fix for this in the 10.8.2 update.

  • rayfromfairlawn Level 1 (0 points)

    Finally my iMessages is working thanks to a coworker (Mr.Mitchell).

    1.go to settings and turn off iMessages. home button twice. and hold an app icon on the bottom

       until you see a red minus sign.

    4.delete all of the icons via the minus sign. the power button and home button until

       you see the apple logo then release both buttons.

    6.go back to settings and turn read receipt on.

    7.turn iMessages on and wait until iMessages has reactivated.

    8.send a picture message.


    I hope this helps.

  • Jeffsilva27 Level 1 (0 points)

    I have a Comcast Arris tg862 modem/router. My Iphone and iPad on iOS 6.0 were not able to send pic imessages while at home using wifi. I bought a new netgear router, hooked it up to the comcast modem/router and my problem was solved. Don't believe Comcast when they tell you that the arris tg862 is not the problem bc it clearly is. I tried to get a different model router from them but they basically refused and told that it wasn't the problem. I'm done dealing with comcast and the $30 router was well worth not having to call them anymore. Good luck. Hope this helps.

  • Jsslanders Level 1 (0 points)

    If Comcast refuses to help you, free of charge, first ask to speak to a manager/supervisor. If that doesn't work, tell them that you are switching service providers. If they don't want to loose your biz then they'll fix the issue. If not, they don't deserve your biz anyway. Don't forget to mention how long you've been a customer and how many colleagues/friends you'll tell about their excellent customer service.


    Good luck!

  • jayhaldors Level 1 (0 points)

    I did this and it fixed my issues. I have Comcast and the identified give it a whirl!! Thank you rayfromfairlawn! ;)

  • phillip5690 Level 1 (0 points)

    FOUND THE MOST SIMPLE FIX!!!!!!!!!!!!!!!!!!!!!!!!


    Go to settings, go to wifi, when you see your wifi click the little blue arrow. Go to DNS and change it to


    Send a picture!

  • SLM98 Level 1 (0 points)

    Oh my gosh Phillip5690.....THANK YOU!!!  That worked on my ipad2!!!  I have the comcast router that has been discussed above and didn't want to go through the bother of switching it out as I had just gotten the questionable router back in June as my previous one was outdated.  This simple solution has did you ever figure that out??!!

  • phillip5690 Level 1 (0 points)

    I had the same problem with the same new router that comcast sent out. Didn't feeling like going thru the process of switching it all up again. lol But I remembered google had a public DNS. So I tried it... and it worked!!!



  • Hamzabutt Level 1 (0 points)

    I hope these steps may help you.


    1st      turn off your cellular data off

    2nd     then switch to WiFi

    3rd     send any picture to your own iMessage id. (for verification)

    4th     if it works then continue using this method.



  • fzebra Level 1 (0 points)

    If you have comcast and you have an additional router, you can solve the problem by having comcast switch your router to full bridge mode and then use your own router for DHCP, WiFi, etc.  There are many posts in the comcast, but here's one:



    You can search for others - there are many threads related to this.  In many of the comcast posts, they tell you to call 800-363-2416 and have them switch it.  I found that number worthless - after a minute on hold, it kept telling me "sorry, we can't take your call" and then hung up on me.


    In the forum I linked to above, there is a post from Baric on 10-14-2011 that says to send a private message to ComcastLarry to switch you to bridge mode and he provides a link to create the private message.  Click on that and then send Larry a message asking him to switch you.  I did that, and in less than 30 minutes he switched me.  I was already running a Netgear wireless router inside the Comcast router, and it immediately started working.  I can now send pics via iMessage. 


    On an related note, my Chase mobile app was also not working after upgrading to iOS 6.  After switching the comcast router to bridge mode, the Chase app started working again too.


  • SLM98 Level 1 (0 points)

    Well switching to the DNS worked for a I'm back to the same old problem.  Was having problems with both imessages and pics on my ipad2.  The imessages are working again, but the pics will again no longer send.  I'm beginning to think i have no choice but to go to Comcast and request a new modem

  • phillip5690 Level 1 (0 points)

    Yes me too.. Out of no where it stopped working for me as well a couple of days ago. I think I'm just gonna have to switch me modem! :/

  • vivrantloven Level 1 (0 points)

    STarted having this issue when I switched to Comcast as my Internet provider. Read another forum and it seems to be the same common denominator. Some sort of comparability issue between the ios6 update and Comcast/Motorola modems.

  • brenna123 Level 1 (0 points)

    Recap and update...

    I updated my iPad3 software in late sept. iMessage at that time stopped sending pictures. I complained to apple who told me to complain to Comcast who told me to complain to apple and so on and so on.  From my previous posts you'll see that I discovered while trolling the Comcast support forums that my Arris TG862 modem, which has the wireless gateway build in so no need for a router, was having issues with blocking many things via wireless... My husbands Xbox was also a victim there but we blamed the Xbox like Comcast said it was.  I called many times to talk to Comcast about this, I had multiple live chat conversations with them. I even stopped a Comcast tech to talk to him about it when he was working on my neighbors service. Every time I was told... The Arris TG862 is the best top of the line modem out there today... There are no upgrades, it must be the other devices with the problems.   I've been in many other places with my iPad, on many other wireless connections sending pictures just fine. But not from home.  So last week I called comcast again. I told them to downgrade my modem.  The rep was stunned by this request, I explained the last 3 months of issues and she insisted it was not the modem and I had the best equipment.  So I told her that since Verizon's service was working that I would be leaving Comcast after being with them for 17 years and going to the service that actually worked.  They overnighted me an Arris TM822 modem, I attached my old belkin router, and it was like a magic fairy sprinkled Internet dust over my devices.  I can now send pictures with no delays, and my husbands Xbox wireless is working once again.


    Do not let them make you believe it is anything other then these modems.   The Arris TG862 and the Arris TG852.

    Get rid of them, get an external router if you have to, but those 2 modems are the issue.

Previous 1 3 4 5 6 7 Next