Skip navigation

My ipod won't connect. Unknown error 0xE80000064. I've tried everything please help!

3511 Views 2 Replies Latest reply: Sep 30, 2012 3:23 PM by rack0 tack0 RSS
AzureDaze Level 1 Level 1 (0 points)
Currently Being Moderated
Sep 30, 2012 3:01 PM

I have a 2 gen iPod touch earlier today I was browsing on safari and it froze on me. I hit the home button nothing worked so I knew I'd have to restore it. My sleep button has been broken for over a year so I couldn't restart it. I pluged my iPod into the computer to restore it (this would be the second time in 3 weeks). I left and let it do its thing but when I come back an hour later its on the charge screen and it says its unable to restore. I thought this might have come up because my internet connection dropped. So I reset my connection and pull up itunes again and try to restore it only to get the unknown error message. I've gotten this before and fixed it. But NOTHING seems to be working. Btw I have a pc.

 

I've updated itunes, restarted my computer, ended tasks in task manager, ended the apple mobile device and started it again. I don't know what to do. I tried switching chargers with my sister still didn't work and I pluged my ipod into her computer and got the same error. Its just stuck with the wrong date and time and a green battery. If nothing works will the battery eventually die and I can just plug it back up? Or is it just time for me to get a new ipod? =/

iPod touch, iOS 4.2

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.