11 Replies Latest reply: Jan 3, 2013 3:58 PM by RockMutchler
idolman2u Level 1 Level 1

My iPad and iPod went nuts and rebooted telling me, "Activation Required" and when trying to activate, it tells me it may take a few minutes. Then says:

Your iPod touch could not be activated

because the activation server is

temporarily unavailable. Try connecting

your iPod touch to iTunes to activate it,

or try again in a couple minutes.


If this problem persists, contact Apple

Support at apple.com/support


This also said this on the iPad but instead of iPod touch it said iPod. PLEASE! ANYONE HELP!


iCloud.com, Mac OS X (10.7.2)
Solved by timothymh on Sep 30, 2012 6:51 PM Solved

It's because you were on the iOS 6 beta, which just expired. You'll need to get the final 6.0 release from the developer iOS portal here and install it manually.

Reply by dfeifer on Sep 30, 2012 6:06 PM Helpful

Same issue. There are a few threads starting about this now. Obviously something freaky is going on with apples servers. One of the squirrles maybe died due to the sustained macintosh diet? <shrug>

Reply by Brooney6 on Sep 30, 2012 6:08 PM Helpful

Same problem here

All replies