1 2 3 Previous Next 33 Replies Latest reply: Jul 12, 2013 6:33 PM by mikefromthe canyon
sam b. Level 1 Level 1 (0 points)

Friends,

I have scoured the message boards of many self help communities and cannot find a great deal to resolve my question and that of many others -  Safari taking ages to load a page or not at all - having to hit reload several times to get the page to load. I have tried Firefox and Chrome with no problems on the same web pages. This has only started in the last week or so. I am on OS 10.8.2. I have treid the following solutions which do not work for me:

 

Resetting Safari

 

Manually and with software dumping of Safari and Java caches

 

Disabling all Extensions

 

Removing all Website Data

 

Removing Safari's folder to create a complete new one in ~Library

 

Changing DNS

 

Turning off Prefetch DNS

 

Checkiing for virii

 

Turning off virus software

 

Starting up in Safe Mode

 

Repairing Permissions

 

Repairing Prefs

 

Starting up in a Test Guest account

 

Unsyncing Safari from iCloud

 

Making sure of my router having the latest firmware

 

All to no avail. Anything I am missing here in an attempt to solve this issue?

 

Thanks for reading this and cheers for now,

sam


Mac Pro, OS X Mountain Lion (10.8.2), 3 gig ram
  • 1. Re: Safari 6.0.1 page loading slow or not at all
    ~Bee Level 7 Level 7 (30,770 points)

    sam --

     

    What app are you using to "Check for virii?"

  • 2. Re: Safari 6.0.1 page loading slow or not at all
    sam b. Level 1 Level 1 (0 points)

    Hiya ~Bee, thanks for asking....I am using ClamXav (latest iteration) and I forgot to mention that I have also tried and failed when I disable ClamXav too. Hope that you might have a great idea for me......

    cheers,

    Sam

  • 3. Re: Safari 6.0.1 page loading slow or not at all
    ~Bee Level 7 Level 7 (30,770 points)

    Good answer, Sam!  ClamXav is great.  I was terrified it was Norton!!!!!  (Yikes)

     

    OK, now, concentrate.

    What did you do to the Mac in the "last week or so?"

     

    Did you upgrade anything?  Add any new internet apps/plugins/extensions?

    I would bet you did. 

    (Based on my own personal experience, LOL)

     

  • 4. Re: Safari 6.0.1 page loading slow or not at all
    sam b. Level 1 Level 1 (0 points)

    Thanks Mate!! Love your work. Yes I forgot the obvious - that I had uninstalled v2 Little Snitch and tried out the demo of v3 before I uninstalled v3 and reinstalled v2. I had a paid up version of v2 and did not feel the upgrade was worth the price so I went backwards; so to speak. For what this is worth I also forgot to say that I disabled v2 Little Snitch in my list of "things that I have tried and failed". I used the uninstallers that came with the software...I think that v3 at that time as still in beta or RC but if so it was the last iteration before the general release....bope this means something to your logic processes.....thanks again & cheers!!!!! Sam

     

    P.S. Obviously it was also in the week of the OSX & Safari updates too.

  • 5. Re: Safari 6.0.1 page loading slow or not at all
    sam b. Level 1 Level 1 (0 points)

    For what it is worth, to whoever reads this, I have also now uninstalled Little Snitch and turned off Firewall; neither of which has helped. I also notice that the "Quicklook" function of an embedded URL, in something like Mail or Google search results, are also slow to non-existent. In all cases after a restart, such as after uninstalling Little Snitch, Safari works fairly well but after a few dozen pages viwed it slows down to almost no loading whatsoever...........cheers to all the bright sparks out there who may be able to shed a bit of light on the issue. Sam

  • 6. Re: Safari 6.0.1 page loading slow or not at all
    ~Bee Level 7 Level 7 (30,770 points)

    sam --

     

    Thanks for the info. I'm pretty certain that you've still got something on there that is interfering with Safari. The LS 2 is not combatible with ML, and they claim V3 is.  That said, I'm glad you have it off there.  Can you look around really carefully and tell us what Extensions, Plugins & other Internet apps you have one there?

  • 7. Re: Safari 6.0.1 page loading slow or not at all
    Linc Davis Level 10 Level 10 (118,030 points)

    Boot into Recovery by holding down the key combination command-R at the startup chime. Release the keys when you see a gray screen with a spinning dial.

     

    Note: You need an always-on Ethernet or Wi-Fi connection to the Internet to use Recovery. It won’t work with USB or PPPoE modems, or with networks that require any kind of authentication other than a WPA or WPA2 Personal password.

     

    From the OS X Utilities screen, select Get Help Online. A clean copy of Safari will launch. No plugins, such as Flash, will be available. While in Recovery, you'll have no access to your saved bookmarks or passwords, so make a note of those before you begin, if they're needed for the test.

     

    Test. After testing, reboot as usual and post the results.

  • 8. Re: Safari 6.0.1 page loading slow or not at all
    sam b. Level 1 Level 1 (0 points)

    G'day Linc & ~Bee,

     

    I booted into Rcovery mode and the problem still existed; FYI I used the Macupdate site for this test; slow to no loading of the test page.

     

    In the "other" brand browers (after a normal boot) it loads like lightning but not in our beloved Safari. I am assuming, ~Bee, that this Recovery Mode bootup would rule out a conflict inherent in my System of add-ons.

     

    Linc & ~Bee thanks once again for taking the time to help.

    Cheers,

    Sam

  • 9. Re: Safari 6.0.1 page loading slow or not at all
    Linc Davis Level 10 Level 10 (118,030 points)

    How did you disable DNS prefetching?

  • 10. Re: Safari 6.0.1 page loading slow or not at all
    sam b. Level 1 Level 1 (0 points)

    Yes I did but it did not help. I disabled it according to an Apple Knowledgebase doc thru Terminal command. I have turned it back on though well before I tried the Rovery Mode boot (in other words Prefetching was ON during the Recovery boot). Thanks. Sam

  • 11. Re: Safari 6.0.1 page loading slow or not at all
    Linc Davis Level 10 Level 10 (118,030 points)

    Select System Preferences Network. If the Network preference pane is locked, click the lock icon in the lower left corner and enter your password to unlock it. Then click the Advanced button and select the Hardware tab. Select  Configure: Manually and MTU: Custom. Enter an MTU value of 1280. Click OK and then Apply. Test.

    You must apply the change before it takes effect.

    If the issue is resolved, experiment with higher MTU values until you find the highest one that works. The higher the MTU, the better the network interface will perform.

    If changing the MTU has no effect, restore the Configure setting to Automatically.

  • 12. Re: Safari 6.0.1 page loading slow or not at all
    sam b. Level 1 Level 1 (0 points)

    Once again thank you but that did not help. I have reverted to Auto and the MTU is back at Standard 1500. Sorry that you ahve to take so much time here.....but it is welcome, I must say...cheers, Sam

  • 13. Re: Safari 6.0.1 page loading slow or not at all
    sam b. Level 1 Level 1 (0 points)

    Linc - Interestingly in reviewing my actions I decided to try the Prefetching command again but came up with the following result from Terminal:

     

     

    Last login: Tue Oct  2 08:21:08 on console

    You have mail.

    sam-bienstocks-mac-pro:~ sam$ defaults write com.apple.safari WebKitDNSPrefetchingEnabled -boolean false

    -bash: defaults: command not found

    sam-bienstocks-mac-pro:~ sam$ defaults write com.apple.safari WebKitDNSPrefetchingEnabled -boolean false

    -bash: defaults: command not found

    sam-bienstocks-mac-pro:~ sam$ defaults delete com.apple.safari WebKitDNSPrefetchingEnabled

    2012-10-02 10:38:25.224 defaults[1222:707]

    Domain (com.apple.safari) not found.

    Defaults have not been changed.

    sam-bienstocks-mac-pro:~ sam$

     

    Do you think that the fact that "command not found" & "Domain (com.apple.safari) not found" has anything to do with this issue?

    cheers,

    sam

  • 14. Re: Safari 6.0.1 page loading slow or not at all
    Linc Davis Level 10 Level 10 (118,030 points)

    To be honest, not much in this story makes any sense.

     

    You entered two shell commands, both apparently valid, and got an error both times. I could understand that, but then you invoke the same command with different arguments and get a completely different error, inconsistent with the previous one. I can't explain that. I question whether you really disabled prefetching. If you did, I don't have a theory that fits all the information you've provided in this thread. I would have to see for myself to believe that it's completely accurate.

1 2 3 Previous Next