1 Reply Latest reply: Oct 1, 2012 8:33 AM by randers4
lpg12 Level 1 Level 1 (0 points)

I have several phone numbers associated with my account and those numbers are getting my imessages


iPhone 4, iOS 6
  • randers4 Level 9 Level 9 (62,590 points)

    If you mean that multiple phones are getting your messages, go to Settings>Messages>Send & Receive and do one of the following:

    1. Either uncheck the email address shown under "You can be reached by iMessage at" on all the phones; or
    2. If you want to continue to receive iMessages at this email address, on all but one of the phones, tap the Apple ID at the top, sign out, then sign back in using a different Apple ID (so they are all using a different Apple ID for iMessage).