12 Replies Latest reply: Mar 14, 2014 1:36 AM by malone5287
JazzJunkie Level 1 (0 points)

I downloaded PDF filrs with Safari. (File opens in Safari online from website, then saved to HD from Safari. Can't open the saved PDF's in any app: Acrobat Pro, Preview, etc. Prompt: "There was an error opening this document. The file is damaged and could not be repaired." This does not occur when files are accessed online, then saved from Firefox.

MacBook Pro, Mac OS X (10.7.4)
  • Linc Davis Level 10 (192,325 points)

    Does this happen with all PDF's, including the ones on this page: Apple - Support - Manuals?


    If not, please link to an example.

  • JazzJunkie Level 1 (0 points)

    Seems like it is all PDF's. Here's a relaible test file. I saved it from Safari -won't open. Saved from Firefox -OK.


    At this URL click on PDF version of map (to the right of JPG image of map):



  • Linc Davis Level 10 (192,325 points)

    Back up all data.


    Quit Safari. In the Finder, select Go Go to Folder from the menu bar, or press the key combination shift-command-G. Copy the line of text below into the box that opens, and press return:


    /Library/Internet Plug-ins


    From the folder that opens, remove any items that have the letters “PDF” in the name. You may be prompted for your login password. Then launch Safari and test.


    If you still have the issue, repeat with this line:


    ~/Library/Internet Plug-ins


    If you don’t like the results of this procedure, restore the items from the backup you made before you started. Relaunch Safari again.

  • JazzJunkie Level 1 (0 points)

    Thanks, will give that a try. Always scary when step #1 is" "Back up all data".

  • Linc Davis Level 10 (192,325 points)

    Here's something even more scary: if you don't back up your data, you will certainly lose it all sooner or later, no matter what else you do.

  • JazzJunkie Level 1 (0 points)

    None of the above remedies worked for Safari. I can open any PDF that I download from Firefox, but the Safari PDF downloads won't open in Preview, Adobe Reader, Acrobat Pro, Photoshop, etc. The error prompt I get is: "There was an error opening this document. The file is damaged and could not be repaired."


    I guess I could uninstall Safari, but I don't want to have to replace all my links, bookmarks, etc. Seems like the plugin might be corrupted?



  • Linc Davis Level 10 (192,325 points)

    Don't uninstall Safari.


    Please read this whole message before doing anything.


    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.


    Step 1


    The purpose of this step is to determine whether the problem is localized to your user account.


    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up guest users” (without the quotes) in the search box. Don't use the Safari-only “Guest User” login created by “Find My Mac.”


    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.


    Test while logged in as Guest. Same problem(s)?


    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.


    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.


    Step 2


    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:


    1. Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    2. When you see the gray Apple logo, release the shift key.
    3. If you are prompted to log in, type your password, and then hold down the shift key again as you click Log in.


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.


    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    *Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.


    Test while in safe mode. Same problem(s)?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • CherylSquadrito Level 1 (0 points)

    Thanks so much, Linc Davis.


    You solved my issue without having to leave my office.


    You're my hero. Thanks

  • TechnoNewby101 Level 1 (0 points)

    Thanks so much - I have been trying to sort this out for days and knew it was something to do with recent changes but you have solved my problem. Thank-you, Thank-you, Thank-you for your expertise.

  • NikitaC Level 1 (0 points)

    I had a AdobePDFplug installed on Safari. After deleting that, I was good.


    remember to quite safari and restart after you delete it.

  • jakewaltman Level 1 (0 points)

    I also have the same problem. I did step one and i CAN open saved pdf files. Now that I know that the problem is in my user account, what do i do?

  • malone5287 Level 1 (0 points)

    I had the same problem. Temporarily I resolved it by unclicking Allow Plug in. Do the following

    Click Safari-Preference-Security-Internet Plug in - unclick Allow Plug in .


    This indicated that one of the pdf plugin is causing the problem. So I tested  and found that the plug in

    AdobePDFVieweNPAPI.plugin  is the culprit. By removing it resolved the issue and now I can open pdf files saved in Safari.


    To delete this plug in do the following 


    Finder-Mcintosh HD ( assuming it is your OSX drive) -Library-Internet Plug ins- Then locate and delete AdobePDFVieweNPAPI.plugin


    I moved it to my desktop so I can retrieve it in case something else does not work.

    So far happy and special thanks to Linc Davis for providing the hint to my solution.

    Oz Lone