9 Replies Latest reply: Feb 1, 2013 2:35 PM by Evian
Head.Ache Level 1 Level 1

I've previouslly posted in other communites : https://discussions.apple.com/message/19834868?searchText=iMessage,%20Lion%20Ser ver%20and%20Open%20Directory#19834868

 

But was wondering if any one has come across this:

 

I currently login to my Mountain Lion iMAC with user credentials from Open Directory on Lion Server. (Lion Server is only doing DHCP, DNS, File & Print, Open Directory)

 

I think since the 10.8.2 update when trying to send iMessages to IOS devices, nothing happens.  It doesn't even show in the messages pane as a failled send and doesn't arrive with the recipient.

 

If I login locally on the server everything works fine, I'm able to send and receive.  If I login as a local user on the iMac everything works fine.

 

I have tried deleting all the relevant plists and archives and restarting messages.  Has anyone out there managed to use iMessages in this manner successfully?

 

This isn't just a 10.8.2 problem as have have had very mixed results on previous versions of ML.  For the purpose of testing, messages only has my apple ID enabled and only sending to myself and other people using their apple id's.

 

TIA

Dave


iMac, OS X Mountain Lion (10.8.2), OS Lion Server, Mac Mini
Reply by Tim Chapman on Jan 22, 2013 1:09 AM Helpful

The best that I could come up with was to make the user mobile but only sync one empty folder to speed up the home sync process - as soon as I did that messages works.  Not ideal but at least I minimise the impact of syncing

All replies

  • Hector Castillo Level 1 Level 1

    I am having the same issue with iMessages on Mountain Lion iMacs with network users hosted at Mac mini Lion server, can't send or recieve iMessages, did you figure it out?

  • Head.Ache Level 1 Level 1

    I've narrowed it down to the home folder being on the network.  i.e. /Network/Servers/s........

     

    I've just checked by creating a new user with a mobile account (Workgroup manager etc etc).  This is where the home folder gets copied / synced from the copy on the server and guess what it worked.  Switched back to network home folder, stopped working. Going to try a few other things watch this space!

  • Hector Castillo Level 1 Level 1

    Thanks for the update, let us know when you figure out something else.

  • Head.Ache Level 1 Level 1

    Thought I could edit this.  But hey.  It's definately a Network HOME folder thing.  Swapped my test user back to mobile and it worked.  Seems to need a /User/.... home folder rather than /Network/Servers/servername .....

  • Tim Chapman Level 1 Level 1

    Did you end up finding a workaround for this.   I am having the same issue.

  • Snoopy001 Level 1 Level 1

    No work around. Looks like iMessage doesn't like the NFS share.  I also have an app that syncs between mac and iOS via iCloud storage. That doesn't work either.

     

    The only way I could get either to work was to have the open directory user as a local only account.

  • Tim Chapman Level 1 Level 1

    The best that I could come up with was to make the user mobile but only sync one empty folder to speed up the home sync process - as soon as I did that messages works.  Not ideal but at least I minimise the impact of syncing

  • Evian Level 1 Level 1

    Same problem. Definately something wrong with mobile users. Until yesterday everything was working without a problem (all my users were network ones). Then I turned one of them into mobile user. Since then, iMessage does not work for any of the networks users. It works for the mobile user and network users when loggin locally into the server.

  • Evian Level 1 Level 1

    In addition, when turning the network user into mobile (as mentioned above) but logging as network user in another machine, the user keeps the mobile preferences even though is acting as network user. That was not the case in previous versions of osx server.