Previous 1 2 Next 17 Replies Latest reply: Mar 29, 2013 7:07 AM by buckster
aciim Level 1 Level 1 (0 points)

I have tried several ideas to fix this problem. DNS, Cache-clean, Proxies, Firewall... But still. I can connect to iTunes-store but not to the AppStore. I can see Main screen of the store but not purchases nor updates. Any ideas?


OS X Mountain Lion (10.8.1)
  • Carolyn Samit Level 10 Level 10 (95,950 points)

    -  Temporarily disable anti virus software if installed.

     

    -  Apps such as Little Snitch, Net Nanny, and Hands Off can prevent apps from downloading including Mountain Lion.

     

    -  Third party download managers are not compatible with the App Store.

     

    Open System Preferences > Security & Privacy > General

     

    Click the lock icon bottom left corner of the pane. You may be prompted for your admin password.

     

    Select:  Mac App Store and identified developers

     

    Click the lock icon to prevent further changes then try the App Store.

  • aciim Level 1 Level 1 (0 points)

    No antivirus. K9 Web Protection is off. Parental Control is disabled for all accounts. Network interfaces are built again by deleting Interfaces.plist. Using ethernet cable. Security settings as adviced. Usind Google DNS-servers. All tips are tested. Same problem on two macs and two are working fine. Doesn't even matter what OSX it is. Lion and Mountain Lion...

  • aciim Level 1 Level 1 (0 points)

    I solved this. I needed to reset Safari from Safari-menu -> "Reset Safari" and then I checked Certificates in Keychain access -program. There was don't allow in "VeriSign Class 3 Extended Validition SSL SGC CA" and few others. You have to check them manually. I think there is many reasons why AppStore can not connect.

  • aciim Level 1 Level 1 (0 points)
  • Philip Kalina1 Level 1 Level 1 (5 points)

    Thanks for posting this solution. I reported this problem back in September (with my new Macbook Air) and I see that it is still not resolved by Apple, as of 11/8/2012.

    Today, I just had a new hard drive installed in my iMac (Apple's hard drive replacement program for certain iMacs) by an Apple repair center. Upon startup, I had to restore all my files using my Time Machine backup. Everything went smoothly. Afterwards, the system needed to be upgraded from 10.8 to 10.8.2. When I tried to open the App Store via Software Update, it said that it could not connect as there was no internet connection (there was).

     

    Deja vu kicked in, and I remembered solving this with the help of an Apple Support engineer. He took me through the process outlined in aciim's posting above. It has worked twice for me, and seems sound.

     

    In both cases, I was restoring my entire Mac from a Time Machine backup when this problem occurred. I'm sort of disappointed that Apple hasn't yet resolved this issue, despite a few minor system updates. I've run into this issue twice in a few months. I can only imagine how many more users are having this same problem.

  • PatsyKB51 Level 1 Level 1 (5 points)

    I'm having this issue too - and I read the solution posted in the thread suggested below. However, I find the fix to be daunting and intimidating. I'm just an everyday computer user and some of the solutions people post as doable at home I find scary.

     

    What's a normal ordinary computer user supposed to do? Apple is getting to be less and less user-friendly as I encounter more and more of these glitches.

     

    If it's of any help in figuring this out, I did look at certificates and the Apple .Mac Certificate Authority which doesn't expire til May 2016 has a red X on it which says This Certificate has been Revoked.

     

    What does that mean? Does it have anything to do with the App Store snafu? What's going on?

  • Philip Kalina1 Level 1 Level 1 (5 points)

    I couldn't agree with you more, re the complexity of this solution. I'll leave my email accessible in my profile, if you need some guidance thru this process. I've done it twice with no problems.

  • Wardoggie Level 1 Level 1 (0 points)

    This solved my Mac App Store problem, too! Thanks!

    aciim wrote:

     

    And from other thread: http://b.rthr.me/wp/?p=356

  • boomm Level 1 Level 1 (0 points)

    Thanks!!! Worked beautifully – this solved The App Store unable to find internet connection problem I was having when upgrading from Snow Leopard 10.6.8 to Mountain Lion 10.8.2.

     

    thread: http://b.rthr.me/wp/?p=356

  • _p0rtal Level 1 Level 1 (0 points)

    is there something I'm missing, or does the link to thread: http://b.rthr.me/wp/?p=356 no longer work?;

  • Wardoggie Level 1 Level 1 (0 points)

    It does appear to be gone. I don't have any connection to the owner, but it was someone's blog. Here is the important text I scoured from a cached version of his site.

     

    It turned out that my solution was pretty simple. I had to delete a few files and reset one to its default setting.

    1. Delete the files /var/db/crls/crlcache.db and /var/db/crls/ocspcache.db. These can be found using Finder’s Go >; Go To Folder menu (Cmd + Shift + G). This resets the cache of accepted certificates in the system. It doesn’t remove them, it just forces the system to rebuild the caches upon restart.
    2. Open Keychain Access (/Applications/Utilities/Keychain Access). Select Certificates in the Category picker on the left side. In the search bar, type in the word Class. Look through that list, and find any certificates that have a blue + symbol over their icon. These are the ones you need to modify.
    3. Select one that has a blue +, and hit Command + I. Click the disclosure triangle beside the “Trust” list to show the list of permissions. Now, what we need to do is to set this certificate to use the system defaults. However, for some reason, when you select it, it doesn’t save. So what you need to do is this. Under “Trust”, where it says “Secure Sockets Layer (SSL)”, change the dropdown menu to say “No Value Specified”. Then, close the window. It will ask for your administrator permissions. Then, open the info pane for that certificate again. Under “Trust” again, now set the dropdown that says “When using this certificate:” to say “Use System Defaults”. You can then close out of the info pane, and enter your password again. Do this for any of the certificates that have a blue + on their icon. There should only be one or two at most.
    4. Restart your system.
  • _p0rtal Level 1 Level 1 (0 points)

    thankyou friend

  • Sailhome Level 2 Level 2 (170 points)

    I'm running 10.8.2 and began having this problem just a few days ago, and only while using one specific user account (there are six users on the machine).

     

    Tried many different suggestions including the keychain, date/time, and var solutions that seem to work for so many. But no luck.

     

    Finally here is what worked for me.

     

    In

     

    System Preferences > Security & Privacy > General

     

    I already had the "Allow from" section set to "Mac App Store and identified developers".

     

    I clicked the lock icon (lower left) to make changes and entered my password.

     

    Next I selected the "Mac App Store" setting.

     

    Then clicked the lock to prevent further changes.

     

    Then clicked the lock to make changes and entered password again.

     

    Selected "Mac App Store and identified developers" --- same as it was originally.

     

    Clicked the lock to prevent further changes.

     

    Launched App Store and clicked on Updates.

     

    It worked. Apparently by toggling this setting something refreshed or reset and all became well.

     

    Hope this helps everyone else who is still fishing for a solution!

  • dwaynesimon18 Level 1 Level 1 (0 points)

    I could not connect to the app store/ itunes using my ipod 4th gen. What worked for me is that I signed out of Itunes and App Stores by going to Settings --> iTunes and App Stores--> Apple ID: sign out. This allowed me to connect to the App Store.

Previous 1 2 Next