4 Replies Latest reply: Jan 6, 2013 10:19 PM by zstanley
zstanley Level 1 (0 points)

For this problem, i have tried the suggested steps in http://support.apple.com/kb/HT4700

Though it states it works for Lion and Mountain Lion but my 10.8.2 ML still does not work after all the steps are performed.

 

 

Evidence for the steps done:

 

defaults read /Library/Preferences/com.apple.AppleShareClient afp_host_prefs_version

1

 

defaults read /Library/Preferences/com.apple.AppleShareClient afp_disabled_uams

(

    "Cleartxt Passwrd",

    "MS2.0",

    "2-Way Randnum exchange"

)

 

Symptoms:

- If i use Guest account for afp://<ip-address>, it will connect without problem before and after applying HT4700.

- If i use registered account with username and password for afp://<ip-address>, it won't connect but always show:

There was a problem connecting to the server XXXXXX

- The version of the server you are trying to connect to is not supported.  Please contact ......

 

Questions:

1) Please advise the log path for the above error so that i can at least know the error code and more informaton to search.

2) If it relates to UAMS, why Guest account is allowed without problem?  Guest account is more risky than all above 4 disabled authentication methods! 

3) Will this problem occurs in 10.8.2 only as HT4700 KB was announced before 10.8.2?

 

Thanks in advance for all suggestions and solutions.


iMac (21.5-inch Mid 2010), OS X Mountain Lion (10.8.2)
  • BDAqua Level 10 (122,202 points)

    Hello,

     

    10.8.2 does connect/allow me connecting to/from an eMac/10.4.11, but in Lion, from about 10.7.3 to 10.7.5 I've not been able to, can't remember 10.8.0 or 10.8.1

  • zstanley Level 1 (0 points)

    Hi BDAqua,

    Could you advise the log file to make AFP connections?  It can connect to Guest only account but not registered one.  It means the physical connection is okay but the new AFP version itself expects for more information that my old NAS server currently does not know it needs for authentication methods.

  • 8leed Level 1 (0 points)

    Cannot connect from 10.8.2 to my old afp server wich supports CTL, encrypted login, kerberos login

    HT4700 helps at 10.7.5, but not at 10.8.2 there even no com.apple.AppleShareClient.plist in the system, is this file relocated on something? please help!

  • zstanley Level 1 (0 points)

    For other website forums, the main cause is that the required version of netatalk from OSX 10.8 requires higher version as 2.2+. If your old AFP machine can update the netatalk to higher version, you can backup data and try it. 

     

    For my case, i can't update the netatalk to later version and it seems the only way is to use Guest account to connect to that old AFP machine (i hence need to redesign the network diagram )  Anyway, i am still trying to find any better workaround for this problem.