Previous 1 2 3 Next 37 Replies Latest reply: Feb 21, 2015 4:00 PM by alexfrompittsburgh
mrcoates14 Level 1 Level 1 (0 points)

Hi after upgrading my 4s to IOS 6 I used the contact sync feature with Facebook so that I have friends details from Facebook now in my contact list. This also added a Facebook email address to myself. Now when I use safari and use autofill it uses the Facebook email address. I can't seem to change it. When I go into my contacts and edit I'm unable to delete the Facebook email. How can I therefore push my home email address up the pecking order so that autofill uses it?


MacBook Pro, Mac OS X (10.7.4)
  • 1961templar Level 1 Level 1 (0 points)

    Tap on:

    • Settings
    • Facebook
    • Allow These Apps to Use Your Account: and switch Contacts to Off.

     

    This removes your Facebook email from contacts so autofill will use your home email address instead.

  • L.Shaner Level 1 Level 1 (10 points)

    Good as a workaround, but with loss of FB integraton functionality.

    The original question still stands -- how to tell Safari which email address to prefer?

  • L.Shaner Level 1 Level 1 (10 points)

    WORKAROUND FOUND:

     

    I unlinked my FB address record from my local address book record. Then I edited the FB one and added (Facebook) to my last name in that one.  Then in prefs/Safari I set my autofill address card to the non-FB one.  After killing the Safari app, the autofill started picking the right e-mail address for me.

     

    This is still just a workaround. There is no good reason that I shouldn't be able to link address records between local and FB for myself and still tell autofill which e-mail address to use.

     

    It is patently silly that Apple coded the autofill to put FB e-mail ahead of home and work email addresses, and in any case they should let me CHOOSE the right address from among those in my record.

    Per the workaround, it is annoying that I now show up twice in the address book (local and FB).

     

    Apple is slowly losing the polish, one loose end at a time.

    Attention to detail is no longer forefront. :-(

  • L.Shaner Level 1 Level 1 (10 points)

    (And isn't it ironic that to redit a typo in the above post using my iPad, I had to switch to Chrome and "Request Desktop" site? At least I didn't have to get out of my chair and go use a Mac... Which reminds me, where is back to my Mac for iPad?  I'd be far less frustrated with iPad #fail if when the normal iPad ways do not work, I could access my Mac at home from anywhere in the world).

  • Kevin Mitchell Level 1 Level 1 (5 points)

    I fear L Shaner is correct is this is very sad that I cannot control the autofill fields for Safari. Searched around multiple sites and no iOS solutions, only work arounds.

     

    Apple: Why can't I change this? Why note allow editing of autocorrect Dictionary to remove mistakes? Open up!!!!

  • amandasteed Level 1 Level 1 (0 points)

    It's in the settings for your browser. If you're using safari, go to settings, safari, autofill. It's based on your saved contact info.

  • redthumb45 Level 1 Level 1 (0 points)

    I can't see how you can do this.  The Facebook.com address entry in my saved contact info cannot be deleted or edited.

  • L.Shaner Level 1 Level 1 (10 points)

    Redthumb45:

     

    The most important thing is to NOT link your personal record to your FB one.

    If it's easier for you, you could temporarily change the name on your personal record and add something to distinguish it like ME. Then choose the ME record for Safari autofill and Siri, then change the name and remove the ME part.

     

    I have linked all my other contacts with their FB contacts, but for my own record I keep them separate, just because of this extremely annoying Apple-ism. How could they think I would want to use my FB info in web forms? Silly.

     

    Anyway, I hope my note was helpful.  Good luck!

  • cwsmith1923 Level 1 Level 1 (0 points)

    Open your contact linked with autopilot and you will see the Facebook email address is labeled "email", and your other email addresses will be labeled "home" or "work", etc.  You cannot edit the Facebook, but just change the label of the email you want auto fill to use to "email" also, and auto fill will use it. 

  • cwsmith1923 Level 1 Level 1 (0 points)

    "auto fill" ... Not "auto pilot".  Lol... **** you auto correct ;-)

  • Kevin Mitchell Level 1 Level 1 (5 points)

    Thanks CWSMITH1923 for this:

     

    cwsmith1923 wrote:

     

    Open your contact linked with autopilot and you will see the Facebook email address is labeled "email", and your other email addresses will be labeled "home" or "work", etc.  You cannot edit the Facebook, but just change the label of the email you want auto fill to use to "email" also, and auto fill will use it. 

     

    However, looks like Email is the default fieldf that auto fill uses and Facebook occupies that slot. As you said, I can't edit that field label. So, the only option is to pick Email 1, Email 2 for my preferred personal email.

     

    I'll try unlinking from Facebook and then turning my personal email to Email to see if that works.

     

    As for feature request: Apple needs to allow customization of what the user wants to autofill. Please don't decide what various contact fields should be used for us.

  • cwsmith1923 Level 1 Level 1 (0 points)

    But you can change "work" or "home" label to "email", so both Facebook email and the email you want to use are labeled "email"....and if not at top of email list order, be sure the email you want to use is at top of list.

  • Kevin Mitchell Level 1 Level 1 (5 points)

    The option "email" is not available to select from the field.

     

    I can do it via a custom label but that doesn't fix the issue: Facebook email still comes first in autofill even though my yahoo email is the one at the top of the list.

     

    I rebooted phone after making the contact changes and that didn't fix the problem.

  • cwsmith1923 Level 1 Level 1 (0 points)

    If your yahoo email is at the top, AND you labeled it in custom (yes...that is how I changed mine) I'm not sure why it is not working for you.  I just did it this morning because Facebook was coming up in auto fill for the HGTV home give away entry form.  I just did what I described, fixed it right away.  Good luck!

Previous 1 2 3 Next