5 Replies Latest reply: Feb 6, 2014 4:40 PM by NinaNH
amityweb Level 1 Level 1 (0 points)

There seems to be a major issue with Apple Mail and GMail at the moment... I have not used Apple Mail for a while, before Mountain Lion so I do not know if it is related.

 

When using Apple Mail with GMail, sending and receiving emails take a LONG time. Far too long than it should. A small 9Kb email just took about 1 minute to send. When I receive emails the Loading icon is also spinning for about 1 minute, sometimes even longer, two minutes or so.

 

Now, if I use Apple Mail to connect to a non-Gmail account, e.g. my Yahoo one, it is fine, sending and receiving takes the time you expect.

 

If I use Thunderbird to connect to my Gmail account, it is also fine, sending and receiving takes the time you expect.

 

So it seems the issue is only with Apple Mail and Gmail.

 

I have set the folders to Use This Mailbox For... for Junk, Spam, Drafts and Sent Items. I have set it so hitting Delete will delete them, Archive will Archive them. These settings are what I used to use a while ago when it worked fine anyway.

 

So anyone else have this experience?

 

P.S. Other issue is when I delete or move an email out of my inbox into a folder, it comes back into the inbox. Maybe its related, e.g. the time taking Mail to communicate with Gmail is too long or something.


iMac, Mac OS X (10.7.3)
  • amityweb Level 1 Level 1 (0 points)

    Oh, and this is the same on my Macbook Pro at home as my iMac in the office. Both all up to date. Different ISPs.

  • amityweb Level 1 Level 1 (0 points)

    I've managed to get it working OK now by changing various settings, one of them is change the PATH IMAP to [Google Mail] and update all my Gmail labels to prefix them with this. Then do esomething with auto punging and deleting. Something has fixed the speed.

     

    But there are other issues now... if I set the path tp [Gmail] I get a sub folder [Google Mail][Gmail][GMail], and if I set it to [Google Mail] I get a sub folder  [GMail][Google Mail][Gmail]. I think these are for the Archive folders in Mail.

     

    Then when I do actually click Archive they are removed from Mail's inbox but still in GMail's inbox.

     

    I REALLY, REALLY do not want to use GMails web interface because its counterproductive by telling me I have mail all the time as soon it comes in, so I want to use Apple Mail, but it seems it just wont play nice with GMail. Hope I dont have to resort to Thunderbird.

  • Luis Sequeira1 Level 6 Level 6 (8,150 points)

    I have no solution, but one thing must be said. Your experience is NOT normal.

    You should expect your gmail account to work in Apple Mail just as well as any other.

    There seems to be some awkward setting messing things up.

  • amityweb Level 1 Level 1 (0 points)

    The best I can make it results in 2 issues. 1) Archive not removing from Inbox in Gmail, and 2) Either the [Gmail] or [Google Mail] folders and sub folders on the left (they swaop depending on which I put in my Imap path).

     

    So I am trying Postbox out now. It looks great. I sitll get the [Gmail]/[Google Mail] folder in the left (I suspect its a Gmail issue), but at least when I click Archive it IS removing it from my Inbox in Gmail, so it it is better for GMail than Apple Mail.

  • NinaNH Level 1 Level 1 (0 points)

    I did exactly what you said previously, but mine is still extremely slow.  I've reset all the Gmail setting too many times to count doing the CAPTCHA  thing and all.  There is something very wrong.  Google seems to not care, and Apple seems pretty happy with Mavericks.  If anyone figures out anything else, please please post.  Thanks amityweb for sharing however.  Doing what you said got my Gmail inbox back a week or so ago when something was even more wrong.