Previous 1 12 13 14 15 16 Next 238 Replies Latest reply: Jun 12, 2014 6:16 PM by defjamblaster Go to original post Branched to a new discussion.
  • skandigraun Level 1 Level 1 (0 points)

    I am annoyed by this bug since i updated my iPod4g to iOS 6 (have not noticed it with 5, but i'm not sure about it)Now i am at a point where no new updates will be issued for my device, so it will never be fixed. I could not find a patch for jailbroken iOS either (i don't do any warez with jb, i only need it to access the hosts file, but that's another story). But i am quite diappointed. I bought it about 2 years ago for almost $500, and this bug is ancient, it's ridiculus that i have to live with it for that money. I guess they would lauch at me if i would ask for a refund, right? I think i was patient enough with waiting for the fix...

  • bobackz Level 1 Level 1 (0 points)

    Wow. Didn't realize how many people were as frustrated as me. I have the same problem. Is Apple even aware of it?

  • JMMYGIRL Level 1 Level 1 (0 points)

    iOS 7 has solved the problem I was having.  Me and my devices are happy!

  • defjamblaster Level 1 Level 1 (10 points)

    what i'm noticing in ios7 is that if i quit the app from the backgound (swipe it away) the problem returns. if i don't swipe it away, it seems to keep its place.

  • Kate VanderLich Level 1 Level 1 (0 points)

    So interesting thing I discovered. This playback issue is only occurring in my virgin mobile iPhone 4S. That phone was restored from the backup of an AT&T iPhone 4S on iTunes. Just recently got the 5S on AT&T and registered it as a new device on my iTunes. No playback issues. Even during the beta on the 4s I still had playback issues. Anyone else who has had this playback happened to restore from a previous iPhone?


    That would mean maybe the memory issue would be a possibility.

  • Scottc1978 Level 1 Level 1 (0 points)

    I've had this issue on two different iPod Touch devices.


    Since my device is a whopping 1 1/2 yrs old, Apple has deemed it not capable of any more updates.

    So ios7, even if it does resolve the problem, is not an option for me.

  • wes786 Level 1 Level 1 (0 points)

    "Music not resuming from where you left it off" issue has been there since the inception of iOS6 and I don't know why Apple is taking so much time to fix this bug.


    I am not sure if any of you have tried the "remember plaback position" option in itunes but you have to turn that on for each of the songs and if you have 1000s of songs than it gets a little time consuming (it doesn't allow me to select all and turn it on for all the files at once). And I am not quite sure if that would even fix the issue. Let me know if you guys find a solution to this. ITS VERY ANNOYING....


    So many little annoying things that are keep coming up with apple lately and I might just go for another brand for my next upgrade.    

  • Minok Level 1 Level 1 (0 points)

    Just adding my voice to this list of disappointed iWidget owners.


    I play music to my shower every morning and suffer the repeating sequence of songs issue as well. I turn on the remote speakers, it connects by Bluetooth and after the shower I shut off the speaker which I assume pauses as if the headphones had been removed. Nest morning, Same sequence.


    iPhone 4S with most current iOS 6 version. Sad that this fundamental and core feature on am $800 device doesn't work.

  • frankenhooter Level 1 Level 1 (0 points)

    I've had this issue for many months and recently looked for a solution by updating to ios7. The issue remains. :/

  • k_tromb Level 1 Level 1 (0 points)


    Go to songs tab, click one song, the click ctrl+a.

    It will highlight all the songs in your music library.

    Go to "get info," "options" tab.

    From there, you will see "remember position"

    Check it, change to "yes," then sync.


    Even with turning off my ipod, it still remembers what song it was on when I turn it back on.

  • Given2Dream Level 1 Level 1 (0 points)

    Nope. Page 9, this was suggested and proven not to work consistently. Thanks anyway.

  • Minok Level 1 Level 1 (0 points)

    So this morning I noticed it started playing songs previously played again, but not all the way back to the front if I remmber this right.  Seems it fell back to some prior checkpoint.  I remember these songs playing a month or so ago in this sequence.

  • skandigraun Level 1 Level 1 (0 points)

    If i noticed right, then if you repeat one song, this one song will be the checkpoint for a while. But if the music app is gets out of memory (you do something RAM demanding stuff like browsing, playing, whatever without having the Music app running, restart the device, or simply close the Music app) it will start again from the first checkpoint next time you start it.

  • pegaudet Level 1 Level 1 (0 points)

    I just encountered a lovely bug in ios 6 music playback.


    I almost always unlock my phone to start/stop music playback on my iphone 5 (ios 6.1.4, still not upgraded to 7).


    Last evening, I was in a hurry to pause it so I double tapped the home button to get the locked screen player controls. Later, I unlocked the screen, resumed playback and a few songs later I stopped it normally again, and USB cable sync'ed with itunes. This morning, I started playing one of my smart playlists.


    I got 31 songs in and these were the results (I have linux on one computer and using libimobiledevice, I have access to what the phone is thinking and I can query the database right on the phone...)


    The phone only registered having played 29 songs, the 30th and 31st songs did actually play, but simply stopped near the end of the 31st song (maybe it actually finished song 31). It refused to play by using the start/stop control until I rebooted the phone. When I did reboot the phone, it restarted on the 30th song, not the 31st song which it should have done... The current position in the playlist matched the database plays.


    In my case, I would conclude that there is some code on the phone that says where it is in the playlist for playback (and possibly actually do the playing part), and there is somewhat unrelated code somewhere else that updates playlists and database. The code that updates, might have terminated/crashed/borked unexpectedly, preventing it from getting further play updates (after the 29th song in my case), while the other code that figures out where it is and plays keeps going. Maybe at some point the "player" is expecting the other process (maybe the GUI control, maybe another process) to receive its play updates, the other end never does, and the player plugs up eventually (2 songs in this case), causing a number of these problems mentioned in this thread.


    If that is the case, it might also help explain why some phones (4, 4s) manifest so easily.... The specs on the 5 might delay, postpone or somehow alleviate the problem, but that it's still there.


    Part of the problem encountered by people might be memory related, but I think it also has something to do with long delayed actions (you do something today that seems unrelated and 2 or 3 days later it manifests itself). If my numbers are an indicator, 30 songs would be a very rare album track count or maybe a very long playlist for some people.... maybe I poke the phone the wrong way this morning in the elevator???)


    It seems my unexpected music playback issue I've encountered today (based on what I normally do and didn't do lately) happened to be double tapping the home button on a locked screen to control the player (on my phone that has a screen lock, I've had this kind of problem from time to time, I don't have a screen-lock on my ipod touch and even though was upgraded to 6.1.3 and I did not see that kind of playback reset problem on the touch)


    I hope this helps.

  • pegaudet Level 1 Level 1 (0 points)

    Yet another stupid bug this morning...


    I have Bose QC-15 headphones I use on my commute.


    This morning, everything was going well and I was on song 3 of a playlist. When I ran to catch my bus transfer the cord popped out at the headphone end, not at the phone end.


    The music player control said it was still playing when I unlocked the phone, so I clicked pause. I then unplugged the cord from the phone, reconnected the cord back into the headphone, plugged the cord back into the phone, and clicked play again. Only the display said it had started song 3 again from the beginning, but it was playing song 4. Again, I verified which song the phone had successfully finished playing, and it had finished song 2 (so it should have stayed on song 3)


    IF the phone got some kind of remote control signal that confused it, it should not have produced the kind of behaviour that made it think the UI should still be on song 3 and decide to skip actual playback to song 4...


    I saw similar playback control stupidity from the player (related to normal remote control use) when they first tossed out a perfectly fine music player in ios 5 to replace with the one in ios 6 that seems to be infested with more bugs than a street dog.