Previous 1 2 Next 24 Replies Latest reply: Apr 18, 2013 5:21 PM by tom_john
LDMartin1959 Level 1 Level 1 (5 points)

I had my primare iCloud account on two computers. I also had my cell phone number associated with the Messages software on those so that I could receive message on my Desktop that were sent to my phone number. In redoing one of those computers I inadvertantly deleted the phone number associate. I am no longer seeing messages on my desktop that are sent to my phone.

 

How do I fix this? I can't find anyway to add that number back in.


iMac, OS X Mountain Lion
  • Ralph Johns (UK) Level 9 Level 9 (69,120 points)

    HI,

     

    On the iPhone delete the Apple ID

    You get a warning that it will be deleted from All Devices.

     

    Re-add the Apple ID which will re-link it with the iPhone Number and get the Message Alert on the Mac.

     

    (there is not way to add the iPhone Number on the Mac)

     

     


    10:22 PM      Wednesday; October 3, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • LDMartin1959 Level 1 Level 1 (5 points)

    Ralph Johns (UK) wrote:

     

    (there is not way to add the iPhone Number on the Mac)

     

    Well....that s-ucks. Hello, Apple. I just found a design flaw!!

     

    Just to make sure I've got this correct and am not looking in the wrong place, I want to go into Settings | iCloud, scroll to the bottom and hit the big red "Delete Account" button. Have I got that correct or am I in the wrong p lace?

     

    Thank you.

  • sberman Level 7 Level 7 (26,830 points)

    In spite of appearances, I was able to add my iPhone's telephone number directly to iMessage on my Mac:

     

    In the Messages application, open Messages > Preferences ...

     

    Click on "Accounts" on top.

     

    On the iMessage account, which should basically be set up correctly with your Apple ID but not telephone number, click the "Add email" button on the right.  Then add your telephone number, country code and all, just as it appears on your iPhone under Settings > Messages.

     

    That does it!

  • LDMartin1959 Level 1 Level 1 (5 points)

    And you are getting iMessages on your Mac? Just asking for verification that it actually functions and not just let's you do it but doesn't do anything!!

     

    Thanks.

  • sberman Level 7 Level 7 (26,830 points)

    Good question!

     

    Yes, I can verify I am getting iMessages on my Mac.

     

    That's iMessages only, not text messages.

  • LDMartin1959 Level 1 Level 1 (5 points)

    That's PERFECT!!!! Coooool, thanks and kudos! (I hated the idea of intentionally deleting something just to put it back in !!)

  • sberman Level 7 Level 7 (26,830 points)

    Thanks. I have to say this solution method surprised me - entering a phone number but in the email address area.

     

    But like you, I'm happy not to have to delete and re-enter the Apple ID on my iPhone.

  • Ralph Johns (UK) Level 9 Level 9 (69,120 points)

    Hi,

     

    That is strange as I have tried that and it said it sent off an email to Verify which obviously never went or arrived anywhere.

     

    The Number then just sat in the list saying "Awaiting Verification"

     

     

     

     


    8:45 PM      Thursday; October 4, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • Ralph Johns (UK) Level 9 Level 9 (69,120 points)

    HI,

     

    If you are trying to delete the iMessages account in Messages you have to do it there and it is ot anything to do with iCloud other than you may have used the same Apple ID.

     

    In Messages > Preferences > Accounts use the Sign Out button in Version 7.0.1 (OS X 10.8.2)

    In earlier version use the Account details Button then the Sign Out Button.

     

     


    8:48 PM      Thursday; October 4, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • LDMartin1959 Level 1 Level 1 (5 points)

    That is strange as I have tried that and it said it sent off an email to Verify which obviously never went or arrived anywhere.

     

    The Number then just sat in the list saying "Awaiting Verification"

     

    I get a similar message on one of my computers. The other accepted a phone number fine.

  • Ralph Johns (UK) Level 9 Level 9 (69,120 points)

    Noted.

     

    Interesting.

     

     


    7:34 PM      Saturday; October 6, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • BLived Level 1 Level 1 (0 points)

    I was hopeful when reading this "fix" "work-around" or whatever this highly COUNTER-intuitive approach is that this would work for me, but a phone number entered into the "Add Email" box triggers a messages (http://cl.ly/image/1d1D0k2c1D0A) stating that "A verification email has been sent to..." and then states the new PHONE NUMBER (which, all hope aside, did not receive "a email" or a text message seeking confirmation.

     

    How now brown cow?

     

    :-))

     

    (grrrrr!)

  • Ralph Johns (UK) Level 9 Level 9 (69,120 points)

    Hi,

     

    For me this method did not work.

     

    However as you can see from the other posts for some people it does.

     

    There is not really enough info to determine what was different about those that worked.

     

     

     

     


    9:18 PM      Wednesday; October 31, 2012


    Please, if posting Logs, do not post any Log info after the line "Binary Images for iChat"

     

      iMac 2.5Ghz 5i 2011 (Mountain Lion 10.8.2)
     G4/1GhzDual MDD (Leopard 10.5.8)
     MacBookPro 2Gb (Snow Leopard 10.6.8)
     Mac OS X (10.6.8),
     Couple of iPhones and an iPad

    "Limit the Logs to the Bits above Binary Images."  No, Seriously

  • sberman Level 7 Level 7 (26,830 points)

    Your attached photo shows a second telephone number that looks like it's set up just fine.

Previous 1 2 Next