7 Replies Latest reply: Jan 14, 2014 6:00 AM by aduffbrew
Les614cc2 Level 1 (10 points)

has anyone else gotten this message when trying to sign into the app store:

"could not sign in" "an unknown error has occurred"

 

i know my password is correct, i signed in on my macbook and on my imac and no issue there.

 

i called apple and they coulnd't figure out what it is, i reset my network settings and same thing. of course i can't do a restore because i'm at work and we don't have the new lighting cords here for me to hook up to my imac


iPhone 5, iOS 6
  • Eric Jacobs Level 1 (5 points)

    I experienced this problem, too -- and with the help of an Apple support rep, figured out a way out.

     

    Go into Settings and turn off automatic date and time, and set your phone back a year. Then go back and turn automating date and time back on, to get back to the present. Now go to Settings > iTunes & App Stores, click on your AppleID, and re-enter it and your password. Finally, go back to the App Store (or iTunes Store) and try to download what you had been trying before -- and if you're like me, it will now pop up with a new set of Terms and Conditions for you to approve. After you approve, you'll be able to download whatever you had been trying to.

     

    It appeared, in my case, that Apple needed to present me with a new Terms & Conditions to approve, but for some reason, iOS 6 and the Apple mother ship weren't communicating correctly about how to do that, and I was stuck with the "Could Not Sign In" message. Changing the iPhone's time and/or re-signing in via Settings > iTunes & App Stores resolved the roadblock for some reason. Hope this works for others as well!

  • claabs2012 Level 1 (0 points)

    Thank you so much! This trick worked for my son's new iPod. I didn't have to review any new terms and conditions, but setting the date back a year and then resetting it to automatic did the trick.  Thank you, thank you, thank you!!!

  • Mronion Level 1 (0 points)

    Worked for me too, many thanks

  • Michael Hatton Level 1 (0 points)

    This worked for me.  Thanks a lot.

  • eggbox23 Level 1 (0 points)

    Worked for me too, thanks

  • graemevrecovery Level 1 (0 points)

    sadly , not woking for me   ...if I go though those steps it just want a new account ... complete with new password  ... no mentio of my gift card preloaded.

  • aduffbrew Level 1 (70 points)

    Awesome, Eric! 

     

    Worked like a charm.

     

    Thanks!!