Previous 1 2 3 4 5 Next 74 Replies Latest reply: Jan 30, 2016 2:35 PM by henhowc Go to original post
  • marliken Level 1 (5 points)

    Here's the real answer. For apps that are stuck installing and are stuck with the "installing" button frozen here's what you do and yes it's easy and no you don't have to reset. Plug your ipad into your computer. Open itunes. go to your ipad and to the apps tab. The ipad desktop emulation appears on the right, to the left is the list of apps. They say install if they are not on your ipad. They say remove if they are on it. They say update if they need updating. Click the update button on all the ones that say update, they will now say Will Update. Now apply and it will fix them all.

  • kay220 Level 1 (0 points)

    I have this problem with Twitter.  It has said  Installing for days. I don't have a computer to connect my iPad wit.

  • igrant Level 1 (0 points)



    I had this issue over the last couple of days with an app, saw your suggestion and it worked !

  • barnei Level 1 (10 points)

    Thanks for this.


    I have just tried with the two apps which were "stuck" during installing, and it worked perfectly.


    I hop I remeber for the next time!!

  • bissie Level 1 (0 points)

    I finally fixed the stuck "installing" on the apps on the iphone 5. Go to home screen, hold down apps button until they wiggle. Then go to the apps that are in the install stuck mode (the bar at the bottom of the app will be all black) Then delte the app (you will be able to reinstall it later). After deleting all the stuck apps, you can reload the app, update it and it will work fine. I will, in the future, update only one app at a time. It looks like there are conflicts when doing a global update at the update app screen.

  • tdrom Level 1 (0 points)

    Simple solution I just found tonight... my apologies if someone posted this earlier, but I so excited


    When you see that your apps are stuck in the installing or updating phase within the App Store, go to your Home Screen and then tap on the "stuck" icons. This should re-start the installation or updating process for the targeted app(s), as oppose to having to re-download or uninstall the app.


    Again, this solutions works provided that you have available memory/storage on your iPhone...


    Hope this helps!

  • holdrege Level 1 (0 points)

    All these remedies work under the simple case, but it can also be the case where these app upgrades are simply stuck and nothing works. That's where I am now. None of these trick work this time. I wonder if I jailbreak if I can fix the problem from the unix prompt?

  • Espen Vestre Level 1 (145 points)

    Thanks marliken! Your suggestion of using the update buttons on the stuck applications in iTunes was the only of the many suggestions here that worked for me.



  • DanaBart Level 1 (0 points)

    I tried all the soluations on this page and nothing worked. However, Jas42, how do I find "update problematic app," in iTunes? I can click on the app but it just asks me if I want to remove it.

  • TrueBlueAussie Level 1 (0 points)

    I had the same problem when pending updates stalled after I updated to IOS 6.1.4. The pending updates all hung up on "installing".


    I found that if I did the following it kick-started them:

    - Select the small icon in the update list. The app details page comes up

    - Select the app icon on the details page. This takes you to the page on your phone where the app is.

    - Select the app (which has an empty progress bar) to start it. You get a "failed to download message".


    On returning to the app store update list you will find they work normally again.


    Hope this works for you too, as it avoids any messy syncing

  • Iamsmitty Level 1 (0 points)

    I didn't even have to delete the download.  I just tapped on each icon that got stuck and which took me to the same icon in its normal location.  I then tapped on the stuck icon and it stopped the download.  I did that for each stuck icon and then restarted the process by pushing the update all button.  worked fine.

  • Stacy Scott Level 1 (0 points)

    @Dan Rosellini- that fixed my problem. Even after resetting all the settings and restoring from backup did not solve the issue- Dan's simple trick worked thanks!

  • AxeBox360 Level 1 (15 points)

    Plugging my iDevice into my computer and syncing the device fixed it for me. The application has already been updated on in iTunes on my PC but it was stuck in "installing" status on my iDevice. 

  • andyoo187 Level 1 (0 points)

    I had the problem where the app was stuck on "installing", but I had an icon.

    What worked for my was to touch the icon and put it into "waiting"

    Don't touch it again to go into "installing", just wait. Mine eventually went into"Loading..."

  • jessicah... Level 1 (5 points)

    Make sure that you have wifi and try clicking once again. It may work