Previous 1 2 3 4 Next 57 Replies Latest reply: Feb 6, 2015 3:20 PM by Nippon Newfie Go to original post
  • RichardMcCarty Level 1 Level 1 (0 points)

    I found a different solution for my stuck-installing app problem. After trying numerous suggestions here, I noticed that I had no more space for icons available on my desktop. Moved several into a folder, suddenly the icon for the stuck-app showed up, and I was able to get it installing by tapping on it.

  • tdenmark Level 1 Level 1 (0 points)

    On my iPhone I deleted the app that was stuck installing, then went to the app store did a search for the app, found it, reinstalled.

     

    That worked.

  • igeekart Level 1 Level 1 (0 points)

    Read through some of these with no success and finally just deleted the apps again and reloaded them and they automatically show up if you have an icloud account, otherwise, just downloading the entire app again will fix it. And took hardly any time at all. Thanks Apple!

  • dcnicholls Level 1 Level 1 (20 points)

    Thanks, Liquidsmoke, that fixed my problem. iTunes thought the app was installed, but no icon and no way to remove it to reninstall.  Settings > General > Show all apps allowed me to remove the app from the iPad and the reinstall was simply a matter of reinstalling from iTunes.

  • Jamesnotjim Level 1 Level 1 (20 points)

    Thanks. This worked for me as well. I tried tapping each app (of the three I had stuck this time). Two changed their labels to from "Installing" to "Waiting," but a third changed it's label first to "Waiting" and then, after another press, to "Loading." Nothing seemed to happen, but I could see via the toolbar icon that my iPad was receiving data. So i just left it alone for a few minutes and that third app finally got a progress bar and finished installing. Then one of the others resumed. I'm still working with it, but I assume the remaining app will follow suit.

  • kenmorefield Level 1 Level 1 (0 points)

    After having much trouble deleting Mahjong Vacations and having it reinstall, I found this: http://www.iphonefaq.org/archives/971489

     

    Based on their suggestion, I opened Itunes and "signed out" of the store. (Menu in upper left corner.) I then went to the store while signed out (on my Itunes, not on my phone) and found the app (Mahjong Variations). I clicked on "downlaod for free." I was prompted to log into the store, and when I did, the app downloaded completely rather than getting stuck in "install" mode.

     

    Not sure why this happened, but that fixed it for me. I was then able to delete the app.

  • PaddyFH Level 1 Level 1 (0 points)

    I had recently started having trouble with apps stuck on installing on my iPad 2. Jas42 solved my problem.

     

    The steps I took in detail:

     

    - connect iPad to iTunes via USB

    - Click on the iPad on the left sidebar to bring up the iPad contents on the iTunes window.

    - Click on apps tab

    - On the list of apps installed on the iPad there is a button with either Remove, Install or update to the right of each of the apps on the list.

    - For all the apps which have stuck on updating/installing, they are the ones which show up as "update"

    - When you click on "update" the button will change to "will install". Do that for all your apps stuck on installing

    - Now sync your iPad.

     

    The apps will load and update on the iPad. And all is good again with the world...!

  • YousefSter Level 1 Level 1 (0 points)

    What i did was i rebooted the idevice and the app should say Waiting when it is just hold the home screen (ios 1-6) or hold the app (Ios 7) and delete it,It might take a few trys but it WILL work

  • dbarnes30546 Level 1 Level 1 (0 points)

    marliken I tried what you said but the APPS are still showing on my IPod Touch. They dissappear on the computer on ITunes but when I go to my IPod Touch they are STILL there. GRRR!!! I want them to just go away and I will reinstall them later. I think what I will do is write down all of my apps that I got, and reboot my IPod and start all over again.

  • dbarnes30546 Level 1 Level 1 (0 points)

    Okay Marliken again...all I did was POWER OFF my Ipod and waited for a few seconds, turned it back on and the apps that were hung up in waiting were GONE!! Every thing else was saved.

  • Bulara Level 1 Level 1 (0 points)

    this worked me perfectly.... go to itunes stores, via itunes.. click purchased icon and click the app that you need to reinstall or tht is stuck.. it will reinstall and now connect your ios device and intall it to your phone via itunes, and now uninstall as you wish from itunes only. . . ta da. ..thanks..  i m a pro i know. . :-P

  • Andros tempest Level 1 Level 1 (0 points)

    I don't know what set up some people here have but I can assure you very few of the "fixes" describe here actually work.  At least not on my ipad mini. 

     

    1. Unless you have an Apple laptop forget going to itunes to fix the problem, non of the solutions described work on an IBM compatible machine running windows.  The option to right click and edit, delete or download an app doesn't exist on a window machine. 

     

    2. Syncing your laptop to your ipad doesn't fix the problem either.  It might do for some people it most certainly didn't for me.

     

    3. going into settings-general-etc is a waste of time, this resolution only works for an iphone, if you have an ipad don't waste your time looking the options just don't exist that are described in this thread.

     

    4. closing down all the apps SHOULD work if the issue is that your memory space is maxed out, mine wasn't therefore this fix didn't work either.

     

    The ONLY resolution here that I can confirm actually works is switching the ipad off and back on again. 

     

    I also suspect since this has now happened twice on the same ipad that it is related to the recent IOS8.0.2 update (the ipad in question is running IOS7) and that the updates could not finish installation because the ipad is running the out of date version of IOS.  A possible fix therefore could also be to update to the latest version of IOS, a suggestion not even explored in the previous posts.

  • Nippon Newfie Level 1 Level 1 (0 points)

    Thanks. This solved the issue for me. 

Previous 1 2 3 4 Next