Previous 1 2 3 4 Next 57 Replies Latest reply: Jun 20, 2013 10:29 AM by ChaunceyB Branched to a new discussion.
chadbush Level 1 Level 1

I recently updated my newish Apple TV to version 5.1 and suddenly several apps stopped working:


  • I cannot log into the Apple Store.
  • Photo Stream will not connect.
  • I cannot log into my YouTube account, although the rest of the YouTube app works fine.
  • I cannot play any videos on Hulu+, although I am able to see my favorites.
  • Airplay does not work.


Netflix works fine for some reason.


So, the problem is not with internet connectivity. It's with several apps on the device.


I found a "solution" on this post:


Unplug the ethernet cable! But that is NOT a solution. It's a temporary fix. If I knew that Apple TV was a wifi-only box, I might have bought a different box.


I haven't heard anything from Apple about this, and obviously based on the post above, a lot of people have similar issues.


I have a pretty standard network configuration with fairly new equipment: a LinkSys router, a Cisco cable modem, and Cox's premium internet connection service.


Apple, what's going on? Are you planning to push out a software update to fix this? Has anyone else found a solution other than abandoning ethernet?

AppleTV 2, OS X Mountain Lion (10.8.2), Apple TV 5.1
  • Roy B Level 3 Level 3

    Hello all,


    It appears that this issue is related to specific network/Internet configurations. If you are experiencing this issue (some features work over WiFi but not Ethernet) after updating to Apple TV version 5.1, please send me <> an email with this information:


    1. What is the manufacturer, model number and firmware version (if possible) of your Ethernet router?

    2. What is the manufacturer, model number and firmware version (if possible) of your WiFi router? (if it is different)

    3. What is your Internet service provider?

    4. Where are you located geographically? (what city?)

    5. What Internet features do work over Ethernet?

    6. What Internet features do not work over Ethernet?

    7. Does it read "Activation Failed" at the bottom right in Settings > General > About?


    Please make the subject line of your email be "Some features work over WiFi but not Ethernet".




  • jbinc Level 1 Level 1

    I sent my info through Apple TV general network test settings. I'm sure others have done the same so apple should have enough info to correct this hugely widespread issue. I have to say that I'm not impressed with apple's lack of attention in recent product updates. It looks terrible for apple and makes me want to switch back to android.

    Fix the problems please.

    My router is a Cisco from my cable provider. Anything to do with logging into iTunes or photostream stuff is broken over Ethernet. Internet radio, YouTube and Netflix work perfectly. I use Ethernet for stability and speed. Is hold be able to continue this if apple would actually fix this problem. It's been almost 2 weeks.

  • adam60 Level 1 Level 1

    Hi Everyone,

    hope this message finds you all in time. The recent Apple TV update 5.1 is terrible. Apple knows it is which is why (thankfully for some relentless user -I have no idea who but I believe it was under threat) they have allowed to sign 5.0.2 again which means you can downgrade your Apple TV 2 and 3 to a 5.0.2 version via iTunes. Who knows how long they will keep the window open but I have downgraded my ATV early this morning. I couldn't post this earlier because I was out all day but I am doing it now.


    Here's how to do it:


    1) Connect your ATV to your computer via a Mini USB (not included with ATV but included with many other electronic devices) - in order for your ATV to appear in iTunes you must FIRST plug the USB cable to your computer and ATV and only THEN plug the power cable.


    2) Download your ipsw restore file from Apple.


    5.0.2 (ATV 2): AppleTV2,1_5.0.2_9B830_Restore.ipsw

    5.0.2 (ATV 3): AppleTV3,1_5.0.2_9B830_Restore.ipsw


    3) In iTunes select yout ATV, hold SHIFT and click on Restore

    4) Find and choose the downloaded IPSW file in the Open Dialog Box and hit Next

    5) As long as Apple still signs that version the Restore process will begin and will take a few minutes to complete.





  • mail4et Level 1 Level 1

    Hi Roy


    I can't login to YouTube and that what I use my ATV for my kids to watch YouTube with saved playlist.


    I use a Berkin router with the most basic settings.

    I use a carrier in Hong Kong Hong Kong Broadband (HKBN)

    I am in Hong Kong

    I connect my ATV using WIFI ONLY.


    I hope a fix will come up soon.


    I am disappointed with the recent work. After all I have been using Apple since the Mac II and PowerBook 100 and never encounter a simple functional failure like the recent Apple Map and this ATV YouTube problems. With all my love and respect, I hate to wonder if Apple really can't survive without Steve.



  • jbinc Level 1 Level 1

    Thanks for these instructions. Upon trying this on my own ATV, i dont get finder opening when pressing 'shift' and clicking 'restore'. It never asks me for the location of my downloaded 5.0.2 ipsw file, rather i simply continues to restore it through itunes with the latest software. huge bummer, can you tell me what im doing wrong?




  • jbinc Level 1 Level 1

    I found the issue in my steps. In Step 3) listed above, it should be hold 'OPTION' key and click 'restore' in itunes. not 'shift'.


    thanks for the rest of it though!

  • adam60 Level 1 Level 1

    Hi Jesse,

    on windows pc it's shift on mac it's either option or alt

  • chadbush Level 1 Level 1

    Wow... So, I was using my Apple TV that was broken by the 5.1 update via wifi just until Apple releases a fix, but then after a half hour or so of watching anything on Netflix or Hulu+, the screen would go blank for a moment, then the device would lose its place in the show, returning to the beginning as though I'd never watched any of it. This kept happening, so finally I gave up and took the whole unit to my local Apple Store.


    There, the Apple Genius told me that the unit was defective, and quickly exchanged it for a brand new one. I mentioned the problems caused by the 5.1 update, and he said he didn't think that was correct. He recommended that I apply the 5.1 update to the new Apple TV.


    I foolishly took the Apple Genius's advice, and after setting up the Apple TV, I applied the update. The exact same thing happened as with my previous unit. So, this time, instead of returning yet another unit, I applied the 5.0.2 restore process as described in this thread by adam60 (thank you!) and now the unit works fine with the old software.


    I will not even consider updating my Apple TV now until I've heard definitively from Apple that this is fixed.


    I'm also pretty surprised that the folks at the Genius Bar here in Tucson seemed to be completely unaware of this problem.


    I can hardly believe that we've still heard nothing from Apple about this. I've been using the full range of Apple products for more than a decade, and I've never experienced quite this level of crap in quality control/customer service. Obviously from these user forums, the update to 5.1 completely broke Apple TVs on quite a few folks' networks, yet nearly a month later no word has come down from Apple about any kind of fix or solution.


    I can understand the release of a severely buggy software update; that's sometimes unavoidable at this scale. But then to remain silent while users post dozens of complaints on user forums like this is just terrible customer service. Apple products are often the best in their class, but if I'm treated like this much more by Apple I might settle for a less awesome product when I'm shopping for my next gadget just to avoid this sort of treatment in the future.

  • reivajhh Level 1 Level 1

    Thanks adam60!


    I have suffered the same issues with 5.1 firmware version:


    - No youtube connection

    - Activation failure

    - etc..


    I have downgraded my ATV3 with 5.0.2 version via iTunes and now all is working fine.


    I don't understand why apple permit update ATV to 5.1.


    Thanks and regards

  • alRashedM Level 1 Level 1

    you are my HERO man, you saved me from that update really thanks

  • twdarby Level 1 Level 1

    This worked perfectly after I spent my Sunday trying to figure it out on my own.  Thanks very much!

  • KiwiAdventure Level 1 Level 1
    Apple TV

    I have been having the same problems and I'm starting get very ****** off with Apple. Both my new 2012 apple tvs does this. I've even taken both back to new a down loaded the updates again this worked for awhile but now one of the TV's does not want to connect to iTunes.. The problem is with iTunes connection. I've never had this before the update.

  • Rob2160 Level 1 Level 1

    5.1 is definately problematic.


    I have two ATV3s. One in the Living room and one in the Bedroom..


    Both have worked flawlessly on 5.02 for about 2 weeks


    Yesterday I upgraded 1 to 5.1 and experiences many of the problems you listed.. My main problem was losing access to the Movies and Music stored on my Laptop..

    The ATV on 5.02 continued to work perfectly.


    I would have to restart the laptop about every 15 minutes to make it work..


    I tried resetting, restarting the ATV on 5.1 and each time it lost access to the laptop..


    Today I reverted back to 5.02 and it is working perfectly again...


    I will hold off on updating until the next version...

  • lmd75 Level 1 Level 1

    Thanks adam60.  I tried downgrading a couple of weeks ago but Apple stopped signing 5.02 but thanks to your thread I discovered that they opened it back up.  Now everything is working as it should.

Previous 1 2 3 4 Next