Previous 1 2 3 4 Next 57 Replies Latest reply: Jun 20, 2013 10:29 AM by ChaunceyB Go to original post Branched to a new discussion.
  • easyride Level 1 (0 points)

    I got lucky after the last update everything is working again with the ethernet cable

  • Roy B Level 3 (570 points)

    Hello all,


    If you have updated to Apple TV version 5.1.1 (released on 11/29/12) and you are still experiecing the issue where some features work over WiFi but not Ethernet, please email me <> with this information:


    1. What is the manufacturer, model number and firmware version (if possible) of your Ethernet router?

    2. Which features did not work in Apple TV 5.1 but do work in 5.1.1 (if any)?

    3. Which features still do not work over Ethernet?

    4. Do all of these features work over WiFi?


    Please make the subject line of your email be "5.1.1 - Some features work over WiFi but not Ethernet".




  • ghjgjgjhgug Level 1 (0 points)

    Super!  Many thanks ATV3 works again.



  • NycK1 Level 1 (0 points)

    Extemely annoyed that I did not google AAPL TV update prior to doing it - As I have the plug into iTunes screen and the apple store has no idea what I am talking about and I asked them to just google it- and lucky me I get to go into the store in a few hours. I am not sure why I have to purchase a micro USB cord when I never needed it before to do an update- that is so shady to me. I ALSO did NOT do the update over Ethernet so I am unsure why I am having the issue as everyone that has wrote in, seemed to not do it over WIFI. I literally was JUST using my apple tv before I just hit update - no I know it is not a hardware issue. I have found USB cords in my apt but nothing that fits the Apple TV, and after reading I am not so sure that the cord is going to help...anyone out there know anything on this and willing to shed some productive light? Many thanks in advance...

  • Bob Taylor1 Level 1 (15 points)

    Update on my position. Ethernet and wifi used to work on 5.0.2 but then ethernet stopped working, wifi continued OK; unit requested Ethernet cable to be plugged in even though it was already connected. No change after usual suggestions, forced reset etc, or when updated to 5.1 and 5.1.1. Took the unit to the Genius Bar at a London Apple Store last week and they agreed to replace it. New unit updated no problem to 5.1.1 and Ethernet and wifi both now working. Can only assume from the various threads on this forum that there has been a large batch of faulty units.

  • Medova Level 1 (0 points)

    My ATV 3 simply don't show up in iTunes or in the device list... Am I missing something?


    I starts up flashing it's light for about 20 seconds and then a steady light. But iTunes 11 does not care about it.

  • NycK1 Level 1 (0 points)

    I took mine to the Apple store and the Genius bar was able to get is sorted out and even completed the update for me there. I suggest going to the Apple Store,

  • Medova Level 1 (0 points)

    No apple store in denmark Only useless and incompetent resellers

  • chadbush Level 1 (0 points)

    Since I'm the OP here, I just wanted to say that Roy B at Apple recently contacted me directly to notify me of the update to Apple TV 5.1.1, which I promptly applied and which resolved all the problems with my Apple TV. Thanks Apple! Next time it would be really great to hear from someone acknowledging a problem and offering an estimated date for repair if we're going to be waiting for months with a broken product. But I am grateful that my Apple TV now works as advertised.

  • iphone_traveller Level 1 (0 points)

    Like others, I have struggled with the both the previous 5.1 and the new 5.1.1 update. Wifi works relately well, but ethernet was knocked out.


    I do however think I have found a solution which definitely points to a software based issue.


    My solution is as follows:


    1. Restore the device using micro USB direct via Mac and do a full restore and update.

    2. Instead of allowing the network settings to go to normal instead change the DNS server to use Google's DNS generic server of - all of your other auto network settings should be fine.

    3. Setup your Apple TV as per normal entering all your details for iTunes Match etc.


    After doing the above, I seem to have no issues anymore using ethernet.


    Without doing the above, connection via ethernet is slow or simply does not work without using wifi to sort the connection out at some point. Using my DNS trick however seems to complete sort the issue out and does not require any wifi input at all.


    My take on the whole saga - seems apple has stuffed up the DNS side of things in their last two software releases and at least seems to have put my mind at rest that the last two software releases have caused no lasting hardware damage. To be honest, I was really surprised the solution above worked and hope my little trick works for others.

  • applef Level 1 (0 points)

    Thanks a lot adam60. The 5.02 is very good and apple tv works fine now.

  • ann1020 Level 1 (0 points)

    Thank you - problem solved.

  • omnibusfilms Level 1 (10 points)

    i've been using the Google DNS since day 1. So i think it was just the update 5.1.1. I have had ethernet port problems on and off after the update. usb to itunes 11 restore cleared everything up. The interface is quick and no more buffering. i was almost going to buy a new one. Guess my ole ATV2 has some life left in her.

  • Saverio_83 Level 1 (0 points)

    I downgraded my apple tv 3 to 5.02. It works when connect with ethernet but it still won't pick up my wifi. I have my mac book and iphone which connect perfectly to my wifi. Could this be a problem with my ATV3??

  • archm62 Level 1 (0 points)

    Just wanted to say that the Apple TV restore/upgrade through iTunes worked for me.  My ATV v3 never did work properly out of the box.  Could not activate, could not upgrade and would not connect to router over Wifi.  Much the same problems already described in this thread.  After the iTunes restore, my ATV now has 5.1.1 installed.  I can now see the Hulu app icon, the device has activated, the NHL app actually connects to the NHL service.

    All looks good so far.  Have not confirmed the Wifi connectivity but that will be for another day.