1 2 Previous Next 27 Replies Latest reply: Mar 19, 2013 11:50 AM by DJChad Go to original post
  • 15. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    BosseW Level 1 Level 1 (0 points)

    Hi,

     

    I can also add that software update does not work using ethernet.

     

    Bosse

  • 16. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    MagnusMo Level 1 Level 1 (0 points)

    I can confirm that this happend to me to, Apple TV Gen 3 does not work to use ethernet cable and access NBA. Please fix ASAP, the NBA season is allready here and not being able to use ethernet is not ok. Bythe way, Netflix also have a bugg that is almost the same. If you try to make a search in netflix while connected to the ethernet Apple tv Gen 3 just says "connecting to netflix", but if I use Wifi it works fine. To fix that I had to first connect to wifi, do a search and then shutdown the device, and reconnect the ethernet cable then the netflix search worked.

  • 17. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    PeterS Level 1 Level 1 (15 points)

    If you use ethernet should the Apple TV be connected to the router, or to the Mac?

  • 18. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    Tones Level 1 Level 1 (45 points)

    If you read Roy's post, he does say to EMAIL him, not post your information here.

    Roy B wrote:

     

    Hello all,

     

    It appears that this issue is related to specific network/Internet configurations. If you are experiencing this issue (some features work over WiFi but not Ethernet) after updating to Apple TV version 5.1, please send me <royb@apple.com> an email with this information:

     

    1. What is the manufacturer, model number and firmware version (if possible) of your Ethernet router?

    2. What is the manufacturer, model number and firmware version (if possible) of your WiFi router? (if it is different)

    3. What is your Internet service provider?

    4. Where are you located geographically? (what city?)

    5. What Internet features do work over Ethernet?

    6. What Internet features do not work over Ethernet?

    7. Does it read "Activation Failed" at the bottom right in Settings > General > About?

     

    Please make the subject line of your email be "Some features work over WiFi but not Ethernet".

     

    Thanks,

    Roy

  • 19. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    Roy B Level 3 Level 3 (570 points)

    Hello all,

     

    If you have updated to Apple TV version 5.1.1 (released on 11/29/12) and you are still experiecing the issue where some features work over WiFi but not Ethernet, please email me <royb@apple.com> with this information:

     

    1. What is the manufacturer, model number and firmware version (if possible) of your Ethernet router?

    2. Which features did not work in Apple TV 5.1 but do work in 5.1.1 (if any)?

    3. Which features still do not work over Ethernet?

    4. Do all of these features work over WiFi?

     

    Please make the subject line of your email be "5.1.1 - Some features work over WiFi but not Ethernet".

     

    Thanks,

    Roy

  • 20. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    DJChad Level 1 Level 1 (0 points)

    Hi Roy,

     

    I just emailed you.  Please let me know if you do not get the email.  I didnt want to post my email publically, so will describe my issue for a match.  Also my email in my User ID should also help corelate that the email was recieved. 

     

    I can stream iTunes Media downloaded to my iMac via local ethernet connection.  However if I try to stream an HD movie that is NOT iTunes, then it buffers endlessly and never starts playback.  The white buffer bar just keeps growing.  It will buffer the entire movie (10-20GB) in about 5-10 minutes but never begin playback. 

     

    Also as someone mentioned earlier, I could not update to 5.1.1 via ethernet.  I had to go wireless before it would work.  This worked for the one in my living room. I even tried the micro USB cable method via iTunes and it work would not work either. 

     

    Via wireless, it will drop on occassion, where as ethernet is more steady and reliable to not have interuption. 

     

    I forgot to add that I use an Airport Extreme with 7.2.1 firmware.  I do connect via ethernet by going from the AE to a Netgear PowerLine gigabit adapter into the power outlet.  Another Netgear Powerline Gigabit adapter is in my living room and bedroom, and connect to a gigabit switch.  I then connect to my ATV3's.  So I realize there are a few hops involved locally vs wireless it goes right to the router.  However I never had this issue prior to October  with this setup.  I have an Xbox360 that connects the same way.  I game and stream 1080p HD from their Zune store without any interuptions.  So I think it is a local networking thing with non DRM files. 

     

    Thanks for your considation with this issue. 

  • 21. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    donsylvano Level 1 Level 1 (0 points)

    Hi Roy,

     

    I sent you an e-mail, but no feedback so far... (Thomson modem, Switzerland cable provider...)

    can you please check what can I do ?


    I switch off wifi at night because of the kids, but still would like to watch NBA games...

     

    Thanks & happy new year

     

    Sylvain

  • 22. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    tinpusher35 Level 1 Level 1 (0 points)

    Same problem and email sent. NHL is back today and Game Center only works on wifi. Apple standby for a flood of complaints.

  • 23. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    Noel Versten Level 1 Level 1 (115 points)

    This may be a twist on same problem:

     

    AppleTV is wired. 

    Airplay from MacBook Pro (OS10.8.2) does not work when MBP connected to ethernet.

    Airplay does work when MBP is connected to WiFi.

     

    Router: Asus RT-N66U "Dark Knight"

    Router Firmware Version:3.0.0.4.220

     

     

    I believe all features were working (with 5.1.1) OK until I got this new router. 

    Previous router was Netgear WNDR3700

     

    Will email Roy directly as well.

  • 24. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    micromanage Level 1 Level 1 (0 points)

    I am having the same issues since the last update. No ethernet capabilities but ATV works great using my Wifi network. A new twist is my universal remote no longer controls my ATV. I am sick of these kind of things happening with my Apple TV. It should not have issues each and every time an update is installed.

  • 25. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    DJChad Level 1 Level 1 (0 points)

    No response from email sent a month ago, so I'm sticking to the forum.  Sorry.

     

    Updated to 5.2, my AppleTV in bedroom that would stream over wifi and Ethernet using 5.1 would NOT work at all via WiFi.  It would connect to APE and could see library, iTunes stores, Netflix, but nothing would work.  Connected to Ethernet via power line and everything streams perfectly.

     

    Updated to from 5.1.1 to 5.2 in living room.  It will connect and work fine via Ethernet or Wifi.  However HD 1080p movies that did not come for iTunes and are not DRM will not start playback via Ethernet.  But work fine over WiFi.  Via Ethernet I can see the movie buffer several minutes ahead and playback never starts.  I can see half the amount buffer on WiFi and it starts nearly immediately. 

     

    I know ATV3 is still only 10/100 Ethernet vs 300mps WiFi, but given the buffer ping on Ethernet is more than sufficient I don't see it as a speed issue.  I have allowed 50% of the movie buffer in 3 minutes and it still didn't start.  They are full length movies.  So this is odd.

  • 26. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    69anywayup69 Level 1 Level 1 (0 points)

    Hi had the same problem as this on my apple tv in the conservatory which was connected via a wired connection, my other apple tv in the sitting room is connected by Wi-Fi and updated this one no problem but could not update the one in the conservatory, then connected it via the Wi-Fi network and updated the unit with no problems.

  • 27. Re: Ethernet connected Apple TV 3 can’t play content.  WiFi works fine.  What gives?
    DJChad Level 1 Level 1 (0 points)

    All,

     

    I finally discovered my problems for both living room and bedroom and thought I would circle back and share:

     

    Living Room - I was using a powerline that must have had issues.  I switched back to my ethernet line and this Apple TV would work with both Wireless and Wired connections, all content.

     

    Bed Room - I took ATV in and got replacement.  Works great at first but then wireless started not allowing playback to begin, even though I could see the movie buffering ahead.  So hard to believe 2 ATVs in row would have same issue.  I then switched the ATVs between bedroom and living room.  The one in the Living Room that worked fine in the living room but not in bedroom.  THe one in bedroom wouldn't stream in bedroom over WiFi, but fine in the living room.  So it dawned on me.  I have to have some sort of wireless interference in my bedroom.  The signal was full bars and the network test would pass every time. 

     

    I have a Samsung sound bar with wireless sub.  It operates on a 2.4 and 5.9 frequency.  I decided to turn off the sound bar when the movie would buffer but no playback would start.  As soon as the Soundbar turned off, the playback started on the ATV.  I would let it play for a while and turn the SoundBar on.  The ATV would keep playing until it reached the end of the buffered movie.  Then it would stop and start the endless circle.  My soundbar connects to from my Samsung TV using optical.  So its HDMI to Samsung TV, and then Optical to soundbar. 

     

    I discovered this at about 2am last night (I am dragging at work today, BTW).  BUt it was driving me nuts to figure out what the issue was.  I tried setting up a 5ghz network and connecting to it.  Still had the issue.  I may need to try a diff frequency on my router for this band.  The Samsung is suppose to automatically change frequencies to avoid conflicts.  But apparently not in this case.  i still have a ways to go and find the true root cause.  It could be the wireless, it could be the optical/codec connection for the audio, or maybe even the older HDMI cable I am using.  But I have established it is NOT the ATV itself.  The ATV works great in any other room.

     

    What is even more bizzaro is Netflix and Hulu stream just fine.  Its only when I try to do specific movies from iTunes on my iMac or my iTunes in the Cloud. LIke I said, a ways to go.  But I wanted to bring this to everyone's attention who may be at the end of their rope and maybe was too focused on the ATV, Network, and IMac setup to consider it was another component in their setup! 

     

    I will report back if I find a final root cause/solution. But I hope this helps you get on the path. 

    Chad

1 2 Previous Next