Previous 1 2 Next 18 Replies Latest reply: Oct 10, 2012 4:38 PM by cwalkerb
FailedOdyssey Level 1 Level 1 (0 points)

This one is baffling me. So I have a wireless network set up in my apartment using a Netgear router. I've had it up and running for months without any problems. As of last night, my Macbook Pro has been unable to connect to it. It can recognize it along with all the other networks in the area but when I try to join it and enter my password, it says the password is invalid. Before, I never even had to enter a password other than the time I set it up. My xbox, ipod, etc. can still connect to the network just fine using the same password. I switched to Windows on my Macbook and was still able to connect on that side, and I could see that my password was still the same as I remembered. For whatever reason, I cannot connect to the router from the Mac side, even with the correct password, without it telling me the password is invalid and kicking me out. I've tried resetting the router, resetting the computer multiple times, changing the network's name and password, and everything else I can think of. I'm all out of ideas. Any thoughts? Thank you!

MacBook Pro (15-inch Mid 2010), Mac OS X (10.6.8)
Previous 1 2 Next