Previous 1 2 3 Next 44 Replies Latest reply: Nov 30, 2013 11:09 AM by shape Go to original post Branched to a new discussion.
  • cfrancica Level 1 (0 points)

    Thanks for the tip. Unfortunately it doesn't seem to change the behavior for me (it is still not prompting or saving credentials for the sites I am testing). Thanks though..

  • cabavyras Level 1 (5 points)

    Make sure you've restarted your phone.

  • Cartoonipad Level 1 (0 points)

    > Delete your contact info from contacts and then add a new contact with the original

    > info. This worked for me.


    Big thanks to Ghesse!  It worked for me too. Also glad that this problem inspired me to find the Roboform app - which I now appreciate after figuring out to set up "identities".

  • Cyberian Level 1 (0 points)

    I just came on the forums trying to solve this issue and while I was trying to read all the different posts on this issue I relaized I had "private browsing" turned on. I turned it off and now everything works like it is supposed to. Hope this works for everyone else.

  • cfrancica Level 1 (0 points)

    Restarted and although it seems to prompt me to save credential for some websites, it doesn't for others still. I wonder if it may be related to sites with self-signed SSL certificates.


    Some progress, but unfortunately, the #1 issue for me is it not saving the credentials for wifi hotspots that have a captive portal page, so I'm still on the hunt for a fix for that. I've tried disabling auto-login and manually opening the portal page and logging in, but that doesn't prompt me to save the credentials as it did in IOS5.


    Thanks again.

  • cabavyras Level 1 (5 points)

    Try this, if haven't already. Go to General > Reset >Reset All Setting. Then Try step by step, one change only at the time. Firstly assign (in Safari) some totally different contact with proper details. Once this is done. Try to go and enable AutoFill. See if it works. Restart Phone. Recheck if it works. If not, then do the rest steps for enabling AutoFill.


    IMPORTANT, once you reset all settings, it's not a disaster, but a little inconvenience to putting them back in, small things done in 3 minutes.

  • S3L1N4 Level 1 (0 points)

    Thank you so much for this post!  I have been struggling with this for a while now (since iOS 6 update) and nothing seemed to work.  Followed your instructions and everything is back in order again! (Not sure if I tried turning off Privacy Settings before, but I didn't turn it on this time.) Anyway, thank you for the help!

  • judygr Level 1 (15 points)

    After trying everything suggetsed I used the suggestion in the link provided by cabavyras here .  After reading through that, I turned off autofill and turned on AutoCorrect.  I  then turned Autofill back on and it seems to be working just fine as in previous versions.  But here's the best thing and I didn't see this mentioned, I was then able to turn AutoCorrect back off and Autofill still works.  There seem to be series of things that may toggle Autofill off and then on.  If you have AutoCorrect off, try turning it on temporarily to get your AutoFill back on.  It seems like different combinations of steps are working, depending on how you have your iPhone set up.  I did not need to reboot, reset, or restore to get mine fixed.  Just a few seconds to turn Autofill and Autocorrect on and off.

  • cabavyras Level 1 (5 points)

    I can guarantee you that once you close (in multitask bar) Safari, you won't be able to use AutoFill once Auto-Corrention is turned off. In your case turning Auto-Correction off didn't effect Safari at a time, but once you properly quit Safari, setting take in effect. Say that I'm wrong


    P.S. I've been tinkering (that's how I found this solution) with this bug for some time (I'm sexy) and I know it .

  • judygr Level 1 (15 points)

    Oh're absolutely right. What's even worse, once I closed Safari off of the multitask bar, I can't even replicate it.  For now, autofill will only work when AutoComplete is on.  Looks like I'll have to be doing some toggling on and off until a better solution is found.  I frequently use autofill and I really dislike autocomplete. 

  • gmeroz Level 1 (0 points)

    You can try the excellent TapIN iPad app. It will autofill all those fields and will also auto click buttons.

  • Will-H Level 1 (0 points)

    Turning off Private Browsing in Safari settings on iPhone 4S iOS6 fixed the issue for me without a reset or reboot, now webpages in Safari ask me if I want to save my name and password and autofills. I have Auto Correction turned OFF and it still works fine. Hope this helps.

  • jellero Level 1 (0 points)

    iPad mini- how can I turn off auto fill??? I am typing one letter at a time or spend the day redoing everything if I miss a letter. Please! That took me 22 minutes to type...

  • mimi33706 Level 1 (0 points)

    To activate auto-fill using OS 10.8.5. you must click auto-fill from your Safari toolbar:




    Customize Toolbar

    Drag your auto-fill icon onto your Safari toolbar

    click DONE



    To activate auto-fill click it from your Safari

    toolbar--it works!!!

    If your HOME icon has disappeared you can recover it using the same process.

  • shape Level 1 (5 points)

    i've had private browsing off, auto-correction on, and when i enabled autofill and selected on for each option, password autofill still does not work.  the button for autofill is disabled when selecting the password field and no pop ups ever come up to ask me whether i want to save the pw for that site, as it shows here:

Previous 1 2 3 Next