1 2 3 4 Previous Next 51 Replies Latest reply: Jul 2, 2014 8:06 PM by MenesesInc
portdawg66 Level 1 Level 1 (0 points)

My trackpad seems to have a mind of it's own.  When I move the cursor around the screen, the trackpad selects as though it is being pressed.  When I open a pull-down window, the trackpad selects items without being pressed.  I've bumped the PRAM and accomplished an SMC reset.  Niether action has had an effect.  Has anyone else had this issue?  How did you clear it up?


Magic Trackpad, OS X Mountain Lion (10.8.2)
  • 2. Re: Magic Trackpad has a mind of it's own!
    portdawg66 Level 1 Level 1 (0 points)

    Sorry John, this is a no-go!  I've done everything recommended, to include wiping it clean with a little glass cleaner.  To no avail... the problem persists.  I love using the trackpad, but this is just plain annoying!

  • 3. Re: Magic Trackpad has a mind of it's own!
    John Galt Level 8 Level 8 (36,365 points)

    In that case I would take it to an Apple Store for evaluation. Perhaps it is simply defective.

  • 4. Re: Magic Trackpad has a mind of it's own!
    ZlSmith Level 1 Level 1 (0 points)

    I am having the same problem.  I tried everything and I am still having a problem. I reset the PRAM, SMC, ran the Periodic Routine Scripts and also repaired permissions.  I am pretty sure it is a software issue since it doesn't happen all the time.  It started acting up after I installed some new software. 

     

    Ok, I know it must be a software issue.  If I go up to the top menu, and select discount from the bluetooth it will reconnect itself, some times right away, other times 3 - 5 min later.  I also installed MagicPrefs so I could see if it was the trackpad picking up phantom touches but nothing. 

  • 5. Re: Magic Trackpad has a mind of it's own!
    SJRNET Level 1 Level 1 (10 points)

    I have exactly the same problem with my trackpad performing random clicks and right-clicks all the time!

     

    When composing an email, for instance, the trackpad keeps moving the insert point while I am typing - it is driving me mad...

     

    I have now had to take the batteries out of my trackpad to stop it interfering with my work.

     

    FIX THIS QUICKLY APPLE!

     

     

  • 6. Re: Magic Trackpad has a mind of it's own!
    SJRNET Level 1 Level 1 (10 points)

    I should add that this has only been happening since upgrading to OSX 10.8.2

     

    The defect happens even when you are not near the trackpad - try hovering over a window's close button then just walk away... within seconds, the trackpad has clicked the close button and the window is closed!

     

    Trackpad is also randomly selecting areas of the screen and performing random right-clicks, popping up contextual menus etc

     

    Must be a flaw in OSX 10.8.2 because, up to that point, my Retina MBP has performed faultlessly...

  • 7. Re: Magic Trackpad has a mind of it's own!
    SJRNET Level 1 Level 1 (10 points)

    Here's what fixed it for me

     

    Move the following folders to your desktop (for safe keeping) and reboot:

     

    /Library/LaunchAgents

    /Library/LaunchDaemons

     

    (note, these are the root library folders, not your personal ones)

     

    I don't know why this fixes the post-10.8.2 trackpad defects, but it works!

     

    You may wish to examine the contents of the two folders and selectively put them back, one at a time, rebooting each time until you find which item is causing the problem.

     

    Once you are happy again, you can delete the folders from your desktop.

     

    Cheers,

     

    Steve

  • 8. Re: Magic Trackpad has a mind of it's own!
    SJRNET Level 1 Level 1 (10 points)

    OK... spoke too soon

     

    Problem went away for a while but is back now with a vengeance - Magic Trackpoad is virtually unusable with its random clicking and right-clicking all over the place.

     

    Have taken out the batteries and placed it in my drawer until someone at Apple fixes this bug.

     

    Lots of people having this issue, so should warrant a point release soon...

  • 9. Re: Magic Trackpad has a mind of it's own!
    SJRNET Level 1 Level 1 (10 points)

    If you are running any apps full-screen... don't!

     

    I was running Parallels and iTunes in full-screen, and as soon as I changed them to windowed mode, the trackpad problem went away.

     

    Don't know why, but they are definitely related!

  • 10. Re: Magic Trackpad has a mind of it's own!
    Pyrgos Level 1 Level 1 (0 points)

    The Magic Trackpad really behaves somewhat peculiar: In my case, and used with MS Word, there is a somewhat peculiar "delay" in the response! When I, for example, activate a word with the trackpad. and then delete it by pressing the delete-buttom (back-step) on the keyboard, I have to press the buttom twise before anything happens! Sometimes moving the cursor to another place in the text will cause the same problem, e.g. the new text written, will suddenly appear in the wrong place!

     

    N.B: This does not happen whern using the Magic mouse or the Mighty mouse! (I use either of them when charging the batteries in the Trackpad).

     

    I have had this problem all from the beginning. I got my iMac 21,5!" (i7 processor) in september 2011, and it is continually uppdated. I have hoped the new updates or the new system (10.8) would cure the problem, bu it is still there!

     

    I can live with it, though, even if it is al little bit annoying!

  • 11. Re: Magic Trackpad has a mind of it's own!
    Pyrgos Level 1 Level 1 (0 points)

    Still a comment: The problem seems to be that the system responds somewhat slow to commands from the trackpad. And the problem appears espscially after writing longer texts. The computer is i a way "suprised" when it is reseivin commands from the trackpad after having worked with the keyboard for a time!

     

    But as I said earlier: This problem does not occur with the Magic Mouse ocr the (USB) Mighty mouse.

  • 12. Re: Magic Trackpad has a mind of it's own!
    piratecapn Level 1 Level 1 (0 points)

    I've got this same issue as well.  Brand new macbook pro.  Worked fine when I first got it.  Updated OS a few days later and issue has popped up since.  Happening almost all the time now.

     

    Went into the trackpad settings and unchecked all the options.  Also plugged in a mouse, but even when using a mouse I have these problems.  Multiple locations, surfaces, etc., makes no difference.

     

    My mouse pointer will jerk around, slide in place, scroll to a different screen, and sometimes activate a click.  Really frustrating.

  • 13. Re: Magic Trackpad has a mind of it's own!
    John Galt Level 8 Level 8 (36,365 points)

    Please post a brand new question with this topic.

     

    The original post is dated and "me too" questions are not likely to elicit solutions.

     

    piratecapn wrote:

     

    ... Brand new macbook pro. 

     

    If your Mac is new you should not expend a ounce of effort in fixing such problems. Bring it to Apple, which is the same suggestion I made to the OP.

  • 14. Re: Magic Trackpad has a mind of it's own!
    Fabio Pimenta Level 1 Level 1 (0 points)

    Same Problem Here, got a Macbook Retina 15", using since 03 months and just today this strange and mad problem began!

     

    Need a Solution ASAP

1 2 3 4 Previous Next