0 Replies Latest reply: Oct 3, 2012 8:23 AM by Victoria Chamberlin
Victoria Chamberlin Level 1 Level 1 (0 points)

I am sure it will work if I can upgrade, but I can't even do that.  Any suggestions?

Thanks!


iMac, Mac OS X (10.6.8)