Previous 1 2 3 4 Next 49 Replies Latest reply: Jan 27, 2016 5:21 AM by kimindex
postnocomments Level 1 Level 1

I have a MacBook Air where I don't keep any tracks locally, but access them through iTunes Match. For no reason, one day I find all tracks grayed out and I was unable to play them. I turned off iTunes Match and the tracks were all gone. When I turned iTunes Match back on again, the tracks never showed up. When I click on update iTunes Match it does nothing. I have other devices where I can access the tracks stored in iTunes Match without a problem. How do I fix this?

MacBook Air (13-INCH, MID 2011), OS X Mountain Lion (10.8.2), iTunes 10
Reply by Winseck on Oct 26, 2012 11:58 AM Helpful

I had the same problem.  Tried this solution and it worked perfectly.



All replies

  • mracole Level 4 Level 4

    Sounds like a local corruption to the MacBook Air - an easy route would be to uninstall iTunes.  Restart from cold and install the latest version - on signing into the iTunes Store and starting iTunes Match normal service should return, assuming good communications.

  • Narvon Level 1 Level 1

    Try signing out your Apple ID and sign in agian.


    Go to the iTunes store in iTunes

    Select your Apple ID in top right

    When the popup opens, don't put in Password, just Sign Out

    Go to the top right again in iTunes Store and it should say Sign In (where your ID was before)

    Select Sign In and Sign In on the popup

    On the left hand side you should see iCloud

    Select iCloud and Link Computer

    When this is complete, your music should be available for streaming again


    Try this before deleting and reinstalling iTunes first. Let us know if this works



  • Winseck Level 1 Level 1

    I had the same problem.  Tried this solution and it worked perfectly.



  • sotirios35 Level 1 Level 1

    I am having this problem under Mountain Lion and iTunes 10.7 (2.1). Signing out and then back in does not solve it. I called Applecare and channeled my support request to iTunes Store Support. They responded that this is 'an issue that is affecting several users' and that although the root cause is not clear, 'it seems to be a server-related issue'. I guess we have to wait.


    Probably related to this, though I can't be sure, my iPhone4S (iOS6) does not sync to iTunes Match anymore. I am getting a progress bar when turning on Match, which stalls and fails to deliver Match results.

  • fjoyner Level 1 Level 1

    I'm stuck in the middle of all this as well.  Currently I am very much underwhelmed by iTunes Match and iCloud in general.  All my music has long since been synced and uploaded, etc.  On this new HD on an iMac, it has synced (there were NO songs on the HD) and shows all my music, but it only occasionally lets me access it.  The rest of the time it is grayed out.  This is unacceptable.  I have already tried all manner of uninstall and turning off and on of both Genius and iTunes Match to no avail whatever.  If there is a problem, they should say so and not leave us swinging in the breeze.  Error 4002, yeah, whatever......NOT happy.

  • sphere777 Level 1 Level 1

    As happens sometimes with Apple problems, there may be more than one solution to your problem. I found out how to resolve the greyed-out songs in my iTunes, so this approach *may* solve your problem. Thus I must add this warning. Please read it before proceeding.


    WARNING: This solution worked for me. It may not work for you. Read carefully to determine if my solution will fix your problem. There may be more than one reason for a "greyed-out song." Applying my solution could fix your problem if we both have the same cause for this problem.


    Keeping this warning in mind, I will proceed.


    When checking my iTunes folders, I noticed that all the greyed-out songs in my iTunes UI had two copies in two different places.


    iTunes>ITunes Media>Music>....




    iTunes>iTunes Music>....


    Evidently this was an irresolvable conflict for iTunes. My solution was to select all the music in the second location (iTunes>iTunes Music>....), copy all the folders into the first location (iTunes>ITunes Media>Music>....) then delete all the music in the second location.


    Then I signed out of iTunes and signed back in, then activated iTunes Match again. The greyed-out songs were gone.


    Again, this MAY not work for you for any number of reasons and I cannot promise that it will work for you. When it comes to fixing this, let the user beware.


    Message was edited by: sphere777


    Message was edited by: sphere777

  • seanneal Level 1 Level 1

    Yep, signing out and back again worked for me.

    Although iMatch seems to have lost the 280 tracks that were previously uploaded from my iMac and has decided to upload them again?



  • svcoder Level 1 Level 1

    I'm in complete agreement with fjoyner. I just bought a new Macbook Pro. There is no music stored locally on this machine. An hour ago I was playing music as I was able to access all 1500+ songs in the cloud. I paused, got up to make a sandwich, and when I returned, all the songs were greyed out. I signed off and back on as suggested and now there are no songs listed at all. Tried updating iTunes Match and still nothing. Please fix Apple.

  • seecoolguy Level 1 Level 1

    I'm on 10.8.2 with the new iTunes 11 and signing out and signing back in fixed the grayed out songs..

  • fjoyner Level 1 Level 1

    Among the -many- things I've already tried that didn't work for me.  Happy for you.  Me.....not so much.

  • BooBoo71 Level 1 Level 1

    Didn't help me either.  I am at wits end and Apple won't help.  What's up with that?

  • ajlewis1851 Level 1 Level 1

    You guys might try this fix. It worked for me in iTunes 10.8 and 11 on two seperate computers with similar issues in iTunes Match.


    1) First turn off iTunes Match


    2) Next Deauthorize your computer from itunes in the Store drop menu


    3) Fully shut down iTunes and start it back up.


    4) Authorize Your Computer from itunes in the Store drop menu


    5) Turn on itunes Match and then select add computer when it appears


    6) When it shows as Done, click Done and you should see the cloud icon loading in the upper left next to Music


    7) Go grab a drink and come back to a hopefully fixed itunes experience.


    Please let me know if this helped so I can share with other threads!

  • BooBoo71 Level 1 Level 1

    Thanks, but this did not fix my problem.  I am still very frustrated.

  • kriepl Level 1 Level 1

    aj, this worked for me after trying MANY suggested solutions. I am in iTunes 11 btw.

    Thanks you!!!



Previous 1 2 3 4 Next