Previous 1 2 3 4 5 Next 72 Replies Latest reply: Jun 19, 2014 1:52 PM by Tigra1000 Go to original post Branched to a new discussion.
  • ishakir Level 1 (0 points)

    I'm in touch with apple support since iOS6 release on this issue and the incompetent apple was not able to resolve this  issue  I spent 50$ on phone call calling the these people no resolution yet.

  • Class37 Level 1 (0 points)

    Thank you T. This worked a treat

  • Sandgrown66 Level 1 (0 points)

    Thank you. This worked for me too. Since the update it was saying I was saying I was in the US but I am UK based.

  • Reddcurlz Level 1 (0 points)

    Thanks T.

     

    From Canada and all I did was update to ios 6.1 and the glitch occurred.  Your simple solution solved the problem.

     

    V

  • MacFifer Level 1 (0 points)

    Dear Hunaidi,

     

    Thank you very much for the advice.

     

    Yours faithfully,

     

    Stuart MacLean

  • DocWang Level 1 (0 points)

    I had the same problem after upgrading my iPhone with OS 6.1.  Your instruction help resolved that!

    Thank you.

  • Daraab Level 1 (0 points)

    Even i have been going through this problem and none of the solutions above work.

  • eggar Level 1 (0 points)

    worked like a charm! thank you, T Yahiaoui

  • chloe24_1 Level 1 (0 points)

    yes!!!!!many thanks

    Veronika

  • fiatuno49 Level 1 (0 points)

    Currently Being Moderated
     

    Re: Account Not In This Store (iOS6)

    Oct 5, 2012 10:14 PM (in response to Hunaidi)

     

    @ Hunaidi

     

    I have suggested the following steps to somebody else and it seems to have worked for a number of people including myself:

     

    - go into 'Settings'

    - go into 'iTunes & App Stores' (scroll down until you reach it)

    - click on 'Apple ID:....' (at the top)

    - click on 'View Apple ID' (it'll ask you to key in your Apple ID password)

    - enter your Apple ID password

    - leave the 'Settings' menu

     

    Hope this works for you.

     

    T

     

     

     

     

    IF YOU FOLLOW THESE STEPS IT SHOULD WORK......at least it did for me

     

    Thanks to T Yahiaoui

  • dianayp Level 1 (0 points)

    I've had the same problem in my iPad and the Settings > iTunes & AppStore and the AppStore > Feature tab thing didn't work either. I was stuck in the us store and wanted to use my brazilian account, so i signed out from the ipad Settings, and searched for an app from the br appstore in Safari. When i tried to download it, Safari redirected my request to the AppStore application, I had, of course, to log in to proceed on installing the app, and it worked perfectly!

    hope it helps!

  • kurekaoru Level 1 (0 points)

    Hope this helps..

     

    I had this problem when I switched to China to download something and tried to switch back to HK.

     

    There seems to be a bug with the switching mechanism on iOS6, so while none of the online solutions worked, I tried doing the switch on PC (iTunes) and that worked like a charm

  • gregkar Level 1 (0 points)

    Thank you! Thank you! Thank you!

  • JBoen Level 1 (0 points)

    Hi, for those saying those methods didnt solve your problem, you may try this.

     

    Im living in Indonesia, but want to change App Store to Singapore region because i need google maps on my iphone which isnt available on Indonesia region app store, so this is what i have done:

    Tried changing iTunes account info on my iPhone 5 (6.1.2), it couldnt be done even with those methods unless you did changing from your mac.

    So,

     

    First i changed itunes account information from my mac, and tried downloading Google maps.

    It will ask to enter 3 secret question and answer, but it says unavailable in the end, ignore it.

    Now you should see iTunes downloading Google Maps, then i sync my iPhone with my mac. Google Map appeared on my iPhone. I went to Settings>iTunes and app store> view Apple ID> Sign out> Sign in.

    Delete an app (Hay Day) that i have downloaded through Indonesia region app store, and downloaded it back from Singapore app store. Mission accomplished. This case has been driving me crazy for whole day!

     

    Good luck!

  • Zak77 Level 1 (0 points)

    Thanks T, I am from the UK based in Kuwait on a temporary basis with my job and was having the same problem. This has worked.