2 Replies Latest reply: Oct 4, 2012 11:36 PM by markwmsn
AngieJ64 Level 1 Level 1 (0 points)

I am trying to sync a new iPhone 5.  I updated iTunes as requested and now a message stating I need Mac OS X version 10.6.8 or later.  I can't seem to download that.  Any ideas what I need to do?


iPhone 5