6 Replies Latest reply: Mar 24, 2015 6:06 AM by hattrickmac
rambinca Level 1 (0 points)

After upgrading to iOS6, I can no longer send or receive MMS messages. From what I have read on the internet, this problem is due to the APN settings on my phone. I'm trying to change them using the iPhone Configuration Utility, but my phone says only one APN can be installed at a time. How can I remove the default APN settings? How can I install profile with new APN settings? Is Apple or AT&T going to fix this problem that they deny exists?

iPhone 4, iOS 6, No MMS after iOS6 upgrade
  • alex_vldr Level 1 (0 points)

    After googling and seeing lots of info, I figured out how to get Internet on your Iphone 5 back.

    I was also trying with iPhone Configuration utility, but the phone didn't allow me to install the new profile as I already have certificate with APN settings.


    I have an issue with my previous mobile operator KPN (Netherlands). APN settings of KPN ovewrite the data of all sim cards I use. And I need always manually to edit it. With my current operator T-Mobile, I can't edit APN settings as these settings are hidden.


    This solution will leave you with all your data. Very easy one!!!


    1) Use other sim card, where operator allows to edit APN settings.

    2) Navigate to Settings - General - Mobile data - Mobile data network- Here you can edit APN, MMS, etc...

    3) At this point do not navigate out of this menu and eject the alternative sim.

    4) Insert your sim card.

    5) Edit all settings you need. Make sure they are correct. Lots of info on google.


    For me it worked fine. Although I expect till the next time I change sim. You might try to do it several times as Mobile data network menu can be hidden when you install your sim card.

  • ChrisJ4203 Level 8 (44,800 points)

    AT&T will not allow you to make APN changes. They are set with the carrier file. Make sure that MMS is turned on and that iMessage is activated. If there is not change after resetting the phone, contact AT&T and have them check your account to make sure everything is okay on their end. I have a 4S with AT&T and have not experienced any issues with SMS, MMS or iMessage. I believe the reset or the call to AT&T should rectify your problem.

  • rambinca Level 1 (0 points)

    Appears the fix for my phone was a factory reset and then turning off mms, restarting phone, and then turning mms back on. Seemed to work until I tried to restore my phone to a backup and then problem reappeared. Looks like I will have to do another factory restore to get my mms working again.

  • Southerng Level 1 (0 points)

    I had the same problem. I caused it when I originally added a fake APN so that I would not get random downloads from the internet on my first gen iphone.  ( It did not have the feature at the time to force all data traffic over wi-fi.)  I have since recieved an iPhone 4 which worked perfectly (internet, text, MMS, etc..).  I restored it using the profile which I neutered.  The result was that I had no internet connection and iMessages has been delaying messages upward of a day.  I can no longer go in and switch the fake APN off as that feature has been suppressed by AT&T. Going back to www.unlockit.co.nz and changing the APN did not work, because it detected the existing APN and could not write over it or remove it.  Using the Apple Configuration Utility had similar limitations.   The only way to get around this is to wipe the iPhone clean, add software and wi-fi passwords back manually and avoid restoring from the old back-ups.   Oh well such is life.

  • antonl.anton Level 1 (0 points)

    There is a solution that does not involve jailbraking the phone or using SSH, or anything shady, to remove the hidden fakeAPN and restore it to factory settings in a selective way without losing any data, messages, etc. I found this solution while searching yesterday & used it, after countless hours with the clueless tech reps at both AT&T and Apple and two months of relying only on wifi.

    Problem: my situation is like others here and other fora: I used the fake APN profile mounted by a site called unlockit.co.nz in 2009-2010 to block cellular data in my 3G used without data plan but still locked to AT&T. I upgraded iOSs versions until 4.x.x (whatever was the latest allowed on a 3G). I upgraded straight to iphone 5s about 2 months ago, set up a data plan and could never use it no matter what, unless I restored the phone to factory settings. Obviously I did not want to restore and lose years of text messages so I was essentially stuck to wifi for all functions other than phone or regular text messaging.

    A warning: I tried too many solutions to describe here, including fumbling with the famous 3d0d7e5fb2ce288813306e4d4636395e047a3d28 file, which does contain the messages but cannot be transferred to a different backup, at least not in iOS7. I also tried to change the APN to a new one via unlockit.co.nz to no avail. Don’t waste your time, if you have a recent phone on iOS7.x.x and you have this problem none of this works.

    THE SOLUTION: I downloaded the free application iBackupBot and used the search function to open two files called managedCarrier.plist, not in the phone but in the latest backup file stored in my computer that still contained all the data I wanted to save. I could then see the old and now hidden fakeAPN file still there since 2009, so I just edited that file following the exact directions in a MacRumors forum posted by user caliwolv: http://forums.macrumors.com/showthread.php?p=15828306#post15828306

    I suggest you read his directions, they are simple and brief. Essentially restore the file to its original settings, where (according to the poster) it can get the APN information directly from Apple:


    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

    <plist version="1.0">



    Then I restored the phone from the edited backup file and ***everything*** worked as it should and I had all my data! I will not post details on accessing the backup file on the assumption that you already know but, if not, post here and I will add more info. Good luck to all.